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1 Introduction 

This tutorial aims to help you understand and use PTC’s Model-based Systems 
Engineering (MBSE) solution for the first time.  It introduced the main topics and then 
provides a step-by-step, hands-on guide to MBSE, using PTC’s software tools and best 
practices. 

You may already be an expert systems engineer with experience in SysML and MBSE or 
these may be new and unfamiliar terms, so let’s start with some basic definitions.  
Systems Engineering is the interdisciplinary field of engineering that focuses on how to 
design, produce and manage complex systems over their life cycles. This includes 
disciplines such as requirements engineering, reliability, logistics, evaluation, testing, 
maintenance, plus the collaboration of these different teams and many more.  
Cooperation between all of these domains is necessary for the successful system design, 
development, implementation and eventually decommission, all of which become even 
more difficult when dealing with large or complex systems. Systems engineering also 
considers the processes, their optimization and the risk involved in such complex 
engineering projects. Systems engineering ensures that all likely aspects of a project or 
system are considered, and integrated into a whole. 

Then, model-based systems engineering is a Systems Engineering approach that focuses 
on creating and exploiting domain models as the primary means of information sharing 
between engineers, rather than document-based information exchange.  MBSE was 
popularized by INCOSE (International Council for Systems Engineering) when it started 
its MBSE Initiative in 2006.  The original goals included increasing productivity, by 
minimizing unnecessary manual transcription of concepts when coordinating the work 
of large teams.  Then in conjunction with the Object Management Group (OMG) and its 
members, INCOSE defined and published a specification for a systems modeling 
language, called SysML, in 2007.  This led to SysML implementations in a number of 
modeling tools, such as PTC Integrity Modeler, and widespread adoption within the 
systems engineering community. 

The OMG’s SysML provides a common language for Systems Engineering, improving 
stakeholder communication and buy-in.  It is a general-purpose graphical modeling 
language for specifying, analyzing, designing, and verifying complex systems that may 
include hardware, software, information, personnel, procedures, and facilities.  In 
particular, the language provides graphical representations with a semantic foundation 
for modeling system requirements, behavior, structure, and parametrics.  It is also 
intended to be integrated with other engineering analysis models. 

As a result, SysML enables traceability from requirements to features and parts, whole 
system visualization and linking to reduce complexity, and design alternative exploration 
with tangible tradeoff analysis. It also delivers problem identification during design, 
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when they are less expensive to fix, and optimal function allocation to engineering 
disciplines. 

Independent research shows that MBSE can reduce your development effort and costs 
by 55% and improve you delivery times by 5%, when compared to non-model-based 
systems engineering approaches.  In fact, MBSE has become so prevalent since 2007 
that all contemporary and agile Systems Engineering defaults to Model-based. 

In addition to this basic introduction to MBSE, this tutorial will also cover PTC’s 
approaches to asset-based modular system design and model-based product line 
engineering.  These additional and optional approaches can provide even more MBSE 
business benefits and form part of the PTC Integrity™ Process Perspective™ approach. 

The Asset-based Modular Design section introduces the concepts of another OMG 
standard, the Reusable Asset Specification, and the OASIS Open Services for Lifecycle 
Collaboration (OSLC) Asset Specification.  This section also shows how PTC Integrity 
Asset Library can extend PTC Integrity Modeler to enable widely distributed parallel 
design, system of system modular design and design-time reuse. 

Finally, this tutorial takes you through PTC’s Model-based Product Line Engineering, with 
examples of PTC Integrity Modeler’s variability modeling, feature selection and product 
model generation.  These facilities help you deliver systems that are quickly tailored to 
your specific customer’s needs or a target market, while increasing reuse even further. 

1.1 Purpose 

The primary aims of this tutorial are to introduce the PTC Integrity Process Perspective 
MBSE best practices, show how PTC implements SysML, MBSE and MBPLE.  It also 
provides practical guidance in using PTC’s MBSE solution, including PTC Integrity 
Modeler and its add-ons. To do this the tutorial specifies certain activities that you 
should carry out using PTC products, with examples that are installed with the products 
or are downloadable from the PTC website (www.ptc.com).  

1.2 Assumptions 

This tutorial is not intended to teach the detailed principles, concepts and notation of 
MBSE, PTC Integrity Process Perspective and SysML to a level at which a beginner could 
become a practicing model-based systems engineer.  It will walk through the primary 
product features and give you a good introduction.  Then, we recommend that you 
follow the use of this tutorial with high quality training from PTC University, PTC Global 
Services or one of PTC’s accredited training partners, and then gain practical experience. 

In order to apply the hands-on activities defined in this tutorial you will need access to a 
licensed copy of PTC Integrity Modeler and the add-ons in which you are interested. 

http://www.ptc.com/
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1.3 Structure 

The structure of this tutorial is based on the structure of the PTC Integrity Process 
Perspective. 

 

(more details on the PTC Integrity Process Perspective approach can be found at www.ptc.com)  

Model Based Systems & Software Engineering 

• Visual modeling for systems design, review, simulation and trade study analysis 
• SysML and MBSE practices using PTC Integrity Modeler 
• Based on ISO15288 and PTC best practice experience 

 

Asset Based Modular Design 

• System of systems (SoS) design and supply chains 
• Sub-system and component publication, and reuse 
• OMG Reusable Asset Specification (RAS) practices using PTC Integrity Asset 

Library and PTC Integrity Modeler 
• Based on ISO 26550 and PTC best practice experience 

 

Product Line Engineering 

• Model-based Product Line Engineering (MBPLE) 
• Orthogonal Variability Modeling (OVM) practices using PTC Integrity Modeler’s 

Variant Modeling, Variant Selection and Product Model Creation 
• Based on ISO 15288, 26550 and PTC best practice experience 

 
We will start with Model-bases Systems Engineering (MBSE), then look at Asset-based 
Modular Design and finish with Model-based Product Line Engineering (MBPLE) 

Section 2 of this tutorial examines the structure and content of a complete, example 
SysML model in PTC Integrity Modeler. We look at how to navigate around this example 
model using PTC Integrity Modeler’s toolbars, context menus and commands.  

Section 3 shows you how to create a new SysML model and how you can create outputs 
based on that model. 

http://www.ptc.com/
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In common with other good systems engineering practice, building a system model with 
PTC Integrity Process Perspective MBSE is an iterative process, each iteration refining 
aspects of the model. It is very unlikely that a complete system model would be built by 
simply constructing a sequential set of diagrams as we have illustrated in this tutorial. 
However, the order shown here could be the basis for an iteration. Requirements might 
first be captured. Then high-level structural elements identified together with key 
aspects of their connectivity. Following on from that, required high-level behavioral 
elements of the systems might be identified and explored, with some allocations of 
behavior to structure made (that is, what components do what things). The next 
iteration might then move down a layer of abstraction, refining and elaborating 
requirements, structure and behavior. 

Section 4 introduces asset-based modular design, exploring PTC Integrity Asset Library 
and its OSLC based interaction with PTC Integrity Modeler. 

Section 5 completes the tutorial with examples of model-based product line 
engineering, integrating orthogonal variability modeling (OVM) with SysML, variation 
points, variants, feature selection and product model generation. 

1.4 Using this PTC MBSE Solution Tutorial 

How you use this tutorial, which sections you follow, and in what order you follow them, 
will largely depend upon your background, experience and your overall goals.  

As SysML is the core of PTC’s MBSE Solution, you should go through section 2 to gain a 
basic understanding of a system model and to familiarize yourself with the basic 
structural, navigational and functional mechanisms provided with PTC Integrity Modeler.  

For those meeting the previously stated assumptions and wishing to carry out a 
complete evaluation of PTC’s MBSE Solution, you should read all of the sections, in the 
order presented. Others, who may already be familiar with SysML, and who may want to 
construct only certain types of SysML diagrams can focus on the sub-sections within 
section 3 that are of particular interest. 

However, you need to be aware of some dependencies necessarily built in to these sub-
sections. These dependencies are shown in the following diagram (a SysML package 
diagram), where for example, the sub-section on Interactions depends upon the sub-
section on Use Case Modeling. That is, if you want to go through the Interactions sub-
section, you should first go through the Use Case Modeling sub-section. 
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2 Introducing PTC Integrity Modeler 

To help you get started with PTC Integrity Modeler, an example SysML model has been 
pre-populated with a set of SysML model elements and diagrams. The example model 
represents a hybrid sports utility vehicle (HSUV) and is the example also used in Annex B 
of the OMG SysML Specification. 

This model is available in the PTC Integrity Modeler Examples repository. Alternatively it 
is available for download from the PTC website at www.ptc.com. 

Unless otherwise stated, all of the tutorial steps in this section (2) relate to PTC Integrity 
Modeler (occasionally abbreviated to Modeler.) 

Unlike many other modeling tools and file-based tools in general, PTC Integrity Modeler 
runs live on a database, sometimes called a repository.  This is very useful when more 
than one person needs to access the same model at the same time. 

2.1 Installing and Opening the Example Model 

1. Open Model Explorer from your desktop. If you can see the Examples repository, 
select it in the left pane, and then double-click the HSUV model in the right pane to 
open it in PTC Integrity Modeler.  This may take a little time when opening for the 
first time.  This   

The remainder of this section (2.1) only applies if you do not have access to the HSUV 
model in the Examples repository. 

If you have not already downloaded the SysML Tutorial self-extracting zip file and 
extracted the contained files, you will need to do so now, before attempting any of the 
activities in this section. This file can be found on the PTC website at www.ptc.com  

After extracting the files from the download zip file, the model import file, will be 
available in the <target>\SysMLTutorial\HSUV\ directory, where <target> is the 
pathname you specified to extract the files (default 
is C:\PTCTutorials\).  

2. Open Model Explorer from your desktop or the ‘Start’ 
menu; All Programs, PTC Integrity Modeler > Model 
Explorer.  

3. Right-click the Examples repository and then click 
Import Model. 

4. Use the Open window to locate and open the HSUV.zip 
file. Select Yes when asked to confirm the import and 
wait while the model is imported to your Examples 
repository. 

http://www.ptc.com/
http://www.ptc.com/
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5. When the new model name appears in the repository, in the right pane double-click to open the 
model.  This may take a little time when opening for the first time. 

If you do not see a Models repository in the Models Explorer window, there may be 
another repository available to you in which you can import or create new models. If so, 
substitute the Models name in the activities below with the name of this repository.  

If not, you will need to create and start a Models repository before continuing with the 
section. To do this, start PTC Integrity Modeler without a model and go to the Help.  
Then navigate to Repository, Model, Component… > Repository Management > 
Administration Tasks and read the pages explaining how to create a model repository. 

After creating and starting the new repository you will then need to add it to Model 
Explorer. Again the Help system provides information on how to do this (Repository, 
Model, Component … > Model Management > Model Explorer > Working with 
Repositories). 

After you have a repository running and set-up in Model Explorer, import the model 
using the preceding activities 2 thru 5. 

2.2 The PTC Integrity Modeler User Interface 

 

Your initial screen should look similar to that above. If not, use the View, Reset Layout 
menu option which will change the layout to that shown. You will find that you can drag 
the internal borders of the panes to re-size them, as required.  

Property Pages 

Diagram Pane Browser Pane 

Output Pane 
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2.3 Menus and Toolbars 

Menus 

The menu bar provides access to a number of generic functions. Let's look at each 
option briefly. 

 

File: Provides a typical set of File menu features. These include the facility to open 
models, to create new models and also to create new diagrams.  These features look 
and act like file-based facilities even though Modeler is actually running on a multi-user 
repository. All changes to models update the repository as they are made, so there is no 
need for Save or Save As facilities.  Consequently, a deep Undo feature is also provided.  
The File menu also provides Print and Page Setup facilities.  

Edit: Provides one way of using the Undo facility. It also provides standard cut/copy and 
paste mechanisms, plus a powerful Find capability, which we will return to shortly. 

View: Permits the showing and hiding of toolbars and showing of closed panes. It also 
provides a Refresh and the Reset Layout facility already mentioned, and access to Role-
based UI Simplification.  User Roles can be very useful to keep Modeler simple for new 
users.  Please do not select a Role at this stage, so that all facilities are available as you 
work through this tutorial.  

Tools: Provides access to the various PTC Integrity Modeler add-ins, optionally including 
the documentation production tools, the Component Wizard (for export/import based 
sharing and transferring of components between models) and the various model 
interchange mechanisms.  Depending on the license you have, it may also include the 
MBPLE Variant Selector. Options allow you to change the default text fonts, to hide or 
show an alignment grid and to define its resolution, plus a number of other useful 
features. We look at a number of the Tools in more detail, later in this tutorial. 

Diagram: Only visible when a diagram is open and has the focus, this menu provides 
alignment, sizing and display options for the diagrams displayed in the Diagram Pane. It 
provides a quick way to show/hide the diagram grid, and of applying/removing the 'snap 
to' option. 

Window: You will find here the 'standard' Window operations, including useful tiling 
mechanisms (for viewing more than one diagram simultaneously) and a Close All to 
close all currently open diagrams. 

Help: The main access point to the Help system. Use this as you work through the 
tutorial if you need more detail than that provided in this document. 
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Toolbars 

Different toolbars are displayed dependent upon your current activities. For example, 
when you have a diagram open, you will see a common diagram toolbar and also a 
toolbar specific to that diagram type. We will examine the diagram toolbars in later 
sections of this tutorial. Here we will briefly examine the three toolbars seen on the 
screen shown earlier. 

The Find toolbar  provides a variety of 
search options as summarized by the tool-tips visible when you hover the cursor over 
the various buttons. These buttons, and the Find option from the Edit menu, open a 
detailed Find window that allows you to refine the search criteria. 

The Change Tracking toolbar  provides a means of 
tracking changes to a model. You can use the Help system to find out more about 
change tracking.  

The Standard toolbar provides a number of facilities, many of which are duplicated by 
menu options. 

 

One facility not available from the menu is the navigate facility. The navigation toolbar 
buttons  allow you to navigate to items that have been previously selected in 
the Explorer and Output panes, also to items you have selected on Property Pages, and 
to symbols you have selected on diagrams. 

1. Spend some time (5-10 minutes, we suggest) exploring the structure and contents of the Help 
system. In particular, use the Help menu Help Topics option to bring up the Index facility, and from 
here, input 'navigation buttons' to learn about the use of the navigation buttons. 

You can show or hide toolbars using the View > Toolbars menu options. We will not 
need to use the Change Tracking toolbar so it can be hidden. 

2. Use the View > Toolbars menu 
option to hide the Change 
Tracking toolbar as shown 
opposite. 
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2.4 Using the Browser Pane 

The browser pane provides access to the various items, diagrams and relationships 
defined within a model.  Some of the default Browsers may not be useful for systems 
modeling and can easily be hidden. In this example model, the diagrams are well 
structured in Packages (more on that later) so you might want to hide the Diagrams 
Browser. You should never remove the Packages Browser as this is the main model 
structuring view. It is through this tab that new SysML diagrams and model elements are 
created. The Parts Browser can sometimes provide a useful view (as we will see shortly). 

A specific browser is opened by selecting the required browser’s tab from the set of tabs 
at the foot of the browser 
pane. Each tab has a tool-tip 
that identifies the browser. By default 
the Packages browser is selected and 
open. 

1. Use the tab to select the Diagrams 
Browser. 

2. Close this pane by clicking the Close 
button.  

This results in the Diagrams browser 
pane being closed and its tab being 
hidden from the set of browser pane 
tabs. 

3. Use the View > Show Panes menu 
option to restore the Diagrams 
Browser. 

The order of the tabs may be 
different, but note that you can drag 
and drop tabs into any position.  

We will now look at the Packages 
Browser in more detail.  

4. Open this browser by selecting the Packages tab (usually the left most tab of the Browser tabs). 

There are three top level packages: ModelingDomain, HSUVModel and Profiles.  

Below these entries you can see two items (Text Diagrams): a ReadMe and a copy of the 
introductory information from Annex C of the OMG SysML specification.  

5. Double-click the ReadMe text diagram name in the Packages browser. 
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This opens the text 'diagram' in the diagram pane, which explains a little about the 
diagrams in this model. You may also like to open the Annex C text diagram if you're not 
familiar with the SysML sample problem. 

6. When you have read the text, close the text diagrams by clicking the 
close button on the diagram tab in the Diagram pane (as opposite). 

The two top level packages, ModelingDomain and HSUVModel 
contain the HSUV model. We will examine these and please note that much of the 
information is also accessible through the other panes.  

The main purpose of the Packages browser is to allow you to structure model content in 
a meaningful way. 

7. Expand the HSUVModel package using the ‘+’symbol or a 
double-click. 

This allows you to see the sub-packages within the HSUV 
Model and any model elements (items or diagrams) that 
are filed in the HSUVModel package itself. You can 
expand any of these sub-packages to see their content if 
you wish. 
 
8. Double-click the HSUV Model diagram name. 

This will open a package diagram that shows the 
package structure of the HSUV model together with a 
few key items and relationships. 

You can now see the description of the diagram in the diagram’s Property Page. 

All diagrams in this model have their descriptions from the SysML specification included 
in their properties, in the Text tab. 

9. Select the diagram name in the Package Browser and examine its Description property via the 
property pages Text tab.  
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The other top-level package visible in the Packages browser is the ModelingDomain 
package. This package contains domain items and sub-packages that define domain 
specific value types (e.g. Time, Temperature) and stereotypes (e.g. external, system). It 
also contains two more package diagrams, one of which shows the value types and their 
units, the other shows how the items and sub-packages here relate to each other. Both 
of these diagrams have Descriptions from the SysML specification.  

Now we will look at the other tabs in the Browser Pane and return to the Packages tab 
later. We will review these panes in the order that we will cover their topics in the 
tutorial, rather than the default order the 
tabs appear in the Browser Pane. 

10. Select the Requirements tab.  

Here you see a set of folders containing the 
requirements, diagrams, tables and 
relationships that that exist in the model (as 
shown opposite). 

11. Expand these three folders: Requirement 
Diagrams, Requirement Tables and 
Requirements. 

Each of these (and the other folders) gives 
you a list of model items of a specific type. 
This is a view of ‘Model Items' and 
specifically Requirements related model 
items. The concept of ‘Model Items’ is very important.  Model Items, such as 
Requirements exist only once in a model and they can then be displayed on any number 
of different diagrams and also more than once on a diagram.  This maintains consistency 
as changing the name (or other information) 
of a Model Item means that it will be changed 
everywhere in the model because it is actually 
the same core model item. 

Compare your current on-screen 
Requirements browser view, showing the list 
of requirement diagrams, requirement tables 
and requirements with the view to the right 
(note that this view is not currently visible for 
you). 

This view is a Package browser view showing 
the hierarchical structure within the HSUV 
Requirements package. It shows the way the 
model owner has chosen to create and 
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organize the same set of requirements, requirement diagrams and requirement tables 
you are currently seeing in the Requirements pane. 

12. Select the Blocks tab to view the Blocks. 

Blocks are one of the key model elements in SysML. A good description of blocks and 
some of the other folders you see with this tab can be found in the Description property 
of the top 'block' folder in the Blocks browser.  

Just like the Requirements browser, the Blocks browser provides a Model Item view of 
block-related elements in the model. Each folder displays its content in alphanumeric 
order, making it easy for you to locate any specific item. 

13. Expand a few of the Block browser folders to get an idea of how much block-related information is 
in the example model. 

14. Now switch back to the Packages browser, and expand the HSUVStructure package within the top-
level HSUVModel package. 

Here you will see many (but not all – some are elsewhere) of the blocks and block 
diagrams visible from the Blocks tab view. SysML Block Definition Diagrams (BDDs) are 
visible at the foot of the package that contains them, and to see Internal Block Diagrams 
(IBDs), you will need to expand the block that owns the IBD. 

Because IBDs are owned by a Block, you can open an IBD from the context (right-click) 
menu of the parent Block. If a block has one or more child IBDs (not all do), you can 
right-click that block in either the browser or on a diagram and use the Open option to 
select and open a child IBD. 

The remaining browsers are the Ports and Flows, Constraint Blocks, and Requirements 
(Extensions) tabs. These browsers provide similar, folder-organized, alphanumerically-
ordered lists of relevant model elements. If you wish you can select these tabs to see 
what sort of information they contain. 

That leaves us with the Parts browser. As the name implies, this browser is used to show 
the decomposition of anything that can contain parts (for example, blocks, constraint 
blocks, parts, parts of parts etc.). It is typically used to view the decomposition of a 
Block.  

15. From the Package browser, if necessary expand the HSUVStructure package within the top-level 
HSUVModel package, and then expand the AutomotiveDomain block. 

This exposes the parts of the AutomotiveDomain block. Note that attempting to expand 
the drivingConditions part shows no further layers of decomposition; you will only ever 
see one layer of decomposition in the Packages browser. 

16. Double-click the [Block] AutomotiveDomain IBD  
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This opens the IBD that follows, where the parts of the Automotive Domain are visible. 
We are viewing the OMG SysML example models high-level automotive domain entities 
for a Hybrid Sports Utility Vehicle (HSUV) and how they connect with each other. 

 

Note that the parts on the diagram, as in the browser, have a name that shows their 
part name (e.g. Driving Conditions) followed – after a colon – with the name of the block 
that defines the type for the part (e.g. Environment).  This can be a challenging SysML 
concept.  A clearer example could be the wheels of the HSUV.  There may be five wheels 
or parts identified as ‘Front Left’, ‘Front Right’, ‘Rear Left’, ‘Rear Right’ and ‘Spare’.  They 
may all be of the same type, e.g. ‘Alloy Road Wheel’ but these parts could be changed to 
different types for different system designs.  For example, the ‘Spare Wheel’ part could 
be changed to a ‘Steel Space Saver’ type. 

Three additional pieces of information are also visible on the diagram. Firstly, it shows 
which parts connect to which other parts. Secondly, the drivingConditions part is itself 
composed of lower-level parts (weather, object and road), all of which are external to 
the domain, as indicated by the «external» stereotype.  Plus the Actors which interact 
with the Parts. 

17. Now switch to the Parts browser, where you will also be able to find and expand the 
AutomotiveDomain block (as opposite). 

There are clearly some differences in what is being displayed. For a start, here we are 
able to see all layers of decomposition, so we can expand drivingConditions to see its 
parts. We do not see the IBD – it's not a part of the block. Nor do we see the actors 

ibd [Block] AutomotiveDomain

«system»

HSUV : HybridSUV

vehicleCargo : Baggage

«external»

drivingConditions : Environment

«external»

weather : Weather

«external»

road : Road

«external»

object : ExternalObject

Driver

Passenger

Maintainer

x5

x2 x3

x4

x1

version="0.1"

description="Initial concept to identify top level domain entities"

reference="Ops Concept Description"

completeness="partial. Does not include gas pump and other 

external interfaces."
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because they too are not actually part of the block but 
are referenced by it (this is why they have no part names 
in the Package browser).  

18. You should now spend some time examining the structure and 
content of the HSUVModel package and its sub-packages in 
the Packages browser. You should also relate this content to 
the way in which that content is presented in the various PTC 
Integrity Modeler browsers.  

The intention is for you to get an overview of what this 
model contains and how this content is organized.  

 

2.5 The Output Pane 

Like the Browser Pane, the group of Output Pane tabs are useful for a variety of 
purposes. These Output Pane tabs are as follows: 

 Contents Tab 

 Results Tab 

 Results 2 Tab 

 Output Tab 

 Favorites Tab 

 Diagram Thumbnail Tab 

Contents Tab: Displays the contents of the currently selected item in the currently open 
browser pane tab. You can use the drop-down list to select another browser pane tab 
that you wish to view in the Contents Tab.  

The display format can be changed using the 
display option buttons. The order in which 
the content is displayed can be changed by 
clicking into one of the column headings (for 
example, the Type heading). 

Unlike the browser pane, items displayed in 
the Output pane can be multi-selected (using 
the Shift or Ctrl keys, or by dragging a 
boundary). This can be useful for multi-

deletion, common property setting, or moving items between packages. 

In the following illustration the Contents pane is showing the contents of the Package 
browser, which has been selected from the drop-down list. 
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Results Tab: The two tabs act similarly in showing the list of elements (including 
diagrams) that result from a model item search. You can normally select which Results 
tab to receive your output, thereby allowing you to compare or keep search results. 

In the example that follows, we are seeing the results of a request to report all uses of a 
specific actor (Driver). From the list in the Results pane, we could double-click a diagram 
name to open the diagram in the Diagram pane. 
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1. On the previously opened Automotive Domain IBD (as above), right-click on the Maintainer actor 
and select Report, Usage. 

2. When the list appears in the Results tab, double-click the name of the Use Case Diagram to open 
that diagram. 

3. Then right-click on the Maintainer actor entry in the Results tab and select Find, On Diagram to 
locate the actor on the currently open use case diagram. 

4. Finally, right-click the linked 'Maintain the vehicle' use case on the use case diagram and select 
Find, In Package Browser to locate the package scoping the use case. 

Output Tab: Provides a view of the output Modeler information. This information 
includes error messages, status messages, etc. 

5. Right-click in a blank area of the currently open use case diagram and select Report, Consistency. 

You will notice that the Output tab is automatically selected to show the report output. 

The set of consistency checks applied depends upon the type of diagram. You can use 
the Help to find what consistency checks are performed for each diagram type. 

Favorites Tab: Lets you 
quickly access model items 
and diagrams that you use 
regularly. You can add any 
item or diagram to the 
Favorites tab and then use 
that item's or diagram's 
context menu commands as 
you would anywhere else in 
the tool. In addition, you 
can use the items and 
diagrams in the Favorites 
pane for performing drag-
and-drop operations.  

Items can be added to the 
favorites tab either by 
dragging the item into the 
pane from the browser 
pane, or by right-clicking on 
the item (in the browser 
pane or on the open diagram) and selecting Add To Favorites from the context menu. 



Introducing PTC Integrity Modeler  - The Output Pane 

17 

6. Find the Automotive 
Domain internal block 
diagram in the Packages 
pane. 

7. Open the Favorites tab. 

8. Drag the Automotive 
Domain IBD to the 
Favorites tab. 

9. Find the diagram in the 
Blocks browser using its 
context menu by right-
clicking on the diagram in 
the Favorites pane and 
selecting Find ► In Blocks 
Browser. 

Diagram Thumbnail Tab: A view for 
panning around and zooming in or out of 
the diagram currently displayed in the 
Diagram pane.  

10. Select the Blocks browser pane and expand 
the Internal Block Diagram folder. 

11. Double-click the diagram name highlighted 
opposite to open this quite large diagram. 

12. Zoom in to 100% on this diagram (or more, 
depending on your screen resolution). 

You can now only see part of this diagram 
in the diagram pane. 

Select the Diagram Thumbnail tab and drag 
the shaded area around, noting the effect in 
the diagram pane. 

Panning is normally done by dragging the 
shaded area in the Diagram Thumbnail tab, 
although both arrow keys and the mouse 
wheel (with the Shift key) can be used. 
Zooming is done using the mouse wheel, but 
with the Ctrl key down. This pane is typically 
used to navigate around large diagrams. 



Introducing PTC Integrity Modeler  

18 

2.6 Diagrams and the Diagram Pane 

Although we have already seen a number of diagram features, there are still other 
diagramming facilities that are important. One key concept to understand (as 
introduced earlier) is that items displayed on a diagram are actually symbols 
representing an underlying model item in the model database. The model item can be 
represented symbolically on many diagrams and, in some cases, many times on the 
same diagram.  

A significant number of diagramming facilities are provided with toolbars. The common 
diagram toolbar is shown here. 

 

 
 
 
 
 
 
 
This toolbar is available whenever any diagram of any type is open.  

It provides three sets of buttons that allow you to align, evenly space out and 
standardize the size of symbols on the diagram.  

Align to Grid: Provides the ability to align any symbols (including connection links) that 
you add to the diagram to the alignment grid. The granularity of the grid, and whether 
you opt to show or hide the grid is controlled through the Tools, Options menu.  

Selecting the Diagrams 
section on the Tool Options 
form provides the options 
for this grid, as opposite. 

You can also see, from the 
other tabs, that the Tools 
Options form provides pages 
to allow you to change the 
default shadow settings for 
diagram items; to define the 
fonts used in rich text fields 
(including that used for 
embedded model 
references); and to set print options for printing of diagrams. 

symbol 
alignment 

align 
to grid 

diagram 
resizing 

page 
breaks 

diagram 
lock 

symbol 
spacing 

symbol 
sizing 
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Diagram Resizing: Allow you to zoom in and out of the currently open diagram or to fit 
the diagram to the diagram pane (or center a selected diagram symbol in the diagram 
pane). 

Page Breaks: Toggles the visibility of printing page breaks on large diagrams. Where 
these occur depends on your print option settings. 

Diagram Lock: Allows you to control whether other model users can edit a diagram that 
you have opened with write access. The subject of Modeler’s multi-user permissions is 
both powerful but complex, and is therefore outside the scope of this tutorial.  That 
said, it is well worth finding out more about this powerful capability form the help. 

In addition to the common diagram toolbar, each diagram type has its own toolbar. This 
will contain buttons specific to the modeling of that type of diagram. However, they 
nearly all contain the following set of buttons. 

 
 
 
 
 
 
Note: Provides the ability to add a note to a diagram to add some information. It is 
merely a diagram symbol with no corresponding model item. Often you will want to use 
the Link button to link the note with a specific item or items it relates to. 

Comment: Similar to a Note, the difference being that a Comment is a model item that 
belongs either to the package that contains the diagram (if unlinked), or to the model 
item it is first linked to. 

Constraint: Similar to a Comment but is shown on the diagram enclosed in { }. A 
constraint is a limitation imposed upon the functionality of a system.  Both Comments 
and Constraints are created as model items. 

Frame: Used to create a frame box on a diagram that can be resized to enclose a set of 
diagram items. Frame boxes have no model repository items, they are simply diagram 
symbols, to aid communication and understanding. They can be named and the name 
can be shown on the diagram.  

1. Spend a little time now using the toolbar buttons explained in this section on some of the diagrams 
in the HSUV model. Make sure you undo any changes you make. 

2.7 Context Menu Options 

The right-click initiated Context Menu provides quick access to a frequently required set 
of functions, some of which we have already seen (for example, Report). As you 

Note 

Comment 

Constraint 

Link 

Frame 
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progress further through the tutorial you will notice that several of the Context Menu 
options appear in many contexts whereas others are much more context specific. It is 
worthwhile briefly considering some of the more useful and generic options now. 

Links: A powerful mechanism for creating 
associations between appropriate model 
diagrams and/or model items. A Links Editor is 
provided, to create or break links. 

New: Used to create new items that belong to 
the item on which you right-clicked; this 
includes child diagrams. 

Populate: Provides a quick way of adding 
existing model items and relationships to a 
diagram. The Populate sub-menu is context 
sensitive depending on whether you invoke it 
from the diagram canvas or an item on the 
diagram, and what type of diagram or item it 
is. 

Open: Allows you to open child or associated 
diagrams. 

Find: Allows you to locate a selected item or 
diagram in one of the Browser panes, or a 
diagram. 

Applied Stereotypes: Provides a quick method 
of applying a stereotype to a model element. 
The list of stereotypes offered is dependent on 
the element type. 

Add To Favorites and Remove From Favorites: 
Provide a method of adding the source item to 

the Favorites pane. 

Delete and Delete from Model: Delete simply removes an item symbol from the current 
diagram but leaves it in the model and therefore on other diagrams. Delete from Model 
is more powerful as it totally removes an item from the model and all diagrams (you will 
be asked to confirm this type of deletion). 

View Options: Allows you to show or hide information for one or more diagram items. 

The Help system has more detailed information on the above options. 
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2.8 Property Pages 

Property Pages are the same as the other panes in that they can be resized, hidden, 
moved or undocked using a common set of buttons in the top right corner . The 
Help section on 'Organizing Modeler panes' is useful here. The Property Pages include 
an additional button , which opens a Help topic for the properties that are displayed 
on the Property Page.  

As you have been selecting elements of the HSUV model, you will have noticed the 
Property Pages changing. Different model item and diagram types have different 
Property Pages as we will see more fully in section 3 of this tutorial. 

2.9 User Roles 

As briefly mentioned in the Menus section, Modeler provides User Roles that can 
remove unwanted features from the Modeler user interface, including particular 
Browsers, Browser contents, menus, toolbars and buttons. 

If you are interested in only SysML diagrams and items, you may want to use the 
provided Systems Engineer or Minimal Systems Engineer user role to remove non-SysML 
diagrams and items from the Modeler user interface.  

To select a user role: on the View menu, click User Roles, and then select the user role 
you want to use.  

For more information about using and customizing User Roles, see the User Roles - 
Configuring Modeler for Different Users section of the Modeler Help.  
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3 Model-based Systems Engineering using SysML 

The example HSUV model is useful to see how SysML has been implemented in PTC 
Integrity Modeler. We will now look at how you construct your own model. Any models 
you build will, most likely, be different from the supplied example models, so in this 
section we will describe the generic mechanisms that are used to build any SysML 
model. To save time and effort, we will not build a complete 
example model; we will show you the main concepts.  

As mentioned in the introduction, PTC Integrity Process Perspective 
contains best practice process for using SysML on Model-based 
Systems Engineering projects. That said, these practices are 
recommendations and can be modified to suit your own specific 
needs. 

More details on the 
Process Perspective 
approach and its 
practices are 
available in the 

MBSE Best Practice Storyboard document (www.ptc.com) and the PTC Integrity Process 
Director process library for the PTC Integrity Process Perspective.  In this tutorial we will 
introduce the topics at a relatively high level. 

We apply a logical flow that involves an iterative approach and is based on the PTC 
Integrity Process Perspective best practices for MBSE. Each iteration can correspond to a 
layer of abstraction of the system or a delivery against a plan, and involve the capture of 
requirements relevant to that increment, followed by the definition of behavior and 
structural elements necessary to meet those requirements. So in practice, modeling 
within each iteration would additive be performed in parallel. 

http://www.ptc.com/
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However, we are forced to diverge from 'real world' practices a little because the 
information in this tutorial has to be presented serially. So the steps we will cover in this 
section are as follows: 

1. Creating a new SysML model 
2. Introduction to building a model 
3. Capturing requirements (requirement diagram) 
4. Identifying use cases (use case diagram) 
5. Defining interactions (sequence diagram)  
6. Defining activities (activity diagram) 
7. Defining blocks, their parts and their connectivity (block definition and internal 

block diagrams) 
8. Defining constraint blocks and parametrics (parametric diagram) 
9. Allocating activities to blocks (activity diagram) 
10. Defining state behavior (state diagram) 
11. Establishing requirements traceability 
12. Capturing model structure (package diagram) 
 
 

3.1 Creating a New SysML Model 

In both the OMG standard and PTC Integrity Modeler, SysML is implemented as a UML 
profile. Modeler profiles allow the customization and extension of the user interface, 
properties and behavior of the tool.  

The first step in building a SysML model is to create a new model that includes the 
SysML and UML Profiles. These Profiles can also be added to an existing model at any 
time. Let's start by creating a new model; 

1. Either open Model Explorer, or if you still have it running, check that you can see the Models 
repository. 
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Your Model Explorer window may show more repositories than those shown above; that 
does not matter as long as one of them is the Models repository. 

If you do not see the Models 
repository, try right-clicking the server 
in the left pane of the Models 
Explorer window and selecting Show 
All Repositories, as in the diagram 
opposite. 

If the Model repository appears, but in gray 
(as in the diagram opposite), right-click the 
repository and select Bookmark. The 
repository will then turn blue and can be 
opened. If a Models repository is not available, 
you can use the Examples repository to hold 
the model you are about to create. Failing that 
you will need to create a repository in which 
this model can be stored (see the Help). 

If you have any unforeseen problems at this 
stage, the PTC Support team will be able to get 
you up and running. 

The instructions that follow assume that you will be using the Models repository; you 
will need to change the name if you are using a different repository. 

2. In the Model Explorer 
window, click the 
Models repository to 
open it. 

3. In the right pane, 
right-click in free space 
and select Create New 
Model ► New Model 
with Profiles.  

 

4. Scroll down the list of 
Options and select the 
SysML (Full Profile) 
check box. 
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This will automatically select the UML check box so that both profiles will be added to 
the model. 

5. In the Model Name text box, type the name My SysML Model. Then click the OK button. 

It will take some time to create the model with the required profiles. 

6. When My SysML Model appears in the right pane of the Models explorer, double-click the name to 
open the model. 

(Note, you may need to click on something else first, if the Model is already selected following creation.) 

The SysML and UML profile packages are visible in the Packages pane. Note that like all 
profile packages, they are protected so that they cannot be modified in error, so their 
content cannot be changed unless the model owner unprotects them.  

WARNING: Changing the SysML or UML Profile can result in severe failure in a SysML 
model and may make it impossible to upgrade the profile at a later point. It should be 
done only in exceptional circumstances and even then only by someone who fully 
understands all aspects of the profile. 

 

3.2 Introduction to Building a Model 

SysML model items (for example, blocks and requirements) are created either on 
diagrams or from the context menu of the package or model item in which you want 
them to reside. Relationships between items can be created on diagrams and in some 
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cases through the context menu for one or both of the items, as well as other 
relationship editors such as the Property Pages Items tab. 

Consequently, it is often the case that some thought needs to be given very early on as 
to how the model should be structured, in terms of the package hierarchy. This 
structure typically evolves as the model becomes larger. A package diagram can be used 
to capture this structure together with the dependency relationships between packages. 
We will not create a structure now, but we will illustrate the evolution of a structure by 
adding packages as we go through each of the following sections. 

3.3 Capturing Requirements 

System requirements can be created directly within the model. However, for many 
projects system requirements will already exist in some other environment. They might 
be defined in Microsoft® Office (e.g. a Word® document or Excel® spreadsheet), or held 
in a requirements management tool (e.g. PTC Integrity Lifecycle Manager or IBM 
Rational® DOORS®). Where this is the case, copy-paste is one option for importing 
requirements into your model. However, you need to keep both copies synchronized 
with any changes. Modeler's Integration for PTC Integrity Lifecycle Manager (or IBM 
Rational DOORS) does just that, and more. However, this is beyond the scope of this 
tutorial and we will simply create requirements directly in the model, knowing that in 
practice PTC Integrity Modeler is integrated with other requirements management 
tools.  In fact, as MBSE matures many organizations are using SysML model 
requirements as the master. 
 
1. Right-click the model name in the Packages browser and select New ► Package. 

 

2. Enter the name HSUVModel as in the supplied model. 

3. Now right-click on the HSUVModel package, select New ► Package again, and name this package 
HSUVRequirements. 

You now have an HSUVModel package containing an HSUVRequirements package, 
within which you are about to create a requirements diagram and some requirements. 

4. Right-click on the HSUVRequirements package and select New ► Diagram ► SysML ► 
Requirement Diagram.  
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5. Leave the diagram name as the default '[Package] HSUVRequirements' 

6. On the requirement diagram toolbar, select the Requirement button . 

7. Click the diagram, inside the diagram frame to 
create a new requirement. 

8. Name it Performance and press the  [Enter] 
key 

The new requirement appears on the 
diagram. It also appears in the Package 
browser (together with the diagram) 
beneath the HSUVRequirements package, 
as shown opposite.  Modeler created both the diagram symbol and the underlying 
model item.  This Requirement model item 
can now also be shown on other diagrams, 
ensuring consistency and enabling reuse. 

Model item Names must be unique within 
a Package and Modeler enforces this for 
you. You may also choose to give each 
Requirement an ID, perhaps referencing an 
external requirements management system ID. 

9. Open the properties of the Performance requirement and select the Requirement tab. 

10. To set a requirement id# value, double-click in the Tag Value column for id#, and enter the required 
text value (REQ_1 in the example opposite). 

In Modeler, Requirements are created with default text within their description, this will 
need to be changed for each Requirement you create. 
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11. Select the Text tab on the Performance property page, and select the Description property from the 
drop-down list. 

12. Replace the default description text (The System shall do…) with something more meaningful (see 
the example that follows). 

When you have typed the text you need to be aware that pressing the [Enter] key will go 
to a new line and that there is no Save button or menu option.  Each change in Modeler 
is saved when you move to a different pane, tab or field. 

You will have noticed that this additional property is not yet visible on the diagram. You 
can control how much information is shown on diagrams, using the View Options form, 
or, as in this case, via a context menu option to Show/Hide Compartments. 

13. Right-click Performance on the diagram and select Show/Hide Compartments.  

Note that clicking away from the property 
page will save your Requirement 
Description in the background. 

14. From the list that appears, expand the 
Properties folder, and then select the 
Description and Id# check boxes.  

The Performance requirement on the 
diagram will resize automatically, so that it 
looks similar to the example that follows. 

Note that you can hide compartments by 
deselecting them (we have done so for 
following screen shots but you can keep them if you choose). 

Now we will consider the relationships between requirements. 

15. Use the Requirement toolbar button, as previously, to create another requirement on the diagram 
called Acceleration. 

16. Now select the Requirement Nesting Link button . 

17. Click first on Performance, then on 
Acceleration to create the link between the 
requirements (as opposite). 
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This nesting relationship (one requirement contained as part of another) has been 
captured in the properties of both requirements, as you can confirm by looking at the 
requirement tab properties for Acceleration - parentRequirement.  

It is also visible in the Package browser view, as shown opposite. 

Another type of relationship we will cover here is the derive 
requirement dependency, where a ‘client’ requirement is derived from a ‘supplier’ 
requirement. This time we will show an alternative way to create a requirement. 

18. In the Packages browser, right-click the HSUVRequirements package and select New ► SysML ► 
Requirements ► Requirement. 

19. Name the new requirement Power. 

The Power requirement should be clearly visible in 
the Package browser, as shown opposite.  

20. Now drag the Power requirement from the browser and drop it on the diagram. 

21. Then, select the Derive Reqt dependency toolbar button  (you may need to use the pull-down 
list),  click first on Power (the client), then on Acceleration (the supplier). 

This will create the dependency (Power 
requirement is derived from Acceleration 
requirement) as shown opposite. You will 
also see this relationship in the 
requirement properties page of each 
requirement (although there is no visibility 
this time in the Packages browser view). 

In practice, you would add Descriptions for both Acceleration and Power requirements, 
and perhaps use the Show/Hide Compartments option to display these on the diagram. 

To finish this section on requirements, we will create a requirements table. 

22. Right-click on the HSUVRequirements package in the Packages browser and select New ► SysML 
► Requirements ► Requirement Table. 

This creates the table scoped to the package. 

23. Amend the default name slightly to include 
Table1 inside the final pair of square brackets as 
shown opposite and press the [Enter] key. 

Before we look at this table, we will consider 
the scope and format of what it contains. 
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The table will include all requirements in the package, including those in any child 
packages. If you want to extend the scope to another package outside the parent you 
can do this, by right-clicking the table in the browser and selecting Links ► Analyzed 
Packages. The Links Editor will then allow you to define the packages you wish to 
analyze - look for further details in the SysML Help.  

Another thing you might want to do is to define the specific information that goes into 
the table. There will be a row for each requirement within the selected scope, but you 
have control over what columns are created when you open the table. 

24. Right-click the table name in the browser and select Set ► Column Definitions. 

This opens the Profile Column Editor 
shown opposite, which will allow you to 
configure which columns appear and how 
wide they should be. 

We want to end up with five columns: 
Name, id#, txt, subRequirements and 
derivedFrom, and we want them to appear 
in that order with auto width. The example 
you see opposite has two columns we 
want to remove. Your Editor window may show the same or it may be slightly different. 
Removing an unwanted column is very simple. 

25. Select the unwanted column entry (for example, rationale) and then click the DELETE button : on 
the Editor toolbar. 

26. To add a new column, click the NEW button  on the Editor toolbar.  

This adds a new entry to the list, by default another Name entry. 

27. Click (you may need to double-click) the new 
Name entry to expose the drop-down list (see 
opposite). 

28. Scroll the drop-down list to find the required 
entry (for example, the id# entry shown 
opposite) and select it (do not click the OK 
button yet). 

New entries are added with the default auto width value. Should you want to change 
this, you simply double-click the width column and insert the required width value (try 
using 35 as a value). 

The order of the list defines the order of the columns. To move an entry up or down the 
list in the Editor window you use the up/down arrows to the right of the delete button. 
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29. Select the id# entry and click on the 'up' button . 

This positions id# between Name and txt. 

30. Add the other columns we stated earlier and place them in the correct positions. 

31. When your Editor list is correct, click the OK button and confirm your changes when asked. 

32. Then double-click the table entry in the Package Browser. 

The table will open in Excel, which may be minimized. You may want to adjust column 
width and row height using standard Excel formatting functions, but be aware that 
these changes will not be preserved. You can confirm that the required information is 
present and that it is correct and consistent with that on the requirements diagram. 

33. Close Excel and choose not to Save the table when asked. 

The table will be re-generated into Excel from the current model data each time you 
open it, so you only need to save it if you want to baseline the table at a point in time. 

Before leaving requirements modeling, you should switch to the Requirements browser 
pane and open the folders there to see the model elements you have created. 

34. Finally, close the requirements diagram and collapse the HSUVRequirements package in the 
Packages pane. 

 

3.4 Identifying Use Cases 

Now that we have started to define the Requirements for our system we will move on to 
consider the functional aspects of our system, with behavioral modeling.  This follows 
the widely adopted RFLP (Requirements, Functions, Logical Structure and Physical 
Structure) flow and also aligns with the PTC integrity Process Perspective approach to 
MBSE. We will start by considering Use Cases, which are shared between SysML and 
UML, and have been applied in many engineering methodologies. Use Cases can be 
defined at several levels; the HSUV example has both top-level and operational-level use 
cases defined. In this tutorial we will use an operational level example as the modeling 
concepts and techniques are the same irrespective of the level. 

We will begin by creating a package to hold the use case elements. 

1. Close any currently open diagrams. Then select the Packages pane and collapse the open packages. 

2. Right-click the HSUVModel package in the Packages Broswser and select New ► Package. Name it 
HSUVUseCases. 

3. Now right-click the HSUVUseCases package and select New ► Diagram ► SysML ► Use Case 
Diagram. Name the diagram Operational Use Cases. 
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From the New > SysML> Use Cases sub-menu, you can also create two of the items that 
can appear on use case diagrams (actors and use cases) directly in the package for 
dragging on to the diagram, or (as we will do) you can use the diagram toolbar to create 
these items. Increments are a tool-specific item that allows you to relate particular use 
cases to increments for an incremental development approach or agile approach. 

The first thing you may notice about the diagram, is that there is no SysML diagram 
frame. SysML Use Case diagrams are shared with UML, where diagram frames are 
optional. If you want to add a SysML diagram frame, it's quite simple. Here's how you do 
it. 

4. Select the Frame Box toolbar button , and click onto the diagram. 

5. Enlarge the frame box (drag a corner) so that it nearly fills the diagram pane. 

6. Now locate the diagram in the Packages Browser and drag the diagram to anywhere on the 
boundary of the frame on the diagram (the mouse pointer will change shape when you are within 
drop range of the boundary). 

The result is that the frame gets a name box in the top left 
corner as shown opposite. You can change the name in 
the browser if you wish and the diagram frame name will 
automatically change as well. 

Now let's add the diagram content, inside this frame. 

7. Select the Actor toolbar button  and click on the diagram. Name the actor Driver. 

8. Select the Use Case toolbar button  to add a use case called Drive the Vehicle to the diagram. 
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9. Add five more use cases to the diagram, name them Start Vehicle, Cold Start, Warm Start, 
Accelerate and Brake. 

The HSUV example has other use cases, but these will be sufficient for our purposes, 
one of which is to create use case relationships. Before we consider these, we will add 
another frame box to the diagram. It is conventional on a use case diagram to enclose 
the use cases in a frame box with the actors outside the frame box, to separate what is 
happening inside our system (the execution of the use cases) from external actors.   

10. Use the Frame Box toolbar button again to create a frame box enclosing the use cases only (you 
may have to move diagram items around to do this – see the final diagram that follows shortly). 

This frame box represents our System and in SysML, systems and sub-systems (or 
components) are represented as Blocks.  We will focus on Blocks later in this tutorial but 
for now we will just create the Block that represents our system and this frame box on 
the diagram. 

11. Right-click on the HSUVModel package in the Package browser, and select New ► Package. Name 
it HSUVStructure. 

12. Select the Block toolbar button , and click on the diagram within the frame. Name the block 
HybridSUV. 

13. Now, with the HSUVStructure package expanded in the Packages browser, drag the HybridSUV 
block from the browser and drop it on the new frame box boundary (like you did when creating the 
diagram frame). 

The frame box now displays the block name.  In addition the style properties of the 
Block item have been applied to the frame, making it look like a block and hiding the use 
cases. This is easily corrected. 

14. Right-click the name compartment of this frame and select View Options. 

15. On the Style tab select the Default option and then click the OK button. 

Now we will consider the relationships between the Actor and the Use Cases. 

16. Select the Interaction toolbar button , click on the Driver actor, then on the Drive the Vehicle use 
case. 

This models the interaction that occurs between the driver and the HSUV when the use 
case is executed. 

17. Now select the Include Flow toolbar button , click first on Drive 
the Vehicle, then on Accelerate (the order is important here – use 
Undo or the context menu option Delete from Model if your arrow 
points the wrong way – see opposite. Do not use the Delete key – 
this just simply deletes from the diagram and will give you an error 
when you try to create the relationship in the correct direction). 
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This creates an include relationship between the use cases; Accelerate is included as 
part of Drive the Vehicle. 

18. Create a second include relationship going from Drive the Vehicle to Brake. 

So driving includes both accelerating and braking, but what about the Start Vehicle? 
Sometimes the vehicle is driven off with it already started (every time we stop but leave 
the engine running); only occasionally do we have to start the vehicle before driving off. 
We need the «extend» relationship. 

19. Select the Extend Flow toolbar button  
and click first on Start Vehicle and then on 
Drive the Vehicle. (Again the order is 
important, if you get it wrong (see opposite), 
you cannot use the Delete context menu 
option or the Delete key – this removes the 
relationship from the diagram, but leaves it in the model. You must Undo or Delete from Model.) 

Finally we will look at the cold and warm start use cases. 

Both are ways of staring the vehicle, but starting from cold is not the same as starting 
when already warm (for example, cold starting requires a richer air-fuel mixture). The 
generalization relationship is appropriate here.  

20. Select the Generalization toolbar button , 
first click on Cold Start, then on Start Vehicle 
(yet again, order is important – if you get the 
direction wrong use Undo or Delete from 
Model). 

21. Use the Generalization toolbar button again to create this relationship going from 
Warm Start to Start Vehicle. When the pop-up (opposite) appears, select 1(as 
shown), to indicate that this the same type of generalization as the first one you 
created to Start Vehicle, rather than a completely new type. 

Your 
final 
diagram 
should 
look 
similar 
to this. 
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We now need to consider how PTC Integrity Modeler and SysML can be used model 
more detailed levels of behavior. 

 

3.5 Defining Interactions 

Interactions describe messaging between items; in a SysML model these items are 
normally structural items such as block, parts and ports. In UML, four diagram types 
exist to support interaction modeling; in SysML only one of these is used: the sequence 
diagram. 

Sequence diagrams are very powerful as they implicitly relate behavior structure.  The 
lifelines, defining the senders and receivers of the messages, being used typically to 
represent blocks, their parts or ports, or even actors; each message represents a request 
to invoke behavior in the receiver.  This is the link between ‘F’ and ‘L/P’ in RFLP 
mentioned earlier.  Sequence diagrams are typically used to model scenarios – typical 
patterns of behavior to achieve a particular goal.  They are often used to refine the use 
cases and elaborate their defined behavior in less ambiguous terms. 

As we will see later, a similarity between sequence and activity diagrams is the ability of 
both diagram types to model layers of abstraction. Sequence diagrams use two 
concepts: 'Interaction Use' and 'Part Decomposition' to refine a single step at one level 
into a set of more detailed steps at a lower level. 

Block operations, described later in the section on blocks and block diagrams, will be 
used in this section. Many of the messages modeled on sequence diagrams are requests 
for a block – or more typically a part typed by that block – to execute a block operation. 
We will also see in this section a link to activity modeling, where an activity (more 
specifically its child diagram), defines the detailed implementation of a block operation. 
We will also see how we can capture the specification-implementation relationship 
between an operation (the specification) and its implementing activity in the model. 

In this section we will illustrate the refinement concept as well as the use of messages. 
The supplied HSUV example uses sequence diagrams in the context of refining use 
cases. Sequence diagrams don't necessarily have to relate to use cases (we will also 
describe how to create those that do not), but this is a very common use for them and is 
the scenario we will use. 

1. Close all currently opened diagrams (Window ► Close All). 

2. Expand the HSUVUseCases package in the Packages browser and double-click the Operational Use 
Cases diagram name to open the diagram. 
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3. Right-click the Drive the Vehicle use case (either on the diagram or in the browser) and select New 
► Sequence Diagram. 

 

This creates and opens the sequence diagram as a child diagram of the parent use case – 
as you can see in the browser pane in the following image. 

You can also create a sequence diagram scoped to a package rather than a use case by 
right-clicking the package and selecting New ► Diagram ► SysML ► Sequence 
Diagram. Other permissible parent items for a sequence diagram include Events and 
Operations. 

Driver

Drive the
Vehicle

Brake

Accelerate

Warm Start

Cold Start

Start Vehicle

«include»

«include»

«extend»

uc Operational Use Cases

HybridSUV
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When the diagram is created from a use case, the use case name is added to the top 
left. No diagram frame is created on a sequence diagram. Just like the earlier use case 
diagram, this is an inherited UML diagram, and UML diagrams do not have frames by 
default. If you wish you can add a frame in the same way as you did for the use case 
diagram. 

The two vertical lines visible on the diagram are the System Boundary - the thick gray 
line that separates external actors from elements within the system (much like the 
frame on the Use Case diagram) and the Architectural Boundary - the dashed line that 
can be used for whatever architectural separation you wish, but is often ignored (but 
cannot be deleted). 

The sequence diagram has a rich set of toolbar buttons, many of which are not needed 
for SysML modeling and will not be covered in this tutorial. If you are interested in what 
they all do, they are described well in the online Help. 

The Description box labels the area of the diagram where you build up the description 
steps for the message sequence. This description is where you can create a more 
structured version of Use Case description. 

In Modeler each message must have a corresponding description step, and the step 
must be created before the message can be added. You can do this one message at a 
time or, as we will do, define all description steps before adding messages. 
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4. Select the Sequence toolbar button , and 
click into the Description area below the 
Description box. 

A sequence step is added with the default 
content of ‘seq’ (as opposite). This default 
can be over-typed in-situ or changed afterwards by right-clicking the Step and selecting 
Rename, clicking the step twice, or by editing the text in the Property Page for that step. 

5. Change seq to startup. 

We will use this step to invoke the Start Vehicle use case. However, if you look at the 
use case diagram, you will see that Start Vehicle is an extension of Drive the Vehicle. We 
need to define the condition under which Start Vehicle is invoked. 

6. Select the Selection toolbar button , and click in the Description area below the startup step. 

This adds a selection construct (alt, end alt). 

7. Change the default notation text to something more 
meaningful, as opposite.  

We now need to move the startup step between 
the if and end if lines of the selection. 

8. Simply drag the startup step and drop it between the if 
and end if lines (as indicated above). 

The description steps should now look like those 
opposite, with the startup step indented within the 
selection.  

Now we need to consider the two included use 
cases, Accelerate and Brake. In our simplistic scenario we will assume that driving the 
vehicle is a repeated set of accelerate and brake behaviors. We model this on the 
sequence diagram using an iteration construct. 

9. Select the Iteration toolbar button , then click in the 
Description area below the 'end if' line. 

This creates another two-line item with default text 
of loop and end loop (see opposite). This would 
normally specify the condition that terminated the 
iteration, but we will just leave the defaults for this 
tutorial. The final task is to add two sequence steps 
for the accelerate and brake use cases. 
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10. Use the Sequence button (twice) to add an accelerate and a brake step, by clicking each time 
between the loop and end loop lines, as above. (If you get the order wrong, remember you can 
simply drag steps and drop them into the correct position). 

There are other buttons in the toolbar group  for creating 
description steps. These include the creation of selection outcomes and parallel 
constructs. We don't need them here, but you should refer to the Help (under sequence 
diagram, statements) to find out what they do. 

Now we will add the 'messages'. However, as Drive the Vehicle is a high-level use case 
that references other use cases, we will not have any actual 'messages' on this diagram. 
Instead we will add references to other lower-level diagrams (child diagrams of the 
included and extended use cases) where the message sequences are shown. To create 
the references we need to have the lower-level diagrams to make the references to. 

11. Switch to the use case diagram and right-click the Start Vehicle use case to create a child sequence 
diagram. Immediately close the sequence diagram when it opens (we won't need it yet). 

12. Do the same for the Accelerate and Brake use cases. 

13. Now return to the Drive the Vehicle sequence diagram and select the Interaction Frame toolbar 
button . 

14. Click on the diagram adjacent 
to the startup step, as shown 
opposite. 

This adds an interaction 
frame with the description 
step text highlighted in the frame's 'label' (as 
opposite).  

15. With this text highlighted, press the Delete key and 
then the Enter key to leave the interaction frame 
with no 'label' text (as opposite). 

16. Make sure the Start Vehicle child diagram is visible in the Packages Browser, then drag this 
diagram from the browser and drop it on interaction frame label, as follows. 
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The interaction frame changes, with the label showing the keyword ref - to indicate that 
the frame is now a reference to another diagram, and the name of the referenced 
diagram (Start Vehicle) in the body of the frame (see the following illustration). 

The frame (its formal name in UML/SysML is an 'interaction use') can be re-sized and 
moved horizontally but not vertically (it's tied to the startup description step). It can also 
be used to access the referenced diagram. 

17. Right-click the interaction frame and 
select Referenced Diagram ► Open (as 
opposite). Alternatively, double-click on 
the interaction frame. 

Note that you can also change the 
linked diagram or break the link 
through this context menu. 

18. Return to the Drive the Vehicle sequence diagram, and use the Interaction Frame toolbar button to 
create another frame, with an empty label, against the brake description step. 

19. Expand the Brake use case in the browser and 
drag its child sequence diagram on to the 
interaction frame, just as you did with Start 
Vehicle. 

20. Repeat the last two activities to create an 
appropriate frame for the accelerate step. 

Your Drive the Vehicle sequence diagram 
should now look similar to the preceding 
example. Each frame references a child 
sequence diagram for a use case. 

Drive the Vehicle

Description

if engine not running

startup ref Start Vehicle

end if

loop

accelerate ref Accelerate

brake ref Brake

end loop
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We will start on the lower-level sequence diagrams by considering the accelerate step. 
As described above, a message on a sequence diagram represents a request to invoke 
behavior in the receiver.  Behavior (function) is specified by operations which belong to 
a blocks in SysML to describe the behavior supported by the block. The implementation 
of that behavior can then be described by an activity diagram that belongs to the activity 
defined as the implementation of the operation. Both the operation and its 
implementing activity must be scoped to the block and they must have identical 
signatures (number, type and direction of parameters). We will look at Activities later. 

The need for block operations can often be identified by analyzing internal block 
diagrams (IBDs) containing parts or ports typed by that block. Although our simple 
model has no such IBD, the original HSUV model does and it shows the HybridSUV typed 
part with a connector to the Driver actor. 

Another good way to identify the necessary Blocks and their operations is to describe 
the steps in a way which naturally leads to the definition of the behavior and the 
structural Blocks.  For example, ‘The driver starts the HSUV’.  The nouns give us two 
structural elements (Driver and HSUV) and the verbs identify the behavior (Start). 

It would not be unreasonable therefore to assume that the HybridSUV block would need 
to provide an Accelerate behavior as a response to driver input, in other words, the 
Driver accelerates the HSUV. 

21. Expand the HSUVStructure package to expose the HybridSUV block. 

22. Right-click the HybridSUV block and select New ► SysML ► Operation. Name the operation 
AccelerateOp. 

The acceleration behavior will provide both drive power and transmission mode 
commands as outputs later. Therefore the operation requires similar parameters.  

23. Right-click the AccelerateOp operation and select New ► Parameter. Name it dP. 

24. Create another parameter for the AccelerateOp operation called tMC. 

We have now created an operation that will have the same number and type (that is, no 
type) of parameters as the Accelerate activity later. However, we also need to set the 
direction. 

25. Select the AccelerateOp operation, open its properties and select the Sig'ture tab. 
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26. Replace the 'in' with 'out' (a simple text replacement) for both parameters (as follows). 

 

This is a quicker way of changing the direction (called Mechanism in Modeler) property 
of each parameter than using each parameter's property pages. 

27. Now make sure you have expanded the HSUVUseCases package, right-click on the Accelerate use 
case and select New ► Activity. Name the activity Accelerate. 

28. Now expand the HSUVStructure Package in the Package Browser and drag the Accelerate activity 
from the use case to drop it on the HybridSUV block. 

29. Rename the activity 'AccelerateAct' (this is purely to make it easier to distinguish from the 
operation). 

In doing this, we are redefining the purpose of the activity from that of defining classifier 
behavior for the Accelerate use case to that of defining some behavior detail for the 
HybridSUV block. If we now want to create the specification/implementation 
relationship between operation and activity in the model, we do so through the 
properties of the operation.  

30. Open the properties page for the AccelerateOp operation again and select the Items tab. 

31. Select Specified Activities 
from the Show associated 
drop-down list, and then 
click the Link button 
(highlighted opposite). 

This opens the Links Editor 
(shown below), which 
should have Specified 
Activities selected in the 
Show Associated drop-down list, and any activities scoped to the operation's block will 
be listed. 
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32. Ensure the Types drop-down shows Specified Activities and that the AccelerateOp operation is 
visible in the left pane (if not, complete the steps in the IBD section, below). Then select the 
AccelerateAct activity in the central pane to add it to the selected items in the right pane (as 
above), and click the OK button. 

 

The relationship is now visible through the Items properties of both the operation and 
the activity.  

 

The key point to remember is that, although the names of the operation and activity do 
not need to be the same, their signatures must match in terms of the number, order, 
direction and type (but again, not names) of their parameters. 

We now have an Accelerate use case with a child sequence diagram and the HybridSUV 
block with an AccelerateOp operation that has an associated AccelerateAct activity as its 
implementation. We can now model how the AccelerateOp operation is used on the 
Accelerate sequence diagram. However, before we do this we need to replicate the 
situation in the original HSUV model where the HybridSUV block is used to type an HSUV 
vehicle as a part of the automotive domain. 
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33. In the Packages browser, right-click the HSUVStructure package and select New ► SysML ► 
Structure ► Block. Name the new block AutomotiveDomain. 

34. Now right-click on the AutomotiveDomain block and select New ► SysML ► Block Property 

35. Use the Type Selector window to select the HybridSUV block as the type for the part, and name the 
part HSUV. 

Acceleration is triggered by the driver depressing the accelerator pedal. The vehicle then 
responds by invoking acceleration behavior. 

36. Open the Accelerate sequence diagram, from the browser (by double-clicking), by double-clicking 
the Accelerate action frame on the diagram or from the Drive the Vehicle sequence diagram 
(Referenced Diagram context menu option). 

37. Use the Sequence toolbar button to create two sequence steps: ' driver depresses pedal' and 
'vehicle accelerates' (see the following diagram).  

38.  Drag the Driver actor from the HSUVUseCases package in the browser and drop it on the diagram, 
to the left of the system boundary. You will not be able to drop it to the right of this boundary, but 
you can position it anywhere to the left of this boundary, and in doing so, move the boundary. 

 
39. Use View Options to hide its full name. 

40. Now expand the HSUVStructure package (if necessary), expand the AutomotiveDomain block and 
drag the HSUV part somewhere to the right of the system boundary. 

41. Use View Options to not show the full name of the part. 

Now we will add some messages. We will use an event message to represent the event 
occurrence of the driver depressing the pedal. 

42. Select the Event toolbar 

button  and click on the 
Driver lifeline in line with 
the 'driver depresses pedal' 
step. 
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43. Move the mouse pointer to the right and click on the HSUV:HybridSUV lifeline. 

44. In the Select Object window click the New button and name the event message 'depress pedal'. 

An event message is created on the diagram and the 'depress pedal' event is created in 
the HSUVUseCases package (as this is the package that indirectly scopes the diagram). 

Now we will add the AccelerateOp operation. 

45. Expand the HybridSUV block in the 
HSUVStructure package to see the 
AccelerateOp operation. 

46. Drag the operation from the 
browser and drop it on the 
HSUV:HybridSUV lifeline in line with 
the 'vehicle accelerates' step. 

This creates an operation message going from the HSUV:HybridSUV lifeline back to that 
lifeline. 

Some modelers may have chosen to capture this differently, for example, by having just 
a single step with the operation message going from Driver to HSUV. The approach we 
have taken is not necessarily more 'correct' but it does separate external events from 
internal behavior and it has also allowed us to demonstrate more of the tool 
functionality (a key objective for the tutorial). 

In PTC Integrity Modeler we can indicate that an operation is an 'event handler' through 
its properties. 

47. Open the properties for the 
AccelerateOp operation and 
select the Items tab. 

48. Select Events in the 'Show 
associated' drop-down list and 
click the Link button. 

49. Use the Link Editor window to 
select the depress pedal event 
and make the link as shown 
opposite 

The use of reference frames (InteractionUse) allows you to structure sequence diagrams 
to any number of levels. We will now examine an alternative way to model behavioral 
decomposition by considering the detail of the Start Vehicle sequence diagram. 

Unlike the Accelerate use case, where the next level of decomposition below the 
sequence diagram is described using the AccelerateAct activity diagram, we will model 
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the Start Vehicle use case at two levels: black box and white box. This will also allow us 
to illustrate the other decomposition mechanism in Modeler's sequence diagram. 

50. In the Package Browser, rename the existing Start HSUV sequence diagram to 'Start Vehicle – black 
box' (either right-click and use Rename, or left-click twice (not a double-click) on the name). Then 
open the diagram. 

At this black box level we want to show the driver turning the ignition key and the HSUV 
dealing with this event. This is just a single message going from the Driver actor to 
HSUV. 

51. Use the Sequence toolbar button to create a description step 'driver starts vehicle'. 

52. Drag the Driver actor and the HSUV part (of the AutomotiveDomain block) tono the diagram, and 
use View Options to hide full names (as before). 

53. Select the Event toolbar button , click on the Driver lifeline, then on the HSUV lifeline – in both 
cases level with the 'driver starts vehicle' description step. 

 

54. Click the New button on the resulting Select Object window, and name the new event 'turn key'. 

This creates an event message 
going from the Driver to the 
HSUV, as opposite. 

It also creates a 'turn key' event, 
scoped to the HSUVUseCases 
package (which indirectly owns this diagram). 

Events in Modeler have a rich property set that you can see by selecting the event in the 
browser or the message on the diagrams and opening the property pages. 

55. Open the property pages for 'turn key' and select the Rate tab. 

This, and the other tabs, allow 
you to capture potentially useful 
information about this type of 
event in the model. The Help 
system has details if you want to 
know more. 
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Let us now consider the white box sequence diagram for the Start Vehicle use case. The 
HybridSUV block that types the HSUV part itself has parts. The white box diagram is 
going to show the detail of what happens inside a part typed by the HybridSUV block – 
the interactions between its parts when the 'turn key' message arrives. In practice, 
we're going to model only a little of what happens, enough to illustrate key concepts 
and techniques. To start we need to create the white box diagram and allow it to be 
referenced from the black box diagram. 

56. Right-click the Start HSUV use case and select New ► Sequence Diagram to create another 'Start 
Vehicle' child sequence diagram and rename it 'Start Vehicle – white box'. 

57. Immediately close the new diagram to return to the black box diagram. 

58. Drag the white box diagram from the browser and drop it on the HSUV:HybridSUV item on the 
black box diagram. 

 

A reference to the white box diagram now appears in the HybridSUV item name. This is 
called a 'PartDecomposition', implying the referenced diagram will show the internal 
interaction between the parts of HybridSUV.  

59. Right-click on the HSUV:HybridSUV item and select Referenced Diagram ► Open, to open the white 
box diagram. 

We could now go on to use this white box diagram to show the event message being 
detected by the ignition subsystem and a message being sent on to the power 
subsystem to power up the vehicle.  But to keep this tutorial at a high level we will now 
move on to look at the definition and modeling of Activities, another useful approach to 
understanding behavior. 

 

3.6 Defining Activities 

Activities are a key aspect of behavioral modeling in both UML and SysML. Much of 
SysML's activity modeling is identical to that of UML, but there are some differences. 
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The sequence diagram provides a different approach to the activity diagram as a way of 
modeling behavior. The key difference is that with sequence diagrams the focus is on 
the sequence of message passing between elements of the system, whereas with 
activity diagrams the focus is on flow of control and information between actions. 

Activity modeling "emphasizes the inputs, outputs, sequences, and conditions for 
coordinating other behaviors." [SysML]. The 'other behaviors' include other activities, 
thereby providing a model of activity decomposition similar to models of functional 
decomposition familiar to many systems engineers. An activity can own an activity 
diagram, which describes the detail of that activity in terms of a sequence of actions 
that may include the use of other, lower-level activities. The activity diagram can also 
indicate at what point specific inputs are required by actions and specific outputs are 
produced by them. These inputs and outputs can be typed by other model items, for 
example, blocks or value types. Activity modeling provides an extensive set of model 
items. To keep this section within reasonable limits, we will just consider its key 
elements; additional information can be found in the Modeler Help. To open the 
Modeler Help, from Modeler on the Help menu, click Help Topics.  

To illustrate the creation and use of activities and activity diagrams we will take a 
common way of using activities: the modeling of the detail for a use case, specifically the 
Accelerate use case. Activity diagrams have to be created from an activity. So what we 
shall do is create an activity from (and scoped to) the use case and use this to create the 
activity diagram. However, we will not necessarily want other activities we create on 
this diagram to also be scoped to the use case – in general, an activity is an independent 
reusable unit of behavior. Therefore we need to create a package (an HSUVActivities 
package) where these other activities can be held.  

1. Right–click on the HSUVModel package in the Packages browser, and select New ► Package to 
create the HSUVActivities package. 

2. Navigate to the AccelerateAct Use Case in the Package Browser. 

 

This is the activity scoped to the use case we created earlier. 

3. Now right-click the AccelerateAct activity and select New ► Activity Diagram. 
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The diagram is created 
scoped to the AccelerateAct 
activity (expand the activity 
in the browser to see it), and 
is given the name of its 
scoping activity. On the 
diagram you can see that the 
frame shows the name of the 
parent activity. 

We will start by adding some 
actions.  

4. Select the Opaque Action 
toolbar button , then click on the diagram. Name the action PushAccelerator. 

Opaque actions are often used in SysML modeling where simple execution semantics 
are required. PTC Integrity Modeler provides a comprehensive set of specific action 
types, many of which are more relevant to UML modelers needing to create 'executable' 
activities. You can see many of this set of action types by opening the drop-down list 
toolbar button . Other action types have their own toolbar buttons; these actions 
are often used in SysML modeling, although we will only make use of one of these (Call 
Behavior Action). Opaque actions themselves show their UML code oriented origination 
in that they have a Body and a Language property that can be used to define the 
semantics for the opaque action. For SysML modeling these properties are typically left 
empty, the action name and its pins (see later) are sufficient to adequately define its 
semantics. 

Our PushAccelerator action produces output (the accelerator position) that will be used 
by another action, as we will see shortly. We model inputs to and outputs from actions 
as pins. A pin is a type of object node (there are other types - Central Buffer and Data 
Store – also visible on the diagram toolbar).  

5. Select the Output Parameter/Pin toolbar button  and click on the right boundary of 
PushAccelerator on the diagram. Name it accelPosition. 

Expanding the AccelerateAct activity in the Packages 
Browser, as opposite, allows you to see its scoped items, 
including (at the foot of the list) its child activity 
diagram. As we add more items to the diagram this list 
will grow. 

Opaque actions are 'atomic' actions, they do not need further decomposition. Actions 
that are complex enough to require further decomposition can be modeled as Call 
Behavior Actions, actions that invoke the behavior of another activity. That activity can 
itself own an activity diagram that defines the more complex behavior, and which may 
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contain other Call Behavior Actions. Call Behavior Actions are one of main ways of 
handling behavioral decomposition in SysML. 

There are two ways to create a Call Behavior Action; one is to create the activity first 
and then drag it on to the diagram, the other is to use the diagram toolbar. We will 
show both, starting with the use of the toolbar. 

6. Select the Call Behavior Action toolbar button  and click on the diagram.  

This opens the Select Object window to allow you to select an activity that will be 
invoked through the Call Behavior Action. This may be an existing activity or you can 
create a new one. 

7. On the Select Object window, click on the New button, and name it MeasureVehicleConditions. 

The Call Behavior Action is created on the diagram as 
opposite. 

Note the colon character preceding the name; this is 
significant. Call Behavior Actions have a two-part name: the first part is the name of the 
action, the second part is the name of the linked activity. By default only the name of 
the linked activity is shown. 

8. Right-click on the 
MeasureVehicleConditions Call 
Behavior Action and select View 
Options. 

9. Select the Action Node entry, and 
then select the check boxes as shown 
opposite. 

Now you see both parts of the 
name (as shown below). When you 
create a Call Behavior Action, 
Modeler uses the name of the 
activity as the default name of the 
action. In general you are not so interested in the action name as the activity name – 

hence the default view option. 
Either name (action or activity) 
can be changed independently of 
the other. 

10. Open the properties for the Call Behavior Action and select the General tab. 

11. Use this property page to change the name of the Call 
Behavior Action to CBA1. 
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The name change is now visible on the diagram (as 
above). 

It is also reflected in the browser. You will see CBA1 
(shown opposite) together with its linked activity, 
both scoped to the Accelerate activity. 

This is an important point: the symbol on the diagram has two associated model items, 
the action – always scoped to the parent activity of the diagram, and the linked activity 
– which may or may not (as we are about to see) be scoped to the parent activity. You 
will see many other examples in this section where a diagram symbol relates to two 
model items, the symbol item, scoped to the parent activity and a linked item which 
may or may not be scoped to the parent activity. 

You can normally see the linked item from the properties of the diagram symbol item, as 
shown in the following exmaple.  

 
Note also that this property page allows you to open the properties of the linked item. 

When you create an activity via the creation of a Call Behavior Action the activity is 
scoped to the parent activity of the diagram. This may be what you want (for example, if 
MeasureVehicleConditions only ever gets used within the context of the Accelerate 
activity), but it does somewhat contradict the principle of activities as independent 
reusable behaviors. However, to rescope the activity is easy: you simply drag the activity 
to the required destination - normally a package. 

12. In the Package Browser, drag the MeasureVehicleConditions activity from the Accelerate activity to 
the HSUVActivities package. 

This activity should now scoped within the package, as 
opposite. Note that this rescoping has no effect on the 
diagram. Nor does it affect the Call Behavior Action in 
the browser. 

We now want to model that this activity, and therefore the Call Behavior Action invoking 
it, produces an output. 
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13. Select the Output Parameter/Pin toolbar button, click on the right boundary of the Call Behavior 
Action on the diagram and select New Pin ► New Parameter. 

 

14. Name the Pin/Parameter vehCond. 

As you can see in the browser pane this has created two model items: 

 A pin scoped to the Call Behavior Action. 

 A parameter belonging to the linked activity. 

Both items have identical properties, including 
their name, direction and type (had we defined one). Unlike the Call Behavior Action 
and its linked activity, these common properties are linked; changing the name for the 
pin will result in the parameter name also changing. You might want to explore and 
possibly change the properties of these items. If you do make sure you set them back to 
their current settings before continuing. 

Now let's see the alternative way to create a Call Behavior Action. This time we will 
create the activity and its parameters first and then drag it to the diagram. 

15. Right-click the HSUVActivities package in the browser, select New ► SysML ► Behavior ► Activity 
and name the activity ProvidePower. 

16. Now right-click the ProvidePower activity, select New ► Parameter and name it accelPosition. 

17. Repeat the previous step to create three further parameters called 
vehCond, drivePower and transModeCmd (as opposite). 

 

18. Use the Options property 
page for both drivePower and 
transModeCmd to set their 
direction (Mechanism) to Out (as 
opposite). 

 

 

19. Now drag the ProvidePower activity to the diagram. 
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This creates a Call Behavior Action, on the diagram and - scoped to the Accelerate 
activity - in the browser. Note again that the Call Behavior Action has the same name as 
its linked activity.  

Expanding the Call Behavior Action in the browser (as 
opposite) you will see that Modeler has also created four pins, 
one for each of the four activity parameters, giving them the 
same name and direction as the parameters (the browser icon 
is slightly different for input and output pins). 

There are also four pins on the diagram although they are overlaid so you will need to 
move them to see them all clearly. 

20. Move your actions and pins so that your diagram resembles that shown below. Resize the 
ProvidePower Call Behavior Action as necessary. 

 

We now need to consider flow, both flow of control and flow of data. The concept of 
'flow', is central to UML/SysML activity modeling. Conceptually, what flows are tokens; 
control tokens to represent transfer of control, object tokens to represent the 
availability of objects or data. It is not the objective of this section of the tutorial to 
provide a detailed explanation of activity modeling concepts and elements – for that you 
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should refer to a SysML or UML text – but we do need to show how certain key concepts 
and elements have been implemented in PTC Integrity Modeler. 

Control flow is concerned with defining execution order for the actions. It is often the 
case when refining an activity into its composite actions that there is a definite 
sequence, with various control nodes being used to specify starting, stopping, 
branching, merging, etc.. The Accelerate activity is interesting because its three actions 
are not executed sequentially, but in parallel and continuously. The power provided is 
continuously adjusted according to the accelerator position and the vehicle conditions. 
Let's see how we model that. 

21. Select the Fork Node toolbar button  and click on the diagram above the three actions. 

This creates a control node that allows you to model situations where a single incoming 
flow is split into multiple outgoing parallel flows. The Fork can be lengthened to cover 
the three actions as in the diagram that follows. 

22. Select the Join Node toolbar button  and click on the diagram below the three actions. 

This creates another control node (looking very similar to the fork node) that allows 
multiple incoming parallel flows to be joined into a single outgoing flow. 

23. Use the Initial Node toolbar button  to add an initial node above the fork node. 

24. Use the Activity Final Node toolbar button  to add this node below the join node. 

Your diagram should now look similar to this. 
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We use control flows to show flow of control through actions and control nodes on an 
activity diagram. In SysML, as opposed to UML, control flows can be modeled using 
either dashed lines or solid arrowed lines. Dashed lines are used by default, although 
this can be changed through View Options. Control flows have a name but by default 
these names are not shown on the diagram. They can also have a guard condition 
defined (through their properties); guard conditions, where they exist, are shown by 
default. You can use View Options for the diagram to preset display options, or View 
Options for individual items to change default settings.  

Control flows are directional, as implied by the arrow. It is therefore important when 
adding flows to click first on the sender and then on the receiver. You will find that 
Modeler has a number of built in checks that stop you creating illegal control flows (for 
example, multiple incoming flows to a fork node). It is generally safer to use Delete from 
Model (from the context menu) rather than the Delete key to remove incorrect flows. 

25. Use the Control Flow tool bar button  to add control flows as shown below. 

 

Note that control flow lines can be moved or have waypoints inserted in situ (left click) 
or afterwards (select and drag). Note also that in the above image we have used View 
Options to hide the action type for the MeasureVehicleConditions Call Behavior Action.  
Note that you can also hold down the [Ctrl] key to create more than one flow line 
without needing to click the toolbar button each time. 

Now we will add the object flows to show data flow in our model. 

accelPosition

PushAccelerator

vehCond
CBA1 : MeasureVehicleConditions
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vehCond

drivePower

transModeCmd

: ProvidePower

Accelerate

accelPosition

PushAccelerator
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vehCond
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vehCond
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vehCond
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transModeCmd

: ProvidePower
accelPosition

vehCond

drivePower

transModeCmd
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Object flows in SysML must have a solid line. They have similar name and guard 
properties as control flows, but in addition have a more complex set of properties as 
seen through the Options tab in Modeler. It is beyond the scope of the tutorial to 
address the meaning of these additional properties; the Modeler Help system has some 
information about them, but for a detailed understanding you should read the UML 
specification or an appropriate UML/SysML text. 

As with control flows Modeler imposes UML/SysML defined restrictions on where and 
how these can be used. Object flows are only permitted between object nodes (such as 
pins) or certain control nodes (such as forks and joins). Object flows are also directional, 
so similar rules apply regarding defining and changing direction – you will find, for 
example, that Modeler will not allow you to create an object flow going to an output 
pin. 

26. Use the Object Flow toolbar button  to add object flows between the two accelPosition pins and 
the two vehCond pins. 

This leaves us with the two output pins of ProvidePower having no outgoing object 
flows. These two pins produce outputs that are available as parameters of the parent 
activity of the diagram, Accelerate. If the Accelerate activity already had a set of 
parameters, you could simply drag the required parameters to the diagram frame 
boundary to create the boundary pins to act as destinations for the object flows. 
However, Accelerate currently has no parameters so it is easier to create both the pins 
and the parameters at the same time using the Output Parameter/Pin toolbar button. 

27. Select the Output Parameter/Pin toolbar button  toolbar button and click on the right boundary 
of the diagram frame. 

28. Select New Pin ► New Parameter, and name it drivePower. 

A large rectangular pin is added to the frame, with an arrow 
indicating direction. In the browser two new entries have 
now appeared scoped to the Accelerate activity: 

 A new drivePower parameter; 

 The new drivePower pin. 

 

29. Add the other Parameter/Pin to the diagram frame and the 
Accelerate activity, naming it transModeCmd (see the final diagram that follows).  

30. Create object flows going from the two output pins on ProvidePower to the pins on the diagram 
frame. 



Model-based Systems Engineering with SysML 

57 

The final issue to address for this diagram is to indicate that the model of object flow we 
have created is continuous. SysML (and the SysML Profile) provides a «continuous» 
stereotype that can be applied to flows ('activity edges' to give them their formal name) 
and parameters. Whether you show «continuous» against a flow or a parameter pin is 
to some extent dictated by the actual model, but also by personal preference. We will 
include an example of both. 

Modeler provides a quick and easy mechanism for allowing you to see all stereotypes 
that can be applied to a model item and then selecting one to be applied. You can use 
this mechanism from a diagram or from a browser pane. 

31. Right-click on the object flow 
between the two accelPosition 
pins and select Applied 
Stereotypes ► 1 Continuous. 

Nothing appears to happen. Hiding or showing of applied stereotypes is often 
determined by View Option settings. 

32. Right-click on the object flow again and select View 
Options. 

33. Select the Stereotypes entry, select the Show 
Stereotypes check box (as opposite), and click the 
OK button. 

Still nothing seems to appear. 

34. Right-click on the diagram background and select View Option. 

35. Scroll down to Shown Stereotypes and click the link button. 

36. Scroll down to the 'Continuous' stereotype and select its check box. Click OK, then OK again. 

 

The stereotype now appears and can be moved anywhere along the object flow.  
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37. Use the same approach (steps 31-33) to apply and show «continuous» on the object flow between 
the two vehCond pins. 

Rather than apply «continuous» to the drivePower object flow, this time we will apply it 
to the drivePower parameter of the Accelerate activity and show it on the associated 
diagram frame pin. Remember the parameter and the pin are separate but linked model 
items. SysML states that «continuous» can be applied to a parameter, but it cannot be 
applied to a pin. However, Modeler recognizes that most modelers would want to see a 
stereotype that has been applied to a model item on a diagram element that is linked to 
the stereotyped model item. If we apply a stereotype to a parameter, we want to be 
able to see the stereotype on the linked pin. (The same is true for other similar 
situations; for example, you want to be able to see a stereotype applied to an activity on 
a Call Behavior Action that is linked to that activity.) 

38. In the Package Browser, right-click the drivePower parameter of the Accelerate activity and select 
Applied Stereotypes ► 1 continuous. 

39. Now right-click on the drivePower pin on the diagram frame (not the one on the ProvidePower Call 
Behavior Action) and use View Options to show the stereotype. 

The final diagram should look similar to this. 

 

To finish this section on activity modeling we will develop the concept of activity 
decomposition a little more and introduce a few more activity modeling items. 
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40. In the Package Browser, right-click the ProvidePower activity (in the HSUVActivities package), and 
select New ► Activity Diagram. 

This will create a child activity diagram for ProvidePower (as you would expect) for you 
to define the detail of that activity. Note how the four parameters of ProvidePower have 
resulted in the automatic addition of four linked pins on the diagram frame.  

We will not evolve this diagram in any great detail, just sufficient to illustrate the 
additional elements. 

The first of these additional elements is an activity partition (often called a swimlane). 

41. Select the Activity Partition toolbar button  and click on the new diagram, inside the frame. 
Name it pcu. 

42. Create a second activity partition (in the same way) named eng. 

You will have noticed that the default is for activity partitions to be created horizontally. 
You can use View Options to 
arrange them vertically if you 
prefer. 

43. Select both activity partitions (drag 
over both or use the Ctrl key), right-
click on one of them and select View 
Options. 

44. Select Vertical as the Symbol 
Orientation and set the check boxes 
exactly as shown opposite (no name 
shown, show linked item name and 
show type). 

45. Click the OK button. 

The result is to display them vertically but also to hide their names. You can, of course, 
still see their names in the browser, scoped to the parent ProvidePower activity. The 
reason we set the View Options the way we did was because we are about to link each 
activity partition with another model item and it is the linked item name and type that 
we want to see. 

The items we are going to link with are parts of the PowerSubsystem block.  We will 
create this block now. 

46. Right-click on the HSUVStucture package in the Packages Browser, select New ► SysML ► 
Structure ► Block and name the Block PowerSubsystem. 
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We now need to create two parts ; 'ice' part, typed by the InternalCombustionEngine 
block, and the 'ecu' part, typed by the PowerControlUnit block.  We will explain and use 
these parts later in this tutorial. 

47. Right-click on the PowerSubsystem Block in the Packages Browse, selectr New ► SysML► Block 
Property, select the option New Type, leave the Type as Block and type the name 
InternalCombustionEngine, click OK  and name the Block ice. 

48. Repeat the previous step to create the ecu:PowerControlUnit part. 

The rationale behind this linking will become clearer with the next section of the 
tutorial, but is basically to link (or ‘allocate’) behavior to structure, in this case linking 
the ProvidePower activity to the PowerSubsystem block. 

49. Use the property pages to identify the 'eng' activity partition by selecting an activity partition on 
the diagram and using the property pages to see which one has been selected. 

50. Drag the 'ice' part from the Packages Browser to the name compartment of the 'eng' activity 
partition. Then widen the activity partition so that the name and type appear on a single line. 

51. Now drag the 'ecu' part to the name compartment to the other activity partition and widen that 
partition also. 

The reason we have linked the activity partitions to parts of the PowerSubsystem is to 
indicate a structural location for any action nodes or object nodes placed in those 
activity partitions. As we add items to this diagram we will need to enlarge the activity 
partitions. To make this easier we can join individual activity partitions to form a single 
group that can be re-sized as a unit (rather than having to re-size each activity partition 
separately). 

52. Arrange both activity partitions with the ice 
partition to the right of the ecu partition, as 
opposite. 

You will notice the small red triangles in the 
top-left corner of each partition. This triangle 
symbol is used to indicate an activity 
partition group. Currently each partition is in 
a group of its own. 

53. Select and drag the ice partition across to the ecu partition until you see the cursor pointer change 
to the symbol shown opposite and then release 
the mouse button. 

The result is to create a single group (just 
one red triangle) with both partitions 
adjacent to each other. You will find that you 
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can now move and re-size as a group but still select individual partitions when required. 

There is considerable flexibility in how you can use this drag-drop capability to structure 
activity partition groups. The Modeler Help has full details. 

Now we will add a Call Behavior Action. 

54. Create a new activity in the HSUVActivities package called ProportionPower (New ► SysML ► 
Behavior ► Activity). 

55. Create two input parameters for ProportionPower called beltCond and speed (New ► Parameter). 

56. Now drag ProportionPower from the browser and drop it inside the ecu activity partition. 

If you move the activity partition group, you will see that the Call Behavior Action also 
moves within its activity partition. This is further confirmation that the activity partition 
provides a conceptual 'location' for the Call Behavior Action.  This can also be seen 
through their properties, as indicated below ('pcu' is the activity partition name). 

 

Note how the two parameters result in two input pins being created on the Call 
Behavior Action (although you will need to separate them). To finish our work on this 
diagram, we will see how these pins get their data. 

57. Move the diagram frame (ProvidePower) a little to the right. 

58. Drag the vehCond parameter around the boundary of the diagram frame to the left edge (see 
opposite). 

59. Select the Decision Node 

toolbar button  and 
click on the diagram 
between the vehCond 
pin and the ecu activity 
partition. 

60. Create object flows as 
shown opposite. 
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We would normally complete the detail of the ProvidePower activity before addressing 
the next layer in the activity decomposition, that is, creating activity diagrams for 
ProportionPower and any other linked activities for Call Behavior Actions created for 
ProvidePower. 

 

3.7 Defining Blocks 

As described in the Use Case modeling section, Blocks, in SysML, provide a means of 
describing a system as a hierarchy of modular components, each of which can have a set 
of structural and/or behavioral features. The block definition diagram (BDD) is 
principally used to capture block properties and relationships. The internal block 
diagram (IBD) is mainly used to define the internal structure of a block, how the 
internals parts are connected and what flows between them. 

If you have already created the HSUVStructure Package and the HybridHUV Block during 
the Use Case modeling section, you can ignore the following step 1.  If not, follow all of 
the steps. 

To begin we will create a package within the HSUVModel to hold this structural 
information, and from which we can create the diagrams and items we will need. 

1. Right-click on the HSUVModel package in the Package browser, and select New ► Package. Name 
it HSUVStructure. 

3.7.1 Block Definition Diagram (BDD) 

We will start by creating a BDD in our new package. 

2. Right-click on the HSUVStructure package and select New ► Diagram ► SysML ► Block Definition 
Diagram as shown in the following image. Leave the diagram name as the default. 
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This creates a BDD with the same name as the package scoping it. We will use this to 
build a preliminary block hierarchy for the HSUV. 

If you have already created the HybridSUV Block during the previous sections, you can 
ignore the following steps 3 and simply drag it onto the diagram.  If not, follow all of the 
steps. 

3. Select the Block toolbar button , and click on the diagram within the frame. Name the block 
HybridSUV. 

If you have already created the PowerSubsystem Block during the previous sections, you 
can also drag it onto the diagram and create only the BrakeSubsystem and 
ChassisSubsystem blocks in step 4. 

4. Create three other blocks on the diagram, either using the Block toolbar button, or by right-clicking 
the HSUVStructure package in the browser, selecting New ► SysML ► Structure ► Block (see the 
previous screen image) and then dragging the block to the diagram. These blocks should be named 
BrakeSubsystem, ChassisSubsystem and PowerSubsystem (if you do not already have it). 

To show that these subsystems are composite parts of the HybridSUV we create 
composition relationships. 

5. Select the Composition toolbar button , first click on 
HybridSUV, then click on BrakeSubsystem. 

You diagram should look similar to this, and in the browser 
you will see a new block property, scoped to the HybridSUV 
block, so that you can name it in-situ.  

6. Through the General tab of its Property Pages, name the 
composition relationship 'bk'. 

You will see that the block property BrakeSubsystem is shown on the HybridSUV block 
(you may want to hide the compartment as was shown before, the parts tag is under the 
roles section).  

We have modeled that one HybridSUV contains 1 part called bk that is typed by the 
BrakeSubsystem block. Part names are also called role names (the part plays a specific 
role with the parent block). Both the numbers and the part/role name can easily be 
changed. 

7. Open the properties for the 
composition relationship and select 
the End Role tab, as opposite. 

8. Select the tbd entry from the drop-
down list (as shown opposite). 
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This property page provides an excellent way to understand the associations between 
blocks, particularly if you are new to or unfamiliar with the SysML modeling notation.  
You can read the association.  In this example, the Brake Subsystem is part of only one 
Hybrid SUV.  You can also use these properties to change the part/role name. There's 
nothing significant about bk, it's just the identifier we have chosen to use to name the 
instance of the BrakeSubsystem within the HybridSUV.  Changes to the properties in the 
property page are automatically reflected in the diagram notation.  This also helps you 
learn SysML.  Note that, on the diagram, you can move the role name around the 
composition relationship to which it belongs. The tbd (to be decided) selection simply 
means that you will see no multiplicity value on the diagram (as in the original diagrams 
in the SysML specification). As you can see, you have a range of options for the 
multiplicity value, including 'user defined' that allows you to specify, for example, 2 if 
you had two separate brake subsystems in the HybridSUV. 

9. Select the Start Role tab and set the HybridSUV multiplicity value also to tbd. 

10. Create two other composition relationships, with their end role names set to 'c' and 'p' and their 
multiplicity set to tbd in each case (as shown in the following example). 

 

Note the effect that these diagram changes are having in the 
Packages browser. The part/role names are showing within 
the HybridSUV block to indicate the three top-level parts of 
that block; each part entry also shows the name of the block 
that types that part. 

11. On the diagram, create another block called BrakePedal and then 
create a composition relationship from BrakeSubsystem to BrakePedal (role name is bkp, 
multiplicities are tbd). 

12. Create a composition as before between PowerSubsystem and BrakePedal. In the property pages 
select the Options tab and clear the Composite Aggregation check box. 

This creates a similar looking relationship to composition, except that the diamond is 
unfilled (see the following diagram). In SysML this type of relationship is used to model a 
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shared item. The BrakePedal instance that belongs to the BrakeSubsystem, is shared by 
the PowerSubsystem. We will see the implications of this shortly. Composition (part 
association, in SysML terminology) and aggregation (shared association) have similar 
sets of properties. You can use the Shared Composition button to create this link. 

13. Select the shared association from PowerSubsystem to BrakePedal and use its properties to set the 
End Role role name to bkp and the multiplicities to tbd. 

Your diagram should now look much like this. 

 

The BDD tells us what blocks have what parts and what type (of block) those parts have. 
In the Packages Browser, you should see these five blocks and the diagram within the 
HSUVStructure package. Note that you cannot expand the HybridSUV's bk part (to see 
its contained bkp part) in the Packages Browser, you have to select the Parts Browser to 
see multiple levels of decomposition. 

As well as showing part properties, BDDs can also be used to create and show other 
block features. You will find BDD toolbar buttons for both Block Property (Value) and 
Operation. Selecting either of these and clicking on a block on the diagram will create a 
value property for the block or a block operation (a function carried out by the block). 
You can also create block features in the browser by right-clicking the block and using 
the New context menu option. 

In practice, as your structural model becomes more complete, the use of compartments 
on a BDD can be a very useful way to see a variety of block properties. As well as the 
examples we've already mentioned, you can also show compartments for constraints, 
references and ports. 

bdd [Package] HSUVStructure [1]

«block»

parts
«BlockProperty» bk : BrakeSubsystem
«BlockProperty» c : ChassisSubsystem
«BlockProperty» p : PowerSubsystem

HybridSUV

«block»

parts
«BlockProperty» bkp : BrakePedal

BrakeSubsystem

«block»

ChassisSubsystem

«block»

references
«BlockProperty» bkp : BrakePedal

PowerSubsystem

«block»

BrakePedal

bk pc

bkp
bkp
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3.7.2 Internal Block Diagram (IBD) 

It is important to note that what we haven't captured so far is information about the 
connectivity of the parts. The composition and aggregation relationships on the BDD 
show 'ownership' not 'connectivity'.  

1. Right-click on the HybridSUV block on the diagram and select New ► SysML ► Internal Block 
Diagram. 

 

2. Change the default diagram name from '[Block] HybridSUV [1]to '[block] HybridSUV [Part 
Connections]'. 

We want to add the three parts we defined earlier inside the IBD frame – the frame 
representing the HybridSUV block. We could do this by dragging the parts from the 
browser to the diagram, or we could use a Populate context menu option. 

3. Right-click inside the IBD diagram frame and select 'Populate ► Nodes ► Block Properties'. 

 

The HybridSUV parts are added to the diagram, you should now drag them to the 
position you want (see the final IBD below). Note how the parts are shown with the 
parent Block name and the part name (the role name from the BDD), followed by the 



Model-based Systems Engineering with SysML 

67 

part type (the block that types the part). This can be changed if required using View 
Options; we will look at View Options again shortly. Now we will model the connections. 

4. Select the Shallow Connector toolbar button , click on part c, then click on part bk. 

5. Drag the connector line to create a waypoint if you want one, and with the connector selected 
open its properties. 

6. Select the General tab and change the default 
name (Connector) to c-bk (as shown opposite). 

By default, connector names are not shown 
(they often clutter the diagram). To hide or 
show information on diagrams in Modeler, you 
use the context menu View Options. 

7. Right-click the c-bk connector line and select 
View Options. 

8. Select the Association entry (a connector 
defines an association between parts), and 
select the Show Name check box to show the 
name on the diagram. Click the OK button. 

9. Create another shallow connector from part p 
to part bk, name it p-bk, and show the name 
on the diagram. 

We could have left the use of the View Options until both connectors were created. 
Then, by selecting both connectors (using the Ctrl key), we could have right-clicked on 
either and set View Option for both. You will find that you can multi-select similar items 
on many diagrams to change their View Options collectively, rather than individually. 

Your diagram should look similar to the one that follows. You can resize most of the 
items if you wish by selecting them and then dragging a border.  
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3.7.3 Ports, Interfaces and Item Flows 

After we start to consider connectivity of parts on an IBD, we will also start to think 
about exactly how the parts are connected and what items can flow between them. This 
leads us to modeling ports, interfaces and item flows. 

In doing this we will also illustrate another important concept in SysML modeling: layers 
of abstraction. Having modeled high-level subsystems and their basic connections, we 
will now drill down inside the PowerSubsystem block to see (some of) its internal 
structure and connectivity. This time however, we will start with an IBD and create the 
blocks we require to type the parts as we go. 

1. In the Packages browser, right-click the PowerSubsystem block within the HSUVStructure package, 
and select New ► SysML ► Internal Block Diagram. (You can leave the default name for the 
diagram - [block] PowerSubsystem [1].) 

2. Right-click the background of the diagram and select Populate ► Nodes ► Block Properties. 

If you have completed the previous sections of this tutorial, three parts will be added; 
the bkp, ecu and ice parts. The bkp part, typed by the BrakePedal block, which is owned 
by the BrakeSubsystem, but shared by the PowerSubsystem. The dashed boundary for 
the bkp part indicates it is a non-composite (in this case, shared) part. 

We can create parts, and if we wish the blocks that type them, on the IBD. 

3. Select the 'Block Property' toolbar button , and click inside the diagram frame. 

This brings up the Type Selector window, which defaults to allow you to select an 
existing (block) type but also allows you to create a new one. 

 

4. Select the New Type option that changes the Type Selector window to allow you to create a new 
block that will be the type for the part you are about to create. 

5. Enter the name Transmission for the new block, and click the OK button 

Two things will happen: in the browser, you will see the new InternalCombustionEngine 
block and on the diagram a new part – typed by this block – is created, with the input 
box selected for you to enter a part name to replace the default BlockProperty1. 

6. Enter the name trsm for the part. 
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7. If they do not already exist on the diagram, use the previous three activities as a guide, create one 
more part (ft) within the PowerSubsystem block as shown in the following example. 

 

As you see, the diagram is showing the full name of each Block Property. This can be 
changed for all the Block Properties, to simplify the diagram, if required. 

8. Right-click on the diagram background and select 'Default View Options (Profile)'. 
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9. Select the 'Set existing symbols to default options' check box at the bottom of the window, select 
the 'Block Property' check box, high-light the Block Property, double-click the 'Show Full Name' 
value to change the value to 'False', and click OK. 

This will set the default view option to not show Full Names for all Block Properties and 
apply that option to the existing symbols on the diagram.  Depending on the sequence 
you followed, you may also see the FuleInjector, FuelRegulator and FuelPump blocks.  
These cane be deleted from the Diagram (not from the Model) and the ice and ft Blocks 
resized to match the figure above. 

At this more detailed level of modeling, the connections between these parts will go via 
ports. We will illustrate the creation and use of standard ports, full ports and proxy ports 
as described in the SysML specification. 

Proxy Ports expose the owning block’s internal parts to the outside world. Therefore, 
any feature in a Proxy Port (flow or non-flow) is provided or used by something within 
the owning block. Proxy ports are not separate system parts – they are a window into 
the owning block and simply expose the block’s features. A Proxy Port is typed by an 
Interface Block.  

Full ports provide flow, non-flow, and/or behavioral features without exposing any 
other of the owning block’s internal parts or features. Full ports represent a separate 
system element – a part on the boundary of the owning block. They cannot be 
connected directly to other block internals: they must connect through Proxy Ports or by 
behavior invoked on them by other blocks. A Full Port is typed by another block. 

We will create standard ports on both the ice and ecu parts that specify the provided 
and required services for these parts. Consequently we will use an option that allows a 
standard port to be un-typed, the typing being achieved by the provided and required 
interfaces defined on these ports. 

1. Select the Standard Port toolbar button , and click on the ice part. 

2. When the Type Selector window appears, click the untyped option, click OK and name the port 
ctlPrt. 

3. Move the port around the edge of the ice part, and then move its name to 
the position shown opposite (for straight line connection to the ecu part). 

4. Use the last three activities to add a standard port to the ecu part. Name it 
icePrt, and position it for straight line connection to the ctlPrt.  

Now for the interfaces. An interface is one of the UML concepts 
reused by SysML. An interface defines a set of operations. 

5. Select the Provided Interface toolbar button , click the ctlPrt on the ice 
part, move the mouse pointer to the left (see opposite) of the port and 
then double-click. 
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6. In-situ, change the default name (Interface1) to I_ICECmds, as opposite.  

This creates the provided interface symbol on the diagram (as 
opposite). It also creates the I_ICECmds interface, scoped to the 
HSUVStructure package, in the model. You will see this in the 
browser: 

7. Now select the Required Interface toolbar button , click again on ctlPrt, 
move the mouse this time to the lower left (see the following image) of the port and double-click. 

8. Name the new interface I_ICEData. 

This also adds the required interface symbol to the diagram and adds the I_ICEData 
interface to the HSUVStructure package. 

The procedure for adding a provided or required interface to a diagram where the 
interface already exists in the model is very similar except that the double-click is with 
the right mouse button not the left mouse button. This opens the Type Selector window 
from which you can select the required interface. 

9. You should now use these same two toolbar buttons 
to create provided and required interfaces on the ecu 
part's icePrt port. However, note that for this port the 
interface selections are reversed: I_ICEData defines 
the provided interface, I_ICECmds defines the 
required interface. Remember to double-RIGHT-click 
to open the Type Selector. 

By default, when you create interfaces using the 
diagram toolbar, the interfaces are scoped to the package scoping the diagram. We will 
create a sub-package within HSUVStructure to hold these interfaces. 

10. Right-click on the HSUVStructure package in the Packages Browser, select New ► Package, and 
name the new package HSUVInterfaces. 

11. In the Packages Browser select each interface in turn, drag it and drop it on the HSUVInterfaces 
package name to rescope it. (Note that you could use the Contents pane to multi-select both 
interfaces and do the drag-drop in one operation.) 

The final step here is to add a shallow connector between these two ports. 

12. Select the Shallow Connector toolbar button , click on icePrt then click on ctlPrt (although the 
order is not important).  

We will take a look now at full and proxy ports, and we will start with proxy ports. Firstly 
we will create an Interface Block with a Value Type (Torque) to type the proxy ports that 
will be used to connect the ice part to the trsm part.  We will then show how you can set 
the unit and dimension properties for a Value Type. We could have created the Torque 
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Value Type, including any necessary units and dimensions, before attempting to use it 
when creating the flow port (as with the icePrt interfaces). 

13. Right-click on the HSUVInterfaces package in the Packages Browser, select New ► SysML ► 

Structure ► Interface Block, and name the new interface block iTransmPrt. 

14. Right-click on the iTransmPrt Interface Block in the Packages Browser, select New ► SysML ► 

Flow Property. 

15. Select the New Type option, select the Value Type (Data Type) from the drop-down list, enter the 
name Torque and click the OK button. 

 

  

16. When the Value Selector 
window appears, select the 
'out' option (the engine 
delivers torque to the 
transmission), and click the OK button and 
name the Flow Property t. 

The Package Browser now shows the Value 
Type, the Flow Property and the Port as a 
new Interface Block. 

We will now use these to create the Proxy Port on the diagram 

17. Drag and drop the iTransmPrt Interface Block into the boundary of the ice Part. 

18. Select the Proxy Port type and click the 
OK button 

 

19. Enter the name trsmPrt (you can 
rename block properties in the browser 
view at any time, using the context 
menu Rename option). 

The Proxy Port and its name can be repositioned 
anywhere on the boundary of the ice part. It will 
provide a connection to the trsm part, so is best 
placed opposite that. 

 

You can also choose whether to show one or both 
parts of its name using View Options (right-click 
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the port on the diagram). View options also exist to allow you to show multiplicity and 
to define the exact position of the port with respect to the part boundary.  

You will see that what you have created is a proxy port with an 'out' direction (as 
indicated by its contained arrow) because this was what you selected on the Value Type 
window. So, for the receiving port on the trsm part we need to create a proxy port of 
the same type but with an 'in' direction. 

20. Repeat the steps above to create an Interface Block called iICEPrt, with a Flow Property of type 
Torque  and a direction of In. 

21. This time, select the Proxy Port toolbar button, and click on the trsm part. In the Type Selector 
window choose Existing Type, select All Valid Types ► SysML ► All Interface Blocks and then select 
iTransmPrt from the list before clicking the OK button. 

22. Now drag the iICEPrt Interface Block onto the boundary of the trsm Part, select the 'Proxy Port' 
option, click OK and name the new port icePrt. 

Before we connect these two proxy ports and define what flows between them, we will 
just finish with the Torque value type we've created. Currently Torque is scoped by, and 
visible within, the HSUVStructure package. In practice, it may be sensible to create a 
separate package to hold types created specifically for the automotive domain. This 
could then be exported (see package import/export in the Help) and reused in other 
automotive projects. Because we will only need a couple of specific types we won't 
bother to do this now. But we should set the unit property for this value type. 

To do this we make use of the generic 'set' mechanism provided by the SysML profile. 
There is a Set context menu option for a number of model items where properties can 
be set – we will see some other examples later. However, first we need to create the 
Unit. 

23. Right-click on the HSUVStructure 
package and select New ► SysML ► 
Structure ► Unit, and call it ft-lbf. 

24. Right-click Torque in the Packages 
Browser and select Links ► Unit. 

25. Expand the All Valid Items ► All 
Units, then scroll down and select ft-
lbf, then press OK. 

You will see the ft-lbf unit scoped 
to the HSUVStructure package in 
the Packages Browser. Again we should probably re-scope this to the types package 
holding Torque (if we had one). 
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There is no visible evidence of the setting of qualityKind and unit properties, either in 
the browser or on the diagram. But we do see them in the property pages. 

26. Open the properties for Torque and select the 
ValueType (DataType) tab, as opposite. 

 

 

Now we will return to connecting the ports. Creating the connector is simple. 

27. Select the Shallow Connector toolbar button , click the trsmPrt on the ice part, then click the 
icePrt on the trsm part. 

To finalize this connection we will create an item flow for the connector. 

28. Select the Item Flow toolbar button , and click on the connector. 

For a connector between proxy ports, the type of the item flow must match the type of 
the ports. 

29. Name the item flow g1 (as in the original HSUV model). 

The connection should now look similar to that 
opposite. You can move the item flow and the flow 
name; you can also use View Options to hide or 
show item flow information. 

We will now create a connection between the ice 
and ft parts. Again, we will use an Interface Block 
to define the valid item flow types that can be sent 
and/or received across the ports.  

30. Navigate to the HSUVInterfaces package in the 
Packages Browser. 

31. Now right-click on the HSUVInterfaces package and 
select New ► SysML ► Structure ► Interface Block. Name it 
FuelFlow. 

We now need to define the set of flow properties for FuelFlow. Each flow property 
specifies a type and direction for one or more items that can flow in or out of a port 
typed by FuelFlow. 

32. Right-click FuelFlow and select New ► SysML ► Flow Property. 
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33. Use the now familiar Type Selector to create a new block type called Fuel, then select its direction 
as out. 

 

This creates a flow property within FuelFlow, typed by the Fuel block. 

34. Name the flow property fuelSupply. 

35. Use the last three steps as a guide to create a second flow property within FuelFlow, also typed by 
the now existing Fuel block, direction as in and called 
fuelReturn. 

The contents of the HSUVInterfaces package should 
look like that opposite. 

Now we can create the proxy ports. 

36. Select the Proxy  Port toolbar button once more, and click in the ice part. 

37. Use the Type Selector, and its Types list, to select the existing FuelFlow Interface Block as the type 
for the port. 

38. Name the port ftPrt (on the diagram). 

39. Position ftPrt along the bottom boundary of the ice part. 

40. Now create another proxy  port, also typed by FuelFlow, on the ft part. 

41. Name this port icePrt, and position it along the right boundary of the ft part. 

42. Now right-click icePrt (either on the 
diagram or in the browser) and select 
Set ► Is Conjugated (as opposite). 

43. In the Value Selector window, select 
TRUE. 
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The name of the block typing the port is now prefixed with a 
tilde (~) on the diagram to indicate a conjugated proxy port, 
using the same Interface Block as ftPrt, but where the flow 
property directions are reversed (that is, what is sent by ftPrt 
is received by icePrt, and vice-versa). 

Finally we will make the connection between these ports and add the specific item 
flows. 

44. Select the Shallow Connector toolbar button , and make a connection between the two flow 
ports (remember you can drag the connector line after creating it, to create a waypoint). 

45. Now select the Item Flow toolbar button , and click on the connector line. 

46. From the Select Conveyed Classifier window, select the Fuel interface block as the type for the item 
flow.  

47. Click the OK button. 

48. Select the ftPrt on the ice part as the destination of the item flow. 

 

49. Name the item flow fuelSupply. 

50. Use the previous steps as a guide to create another item flow, also of type Fuel, but going in the 
opposite direction to the icePrt on the ft part. Name the flow fuelReturn (so that it has the same 
name as the other flow property in the FuelFlow flow specification). 

Currently, the diagram 
should look similar to the 
one shown. Note we have 
also added a shallow 
connector to the bkp 
(BrakePedal) part. 

 

As this is a high level 
tutorial we will conclude 
this section.  However, 
you could also 
experiment with Full 
Ports if you choose to. 
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3.8 Defining Constraint Blocks 

In determining the physical structure of systems, systems engineers are frequently 
confronted with trade-off, performance, verification and validation issues that depend 
on the relationships between system properties such as cost, performance, power 
consumption and weight. 

Variables representing such properties and the mathematical relationships between 
them can be defined in SysML using constraint blocks and parametric diagrams. A 
constraint block defines a particular constraint (a formula and the variables it 
references). Constraint blocks are typically reusable specifications that can be related to 
other blocks in the model. A parametric diagram describes how constraints relate to 
specific properties of a block. Such constraints and constraint diagrams can then be used 
by the systems engineer to aid in the analysis of and decision-making about these trade-
off, performance, verification and validation considerations. 

The constraint that we will use to illustrate these concepts is the relationship between 
fuel flow rate (required to be delivered by the fuel pump as part of the fuel tank 
assembly), the fuel demand (from the fuel injectors in the engine), and the fuel pressure 
(produced by the fuel regulator, also in the engine). The formula relating these items is 
as follows: 

 flowrate = pressure /(n*demand) 

where n is the number of injectors. 

First we will create the constraint block and relate it to the PowerSubsystem block. 

1. Open the HSUVStructure BDD. (You will find this either by expanding the HSUVStructure package in 
the Packages browser, or through the Block Definition Diagrams folder in the Blocks browser – in 
both cases the full diagram name is '[Package] HSUVStructure []'.) 

2. Enlarge the containing frame on the diagram if necessary (see the final diagram that follows). 

3. Select the Constraint Block toolbar button , and click on the diagram below the 
PowerSubsystem block. Name the constraint block FlowConstraint. 

In the Packages browser, within the HSUVStructure package, you will see the 
FlowConstraint constraint block. 

We now need to define the three formula variables as parameters ('n' will be fixed at 4 
for us as there are 4 injectors). Constraint Parameters can be created through the 
diagram toolbar, or from a Constraint Block in a browser by using the New ► SysML ► 
Constraint Parameter command. We will use the diagram toolbar. 
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4. Select the Constraint Parameter toolbar button, and click on 
FlowConstraint. 

5. Use the Type Selector window to select the Value Type Real (All 
Valid Types ► All Value Types (Data Type) ► Real (SysML 
Profile::Primitive Value Type)) as the type for this parameter. 

6. Name (in situ, in the browser) this first parameter: flowrate. 

Note how Modeler automatically adds a Parameters compartment to the constraint 
block on the diagram, with the parameter name and type shown.  

7. Create the other two parameters (pressure and demand, both also of Value Type Real). You might 
like to try to use the context menu approach from the browser. 

We will now use these parameters to specify the constraint for 
FlowConstraint.  

If you expand FlowConstraint in the browser, below the three 
parameters you will see an item called Constraint1. It is through 
Constraint1 that we specify the constraint. 

This is an area of SysML inherited from UML, the SysML constraint block acting as a 
'wrapper' for the UML constraint, the constraint (or constraints – there can be more 
than one) being a property of the constraint block. 

The constraint itself has a set of properties and it is through these that we specify the 
formula. 

8. Select the constraint (Constraint1, 
not the constraint block) in the 
Packages Browser, open its 
properties and select the Full Text 
tab. 

9. Enter the formula (as opposite) by 
dragging the parameter names 
from the browser and dropping 
them into the Full Text field to 
create the blue hyperlink,s and 
typing the other characters. 

Click on the diagram and you will see that the formula has been entered into the 
Constraints compartment of the constraint block.  

Finally, for this diagram, we should model the relationship FlowConstraint has with the 
PowerSubsystem block. We will use a composition relationship, to indicate that a 
specific usage (instance) of the constraint block is owned by PowerSubsystem. 
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10. Select the Composition Association toolbar button , click first on the PowerSubsystem block, 
then on FlowConstraint. (You can add a waypoint by left clicking at any point.) 

You have used this relationship before and should therefore be familiar with the use of 
the composition properties to set the role name and multiplicity values 

11. Set the role name to fc, and the multiplicity values to tbd. 

The BDD should now look similar to this.  

 

We can now move on to create a parametric diagram that will show how the 
parameters for FlowConstraint relate to specific value properties of the 
PowerSubsystem component. 

However, before we can do this we should elaborate the internal structure of 
PowerSubsystem a little more, to create the components directly involved in fuel flow. 

12. Close the HSUVStructure BDD and open the [Block] PowerSubsystem [1] IBD (either from Packages 
browser by expanding the PowerSubsystem block, or from the Blocks browser Internal Block 
Diagrams folder).  

13. Select the Block Property toolbar button , and click inside the 
ft part to create a part within ft called fp typed by a new block 
called FuelPump. 

bdd [Package] HSUVStructure [1]

«block»

HybridSUV

«block»

BrakeSubsystem

«block»

ChassisSubsystem

«block»

constraintProperties
«ConstraintProperty» fc : FlowConstraint

PowerSubsystem

«block»

BrakePedal «constraint»

constraintParameters
«ConstraintParameter» demand : Real
«ConstraintParameter» flowrate : Real
«ConstraintParameter» pressure : Real

constraints
{flowrate=pressure(4*demand)}

FlowConstraint

bk p
c

bkp

bkp fc
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14. In a similar way, create two new parts within the ice part: fi typed by a new block called 
FuelInjector, and fr typed by a new block called FuelRegulator. 

15. Now right-click the new fi part and select 
Set ► Multiplicity, as opposite. 

 
16. In the Value Selector window select User 

Defined and enter the number 4 in the 
text box. 

17. To show the multiplicity value, right-click fi again and use the View Options. 

Each of these new parts needs to have a value property that will relate to each of the 
constraint block parameters. Parts have value properties as defined by the blocks that 
type those parts. This means that we have to create the value properties through the 
block that types each part rather than through the part itself. 

18. Right-click on the FuelPump block in the browser and select New ► SysML ► Block Property. 

 

19. Use the Type Selector to define an Existing Type for the value property and select Value Type Real 
(for compatibility with the parameter). Name the value property flowRate (upper case R to 
distinguish it from the parameter name). 

 

20. Use the last two steps to create value properties for the FuelInjector and FuelRegulator blocks, both 
of Value Type Real, names are fuelDemand (for the injector) and fuelPressure (for the regulator). 
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21. Select the Parts Browser, locate the PowerSubsystem block and expand it as follows. 

Although we have created these value properties for the blocks, parts typed by those 
blocks will have these same properties. You can clearly see them in the Parts browser. 

Note that 'fc : FlowConstraint', with its three parameters, 
is also visible as a part of PowerSubsystem (a 'constraint 
property' in SysML). 

It is an important requirement of SysML that all elements 
that appear on a parametric diagram are scoped, at some 
level, by the parent block of that diagram. Using the Parts 
browser allows us to drill down into all the levels of 
nested parts for a block to confirm that we have all the 
required elements. 

Now that we have done all the hard work, creating the 
parametric diagram is pretty straightforward. 

 

22. Right-click the PowerSubsystem block in the Parts browser and select New ► SysML ► Parametric 
Diagram (you can leave the default name for now).  

The diagram will open but its name does not appear scoped to the PowerSubsystem. 
This is because we are using the Parts browser and the diagram is not a part of the 
block. It is scoped to the block though, and this is clearly visible in the Packages pane. 
However, we want to stay with the Parts browser pane for now, so to change the 
diagram name we do so on the diagram, rather than in the browser. 

23. Select the diagram frame and then click in the frame header. This will allow you to change the 
default diagram name to '[block] PowerSubsystem [Fuel Flow]'. 

24. Now ensure the Parts browser pane is selected and the PowerSubsystem block is expanded as 
shown in the preceding image. 

25. Then drag the 'fc : FlowConstraint' constraint block from the Parts browser pane to the center of 
the diagram. 

26. Right-click on 'fc : 
FlowConstraint' on 
the diagram and 
select Populate ► 
Nodes ► 
Constraint 
Parameters. 
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27. Right-click 'fc : FlowConstraint' and select Show/Hide Compartments. Expand the Roles folder, and 
select the constraints check box to show 
the constraint formula. 

28. Move the parameters and their names, 
and resize the box, as shown here.  

29. Now drag the flowRate block property 
of the fp part within the PowerSubsystem structure (see opposite) to the diagram. Place it below, 
but close to the flowrate parameter (see the following diagram). 

30. Select the Shallow Binding Connector toolbar button , and 
connect the flowRate value property to the flowrate parameter 
(see the following diagram). 

31. Now drag the fuelDemand block property of the fi part 
(see opposite) to the diagram and connect it to the 
demand parameter. 

32. Finally drag the fuelPressure block property of the fr part 
to the diagram and connect it to the pressure parameter. 

The final diagram should look similar to that which follows. Note the names on the value 
properties, showing their scoping. The key point to be aware of here is that we have 
been able to drag these items to the diagram because they are all parts within the 
PowerSubsystem block that owns the diagram. 

 

We have now modeled a parametric relationship between value properties of parts 
within the PowerSubsystem. 
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3.9 Allocation 

We will now briefly consider the topic of allocation. Allocation, in SysML, is a general 
term for cross-associating items from different parts or levels of a model. It normally 
involves the creation of the 'allocate' relationship and its visibility on diagrams and in 
tables. We will illustrate the use of this relationship in the common context of allocating 
behavior to structure.  

In the previous sections we showed an example of creating a Call Behavior Action in an 
activity partition (the 'ecu' swimlane) on the basis that the parent activity for that 
diagram (ProvidePower) was in some way linked to the PowerSubsystem block that 
contained the 'ecu' part. We can now make this 'link' more concrete using allocation. 

1. In the Packages Browser expand the HSUVStructure package (if necessary) to expose the 
PowerSubsystem block.  

2. Expand the HSUVActivities package (as opposite) to 
expose the activities created earlier, including 
ProvidePower.  

3. Right-click on ProvidePower and select Start Link, as 
shown opposite. 

4. Now right-click on the PowerSubsystem block in 
the HSUVStructure package and select End Link. 

This opens the Quick Link window that enables you to confirm or cancel the allocation of 
the activity to the block. 

5. Ensure the 'allocated to' relationship is selected (use the drop down list to select it if necessary), 
and then click the OK button to confirm. 

Nothing changes in either the browser view or on 
the diagram, but things have changed in the model. 
One way we can see evidence of this is through the 
properties of the related items. 

6. Open the Allocated property page for both the 
ProvidePower activity and the PowerSubsystem block, 
as follows. 
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We can also show these allocation relationships on certain diagrams where the related 
items appear. 

7. Open the ProvidePower activity 
diagram (you may still have this 
open from the previous section). 

8. Right-click the ProvidePower 
diagram frame (easiest to right-
click in the frame name) and 
select Add ► Callout Note (as 
opposite). 

9. In the Compartments to Display 
window expand the Roles folder 
and select the Allocated To check box.  

This adds a note connected to the frame stating the allocation relationship (as opposite). 
You can re-position this note as you wish. 

 

We can, as you would expect, make the allocate relationship visible from the 
PowerSubsystem block.  

10. Open the HSUVStructure [1] block definition 
diagram in the HSUVStructure package. 

There's an alternative way to display the 
relationship for a block. 

11. Right-click on the PowerSubsystem block and 
select Show/Hide Compartments. Expand the 
Roles folder and select the Allocated From check 
box (as opposite). 

This results in the PowerSubsystem block 
displaying a new compartment showing any 
allocatedFrom items. 

 

«block»

constraintProperties
«ConstraintProperty» fc : FlowConstraint

allocatedFrom
«Activity» ProvidePower (in accelPosition, in vehCond, out drivePower, out transModeCmd)

PowerSubsystem
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Note that you get the full signature of the activity (name and parameters).  

The Show/Hide Compartments context menu option is a powerful feature of PTC's 
SysML profile and you will find it as an option on virtually all items and diagram types as 
a way of displaying model relationships, not just allocations.  

The use of Start Link and End Link makes allocation both simple and quick; almost any 
type of model item can be linked, not just activities and blocks. It is also very flexible as 
you can right-click items on diagrams or in the browser. We have also seen the use of 
both compartment and callout notation for displaying allocations; we will see more of 
these later. 

To finish we will see how allocations can be summarized in matrix and table form. To 
make this a little more realistic we will create another allocation relationship. This will 
also be allocating an activity (ProportionPower) to a block (PowerControlUnit). This is 
not just arbitrary – the ProvidePower activity diagram shows a Call Behavior Action 
invoking this activity located in an activity partition linked to a part typed by this block. If 
this activity was invoked on this diagram only, it might be sensible to allocate it to the 
block typing the part. 

12. Right-click the ProportionPower activity in the HSUVActivities package and select Start Link. 

13. Then right-click the PowerControlUnit block in the HSUVStructure package and select End Link. 

14. Select the allocated to relationship in the Quick Link window and click the OK button. 

Note that you cannot create the allocation on the ProvidePower activity diagram. You 
are not trying to allocate the Call Behavior Action to the activity partition. 

So now we have two allocations in the HSUV model. Allocation matrices and tables are 
created scoped to a package and detail any allocations relating to items within the scope 
of that package and its sub-packages. The package can be a high-level package (for 
example, HSUVModel) if you want to summarize all allocations in the model, or a sub-
package if you only want to summarize a subset of those allocations.  

15. In the Packages Browser, right-click the HSUVActivities package and select New ► SysML ► 
Allocations ► Allocation Matrix. 

16. Change the default name to '[Package] 
HSUVActivities [Allocation Matrix]'. 

The matrix name should appear in the 
browser, scoped to the HSUVActivities 
package as shown opposite. 

17. To open and see the matrix, just double-click the name. 
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After a few seconds the matrix opens in Microsoft Excel. It will show any items within 
the HSUVActivities package that are involved in allocations, along with the allocated 
items in a matrix format. 

18. Close Excel and choose not to save (there is no point in saving, each time you open the matrix 
Modeler regenerates the content). 

19. Now right-click the HSUVStructure package in the Packages browser and select New ► SysML ► 
Allocations ► Allocation Table. 

The table name (use the default) appears scoped to the HSUVStructure package and is 
opened as the matrix by double-clicking the name. This also uses Excel, but this time it 
presents allocation information for the selected package in a tabular format. The 
information in the table is similar to that in the matrix, it really depends upon what 
format you want. 

In closing you can also see Allocation in a number of the Modeler browser panes.  

 

3.10 Defining State Behavior 

Like use case and sequence diagrams, state machine diagrams are inherited from UML 
with few changes. Consequently much of the state modeling in Modeler's SysML 
implementation is the same as Modeler's UML state modeling. The intention in this 
section is not to provide detailed coverage of every single feature of state modeling in 
Modeler, but to show those key techniques that will enable you to build simple state 
machines from which you can develop further expertise should you need to do so. 

State modeling is closely aligned with interaction modeling, with sequence diagram 
messages often forming the basis for the events and actions depicted on the state 
diagrams. In both UML and SysML, state diagrams must be child diagrams of a parent 
entity, known as a state machine. 

In SysML, a state machine is a specification of the dynamic behavior of a block, being 
used to describe the state behavior of all instances of that block (for example, parts or 
ports typed by the block) over their lifetime. A state machine is represented 
diagrammatically in Modeler via a state diagram that is a child diagram of the state 
machine it represents. Thus a state diagram is an indirect child diagram of a block; a 
block owns a state machine which in turn owns a state diagram. This is established when 
the state machine and state diagram are created. 

In this tutorial we will build a state diagram for the BrakeSubsystem block. It will not be 
complete, or even particularly realistic, but it will be enough to show the key techniques 
and relationships with other diagrams. The diagram that follows is what we will 
gradually build toward. 
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1. To start, use the Window ► Close All menu option to close all currently open diagrams.  

2. Expand the HSUVStructure package in the Packages browser (if necessary) to expose the 
BrakeSubsystem block. 

3. Right-click this block and select New ► SysML ► State Machine. Name the state machine 
'BrakeSubsystem'. 

4. Right-click on this state machine and select New ► State Diagram. Name the diagram 'ABS states'. 

By default, a round-cornered frame 
containing the name of the owning state 
machine is shown on the diagram. We want 
to display the frame in the standard SysML 
rectangular format showing the full name. 

5. Right-click the frame and select View Options. 

6. Select the Show As Frame, Show Diagram Name 
and Show Parent Item Type check boxes.  
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The result is as follows. Note that the Page reference property for the diagram has also 
been changed to 'stm' via the diagram's Properties window. 

 

7. Use the Initial State and Final State toolbar buttons  , to add these to the top left and top 
right of the diagram (as shown in the final image preceding step 1). 

These would be typically used to define power on and power off (respectively). When 
power is applied, the brake subsystem initially goes into its inactive state. 

8. Select the Atomic State toolbar button , and click on the diagram. Name the state Inactive. 

Note how the Inactive state appears scoped to the BrakeSubsystem state machine in the 
browser.  

9. Repeat the last step to add the Faulty state to the right of Inactive. 

The Active state is a sequential composite state (it contains other sub-states within a 
single region). Entry is triggered by the arrival of the same activateABS message we 
modeled on the white box sequence diagram in the previous section. 

10. Select the Sequential State toolbar button , and click on the diagram below and to the right of 
the Inactive state. Name this state Active. 

11. Enlarge the Active state and use the Initial State and Atomic State buttons to create the Idle and 
Braking sub-states, with an initial state, inside the Active state. (Select the toolbar button and click 
inside the Active state.) 

12. Finally use the Junction State toolbar button  to create the choice state above Active. 

Note how the states are being added to the Packages Browser. You can expand Active to 
see its contained atomic states. 
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Now we will add the transitions that connect the states as shown in the previous 
diagram. This is very easy, made even more so by the use of the Ctrl key. 

13. Select the Transition toolbar button . Now hold the Ctrl key down on the keyboard, then simply 
click in the source and destination states to add each transition in turn, holding the Ctrl key the 
entire time. (If you add each transition separately, without using the Ctrl key, you need to press the 
Enter key or click on the diagram to ignore the pop-up box that appears for each transition.) 

14. Press the Esc key on your keyboard after you have added the final transition. 

You may need to separate the two transitions between Idle and Braking (they may be 
created overlapping each other), and don't forget that, like all link lines in Modeler, you 
can add waypoints either as you go (left click) or afterwards by dragging the link. 

You can also remove all waypoints by right-clicking the link and selecting Cancel 
Waypoints. You can remove a single waypoint by selecting the link, right-clicking on a 
specific waypoint and selecting Remove this Waypoint. 

You can also alter the line style to create straight rather than curved lines if you wish. 
Look in the Help system at the Working with diagrams/Customizing the presentation 
topic. Alternatively look at the Diagrams section in Part 2 of the Modeler Tutorial. 

The / characters on the transitions are acting as placeholders for the events and possible 
actions that we now need to add. However, those on the transitions from and to the 
initial and final states are not really necessary. We can easily remove them. 

15. Select all of these transitions, by using the Ctrl key (standard Windows multi-select). 

16. Right-click on any one of the selected transition lines and select View Options. 

17. Select the Transition entry, clear the Show 
Event Action Blocks check box, as opposite, 
and then click the OK button. 

By now your diagram should be taking shape, and look similar to this. 
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We would now go on to think about the events that cause the transitions to trigger but 
to keep this tutorial at a high level we will finish this short introduction to state 
modeling here.  If you want to find out more about state modeling in Modeler please 
take a look at the Help. You can now close the state diagram. 

 

3.11 Establishing Requirements Traceability 

Having now covered all but the Package diagram (coming next), we are in the position 
where we can revisit requirements and relate them to relevant model items. We will 
show the means by which this can be done; we will also see how we can make these 
relationships clearly visible in the model from both the requirements end (that is, for a 
specific requirement, which model items are related to it, and what type of relationships 
they are) and the model item end. 

You may have noticed that sometimes an arrow appears to the right of a toolbar button, 
for example . Clicking the arrow to the right of the button 
makes related toolbar buttons available. For example, the toolbar 
buttons for creating refine, satisfy, trace and verify traceability 
relationships are grouped in this way. The trace relationship is 
inherited from UML, one of the reasons why the UML profile is 
added to the model with the SysML profile. However, its use is 
not recommended in SysML. We will therefore not cover trace, 
although the mechanisms for its use are identical to those we will 
cover. 

1. Expand the HSUVRequirements package 
content in the Packages Browser as 
opposite. 

2. Then double-click the HSUVRequirements 
diagram to open the diagram. 

The first relationship we will create is a 
satisfy dependency, and we will do this 
on the open requirement diagram. We 
are going to model that the PowerSubsystem block satisfies the Power requirement. 

3. Expand the HSUVStructure package in the browser and drag the 
PowerSubsystem block on to the requirements diagram, below the 
Power requirement. 

4. Now select the Satisfy dependency toolbar button, click first on the 
PowerSubsystem block, then on the Power requirement. 
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This will create the required relationship, as opposite. If your arrow points the wrong 
way, undo and repeat the last step. 

The relationship is established in the model and is visible from several viewpoints. 

5. Open the property pages for the 
PowerSubsystem block and select 
the (newly created) 
RequirementRelated tab, as shown 
opposite. 

This tab only exists because you 
created the satisfy relationship. 
However, as you can see, it is 
used to record any type of 
requirement relationship. 
 
6. Now open the property pages for the Power requirement and select the Requirement tab. 

The relationship is visible here also. 

7. Right-click the PowerSubsystem block, either on the diagram or in the browser, and select Links ► 
Traceability ► Satisfies. 

This opens the Links Editor window, where again the relationship is visible. 

 

The Links Editor is a powerful facility, which as well as providing visibility of existing 
links, also allows you to make new ones or break existing ones. You might want to try 
doing this and note the effect on item properties and the currently open diagram. Use 
Undo to restore the model to its current state. 
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The second relationship we will create is the verify dependency, and again, we will do 
this on the requirement diagram, but in a completely different way. A verify dependency 
can only be created between a requirement and a model item that has had the 
«Testcase» stereotype applied. « Testcase » can only be applied to certain model item 
types: certain behavioral diagrams or behavioral items such as operations or activities, 
which can own diagrams. You need to decide which items in your model constitute test 
cases and apply the stereotype before you can create the verify dependency.  

We will apply the « Testcase » stereotype to the AccelerateAct activity created earlier 
and then show that this activity verifies the Acceleration requirement. 

8. Expand the HybridSUV block in the Packages browser, to 
see the AccelerateAct activity, as opposite. 

9. Right-click AccelerateAct, and select Applied Stereotypes 
►  Testcase. 

This applies the Testcase stereotype and the 
Property Pages of the activity will now 
show a Testcase tab (more shortly). 

10. Now right-click the AccelerateAct activity 
in the browser and select Start Link. 

11. Then right-click the Acceleration 
requirement on the diagram and select 
End Link to open the Quick Link window. 

12. Use the drop-down list control to select 
the 'verifies' relationship (as shown 
opposite) and click the OK button. 

The relationship is now established in 
the model, although there is no visibility of it on the diagram. 

13. Right-click the Acceleration requirement on the diagram and select Add ► Callout Note.  

 

14. Expand the Roles folder, and then select the VerifiedBy 
check box.  

This will add a note indicating the verification 
relationship. 
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This relationship is also visible in the model through properties and the Links Editor, and 
AccelerateAct now also has a RequirementRelated property tab. 

Before we leave the requirement diagram to look at these relationships from the model 
item end, we should briefly consider two further toolbar buttons: Problem and 

Rationale ( ).  

Although these can be used on other diagrams, they are often found on requirements 
diagrams. 

15. Select the Problem button and click on the diagram, close to the Acceleration requirement and the 
verifiedBy note (we have moved items around on the following image). 

16. Enter the text 'need to specify test conditions' in the pop up text box, and press the Enter key. 

A «Problem» note is created on the diagram, as 
opposite. 

17. Now select the Note Link toolbar button , click on the «Problem» note, then on the Acceleration 
requirement. 

This creates a link between the 
problem and the item it relates to (as 
opposite) which persists wherever 
you move the linked items. 

In addition the Problem appears as a model item in the 
Packages Browser, scoped to the Acceleration 
requirement, as shown opposite. 

If you wish you can add a further note link from the «Problem» note to the verifiedBy 
note, but this will not affect its scoping in the model. 

Exactly the same approach is used with Rationale. You can, if you wish, create and link 
the Rationale note shown on the final version of the requirement diagram as follows. If 
you do this, you will find the Rationale as a model item scoped within the 
PowerSubsystem block. 

«requirement»

Acceleration

«Problem»

need to specify test conditions

«requirement»

Acceleration

«Problem»

need to specify test conditions

«Problem»

need to specify test conditions

«Problem»

need to specify test conditions
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The relationship between the Power requirement and the PowerSubsystem block is now 
held in the model. We can therefore see this from the PowerSubsystem end. 

18. Expand the HSUVStructure package and double-click the HSUVStructure BDD shown near the foot 
of the package content to open the diagram (see the diagram that follows, and note that we have 
hidden the compartments on the Blocks for clarity). 

19. Right-click the PowerSubsystem block on this diagram and select Add ► Callout Note. Then select 
satisfies under Roles. 

 

This adds a note, linked to PowerSubsystem, stating its relationship with the Power 
requirement. View Options can also be used to change this note to a box, if preferred. 
You may need to move things around slightly on this diagram to make it look like this. 

req [Package] HSUVRequirements [1]

«block»

PowerSubsystem

«requirement»

Performance

«requirement»

Acceleration

«requirement»

Power

verifiedBy
«Activity» AccelerateAct (out drivePower, out transModeCmd)

verifiedBy
«Activity» AccelerateAct (out drivePower, out transModeCmd)

«satisfy»

«deriveReqt»

«problem»

need to specify test conditions

«rationale»

Contains both power sources
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Not only can we see related requirements on other diagrams, we can create such 
relationships. 

20. Expand the HSUVUseCases package in the browser and double-click the Operational Use Cases 
diagram at the bottom of the package content to open the diagram. 

21. Drag the Acceleration requirement from the Packages Browser and drop it on the use case 
diagram, as shown in the illustration that follows.  

bdd [Package] HSUVStructure [1]

«block»

HybridSUV

«block»

BrakeSubsystem

«block»

ChassisSubsystem

«block»

PowerSubsystem

«block»

BrakePedal «constraint»

constraintParameters
«ConstraintParameter» demand : Real
«ConstraintParameter» flowrate : Real
«ConstraintParameter» pressure : Real

constraints
{flowrate=pressure(4*demand)}

FlowConstraint

bk p
c

bkp

bkp fc

satisfies
«Requirement» Power

satisfies
«Requirement» Power
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22. Select the Refine dependency toolbar button , click first on the Accelerate use case (on the 
diagram), then on the Acceleration 
requirement. 

This will create and show the 
dependency relationship on this 
diagram, as opposite.  

23. Now return to the requirement diagram (HSUVRequirements), right-
click on the Acceleration requirement on this diagram, and select 
Show/Hide Compartments and select refinedBy under the Roles 
option, to show the compartment as opposite. 

There are a number of requirements reporting mechanisms 
provided by PTC Integrity Modeler. Requirements tables can be created and configured 
to show requirements relationships. You can also use the Report context menu option. 

24. Right-click on the HSUVRequirements package in the Packages Browser, and select Report ► 
Unsatisfied Requirements. 

This opens the Results pane and lists any unsatisfied requirements in the 
HSUVRequirements package. You will also see a number of other requirements related 
options from the Report context menu. 

 

3.12 Capturing Model Structure 

The package diagram is typically used to capture the structure of, and dependencies 
between, packages, but can also be used to show views and viewpoints (if you are not 
familiar with these, you can find more information in the SysML specification). As with 
other sections of this tutorial, the intention here is not to show all features of Modeler's 

«requirement»

refinedBy
«Use Case» Accelerate

Acceleration
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package diagram implementation, but enough to enable you to start to use it. To do this 
we will firstly create a simple diagram to show our model structure and then create a 
view and show the items that might relate to this view. 

The package diagram showing model structure is typically held within the top-level 
model package: HSUVModel in our case.  

1. Collapse the packages in the Packages browser pane as opposite, to 
see the package structure within HSUVModel (note we have not 
shown most of the items in the HSUVStructure package for space 
reasons). 

2. Right-click the top level HSUVModel package and select New ► 
Diagram ► SysML ► Package Diagram. Name the diagram 
'[Package] HSUVModel [Structure]'. 

3. Drag each of the four packages within HSUVModel from the browser to the diagram, positioned 
approximately as shown here. 

 

The HSUVStructure package may contain one or two sub-packages, HSUVFlowSpecs and 
HSUVInterfaces, depending on which packages you created during the tutorial. 

4. Right-click on the HSUVStructure package name and select Populate ► Nodes ► Packages. 

pkg [Package] HSUVModel [Structure]

HSUVActivities HSUVRequirements HSUVStructure

HSUVUseCases
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5. Resize the HSUVStructure Package and move the one or two nested packages as shown below. 

 

As well as showing the structure of the HSUVModel packages, we can also show package 
dependencies on this diagram. A dependency exists when something in one package 
references something in another package and identifies a need to be careful regarding 
change in the dependee package. An example in our model is the dependency between 
the HSUVUseCases package and the HSUVStructure package that arises because the 
child sequence diagrams in the HSUVUseCases package contain items scoped to the 
HSUVStructure package. It is useful to capture this dependency more visibly in the 
model, on the package diagram. 

6. Click the arrow on the right of the Abstraction toolbar button  
and from the drop-down menu (see opposite) select Dependency. 

7. Click first on the HSUVUseCases package (click on the name tab or 
the boundary – you are not selecting the package if you click inside it 
somewhere), then on the HSUVStructure package name tab to create 
the dependency relationship in the model and show it on the 
diagram. 

pkg [Package] HSUVModel [Structure]

HSUVActivities HSUVRequirements HSUVStructure

HSUVFlowSpecs

HSUVInterfaces

HSUVUseCases
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Your diagram should now look similar to this. 

 

There are other dependencies that could be added to this diagram, but we will move on 
to look at how the package diagram can also be used to model views and viewpoints. 

To start we will create a package in the model to hold this package diagram and the 
elements we create on it (and in doing so, we should of course update the above 
diagram). 

8. Right-click the HSUVModel package and select New ► Package. Name it HSUVViews. 

9. Now right-click the HSUVViews package and select New ► Diagram ► SysML ► Package 
Diagram. Give the diagram the name '[Package] HSUVViews [Operational View]'. 

As you will see (from the Tool Tips) there are package diagram toolbar buttons for 
creating a view and a viewpoint as well as the relationships that connect them and other 
items. 

10. Select the View toolbar button , and click on the diagram. Name the view OperationalView. 

11. Now select the Viewpoint toolbar button , and click on the diagram next to the 
OperationalView. Name the viewpoint OperationalViewpoint. 

Note how both the view and viewpoint appear in the browser, along with the package 
diagram, within the HSUVViews package. 

pkg [Package] HSUVModel [Structure]

HSUVActivities HSUVRequirements HSUVStructure

HSUVFlowSpecs

HSUVInterfaces

HSUVUseCases

«dependency»
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12. Select the OperationalViewpoint, 
either on the diagram or in the 
browser, open its properties and 
select the Viewpoint tab. 

The tags you see (opposite) 
allow you to set the required 
data for the viewpoint. You do 
this by simply clicking in the Tag 
Value column for the required 
tag, and entering whatever text 
you want. 

13. Now select the Conform toolbar button , click first on OperationalView, then on 
OperationalViewpoint, to create a «conform» relationship between them. 

 

 

We have used more diagram types than you may use on typical project.  In reality you 
would do just enough modeling to define the system, analyze alternatives and build 
your products.  Our objective was to give you an introduction to the modeling and 
diagrams available in PTC Integrity Modeler. 



Model-based Systems Engineering with SysML 

101 

3.13 Model Review 

At this stage in a project we would typically review our models.  As you have seen, 
Modeler helps you with many of the modeling tasks, ensuring that you apply SysML 
correctly.  That said, this does not ensure you have a good design that meets the needs 
of the system stakeholders.  For this type of review we should apply two approaches, 
peer/stakeholder design walkthroughs and automated design reviews.  Automated 
design reviews are usually carried out first, to resolve the majority of errors before the 
human review. 

PTC integrity Modeler provides 
and optional add-on for 
automated design reviews called 
PTC Integrity Modeler Reviewer.  
If you have this tool installed and 
licensed you can follow the steps 
in this section of the tutorial.  
Let’s start by opening Reviewer. 

14. Click the main menu item Tools ► 
Reviewer. 

You will now see the Reviewer 
start screen.  This provides 
introductory help on what to do 
next. 

Now we can select the scope and 
type of the review to be run. 

15. Ensure that the Report ‘SysML’ is selected from the first pull-down and that ‘Dictionary’ is selected 
in the second. 

 

16. Click ‘Run Report’.  In a few seconds Reviewer will produce an overview of the Model status 
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As our model is intentionally incomplete we will see a large number of problems.  Your 
overview should look something like the following graphic, with a pie chart showing the 
Passed, Failed and Ignored reviews, then various bar charts showing the number of 
errors for each individual review type.  The first bar chart shows the reviews in 
alphabetic order and the second shows them in the order of criticality, based on the 
percentage of the model which they affect. 

 

17. Click on any of the highlighted review names or the Summary tab (at the top) to see the details 
review errors.  Both will take you to the Summary tab. 



Model-based Systems Engineering with SysML 

103 

In the Summary tab you will see the individual model items which failed the reviews.  
You will see a section for Undefined Requirements, as follows; 

 

This example provides buttons to automatically fix the problem, ignore the problem, 
comment on the problem for other reviewers or go to the problem item in PTC Integrity 
Modeler.  This then allows you to fix the problem, re-run the review and reduce the 
number of review errors to an acceptable level.  This allows you to assess the 
correctness and completeness of the model so that you can decide whether it is ready 
for publication and use.  Clicking on the review name will provide help on that review 
type. 

This completes the Reviewer tutorial for this high level introduction.  However, there is a 
lot more functionality you can try for yourself.  The Reviews ► Configure SysML menu 
lets you select which reviews are run for this report and configure many of them.  With 
training and experience you can also create your own reviews and automated model 
fixes.  You can also use Reviewer to report on the metrics of your model, so that you can 
understand its size, complexity and growth. 

 

3.14 Model Simulation 

As with Reviewer, at various stages in your systems engineering lifecycle you may need 
to understand the various trade-offs available, so that you can make informed design 
decisions.  There are a number of Modeler facilities which can help with this task and in 
this tutorial we will take a look at SySim, the system level simulator. 

To complete this part of the tutorial you will need the PTC Integrity Modeler SySim add-
on installed and licensed.  You will also need Microsoft Visual Studio installed, which you 
can download for free from the Microsoft web site. 

SySim is another powerful tool with many features so we will only touch on a few of the 
highlights in this tutorial.  To keep things simple we will use a model which is already 
setup for simulation. 

18. Click the menu item File ► Open Model. 

19. Navigate to and open the Examples ► Speed Controller model. 
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In the Packages Browser, at the top level, you will find a ReadMe text diagram.  You can 
open this text diagram to read about the Speed Controller example model and brief 
instructions on starting SySim. 

20. Use the Packages Browser to open the SySim Simulators ► Speed Controller ► [block] Speed 
Control diagram. 

This diagram is a special Internal Block Diagram which is used to describe the user 
interface for the simulation mockup.  We can see various simulation user interface 
blocks, including a knob for setting the load on the electric motor and a meter to show 
the speed of the electric motor. 

 

On a real project you would use a diagram like this to describe the user interface 
mockup for your simulation scenarios. 

Now we can start the PTC Integrity Modeler SySim system level simulator. 

21. Right-click on the Speed Controller block in the Packages Browser or on the diagram and select 
SySim ► PTC Integrity Modeler SySim. 

This will open the SySim control window.  This window will usually default to a simple 
view.  You can see 
more of the 
configuration 
setting by clicking 
the [+] button and 
fewer of the 
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details by clicking the [-] button. We will now prepare and run this simulation. 

22. Click on the Make Model Executable and Run button . 

After a few seconds the simulation user interface will be displayed.  The Visual Studio 
window may also be displayed, which you can minimize.  Be careful to minimize but not 
close it. 

 

This simulation windows show graphical versions of the blocks we saw on the simulation 
user interface diagram.  We will now run the simulation and execute the model. 

23. Click on the Simulation Start/Resume button .. 

24. Move the slider to set your desired motor speed.  We would recommend you set it to 
approximately 50. 

You will see that on the moving graph (to the right) that the electric current (yellow) 
peaks to increase the speed to the value you chose.  You will also see the current motor 
speed (white) increase to align with the demand speed (violet) you set. Now experiment 
by changing the load. 

25. Turn the red knob to various positions and watch the graph. 

You will see that the load applied (red) changes to your setting.  The current motor 
speed (white) speeds up or slows down temporarily and the electric motor controller 
then changes the electric current (yellow) to respond to the new load and maintains the 
speed you asked for. 
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On a real project you may use SysSim identify problems in your system design, you can 
then rectify those problems and re-simulate to validate your model. 

This is a very simple example but you should now see how SySim can be used not only to 
review your system design in much more detail but how it can also be used to 
communicate with non-SysML aware stakeholders. 

You can now close the system simulation mockup window, Visual Studio and the SySim 
control window. 

 

3.15 Model Publication 

Once you have modeled your ‘to-be’ system and validated that it will meet the 
requirements (possibly by checking Requirements Satisfies links, and using Reviewer and 
SySim) you will typically need to share it with a wider audience.  This could be to the 
stakeholders who will receive the system, other systems engineers working on parallel 
systems, down-stream domain- specific engineers, or any other interested parties. 

There are a number of model publication options.  You can automatically generate 
Microsoft Word documents, PDFs and HTML documents.  Modeler also provides a web 
based model viewer, which provides distributed, live access to view the models and 
their versions.  Note; both the Model Explorer and Modeler itself provide a full range of 
model configuration management facilities, including model baselining for version 
management. Model versions are not covered in this tutorial but information on this 
topic can be found in the online Help.  The models can also be published to standard 
XMI to import into other XMI compliant tools. 

In this tutorial we will use our Tutorial1 model to look at PTC Integrity Modeler Publisher 
and automatically generate a Microsoft Word document.  To run these steps you will 
need to have Microsoft Word installed and the Publisher tool available. 

26. Click the menu item File, find the Tutorial1 model in the recently opened models list and click on it 
to open it. 

27. Click the menu item Tools ► Publisher. 

This will open Publisher, which has a single user interface for both the definition and 
generation of documents.  In this tutorial we will focus purely on the generation of a 
document, based on an existing template.  In reality you or your organization will define 
templates for documents to support your specific needs with your layout, content and 
branding. 
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If you do not see this default window layout you can reset it by clicking the main menu 
item View ► Layout ► Restore Default Layout. 

On the left you will see a number of templates provided by PTC.  We will use the SysML 
template to generate documentation from our Tutorial1 model. 

28. Right-click the SysML template and select Generate To ► Word. 

This will show the structure of the document in the main Publisher pane and start the 
automatic document generation.  The document generation may take a minute or two 
to run.  As our model is incomplete, errors may occur during the document generation.  
We can ignore these errors by clicking on [OK].  When the automatic generation finishes 
you will see your document in Microsoft Word. 

29. Scroll through this document to see the title page, table of contents, table of figures, list of tables, 
the revision history and then the diagrams and model items we created earlier in this tutorial . 

You will also see some auto-created diagrams for Types.  Once you have reviewed the 
document and identified some familiar diagrams you can close Microsoft Word, without 
saving the document.  In reality you would save this document and distribute it.  That 
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said, you should remember that the model is the single source of truth and that new 
and up to date documents can be generated at any time. 

As this is a high level tutorial we will not have time to look at the creation of document 
templates but more information can be found in the Help.  We would recommend that 
you also take training in this topic.  You can now close Publisher, in preparation for the 
next stage of this tutorial. 

 

3.16 Model Flow-down 

Of course, system modeling is only a means to an end and is followed by mechanical, 
electrical, software and other domain specific design and production engineering 
processes.  As well as helping you decide on the best design options for the system and 
its functions, the system model is also a useful information source for the lifecycle 
stages that follow. 

We mentioned that XMI can be used to transfer system model information into other 
tools but Modeler also has integrated flow down to software modeling with UML and 
then automated code generation. 

The system models structure can also be a very good starting point for product lifecycle 
management (PLM) and PTC Integrity Modeler can automatically generate a first-cut bill 
of materials (BoM) or ‘parts structure’ into PTC’s Windchill, among other things.  More 
information on this and other integrations is available in the Help. 

This completes this section of the tutorial. You can now close the model or close the 
diagrams and continue to the next section.
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4 Asset-based Modular Design 

While PTC Integrity Modeler provides good SysML facilities for system decomposition it 
sometimes helps to break systems up into even clearer sub-systems.  This can help to 
avoid model bloat, keeping models a small and as simple as possible.  It can also help 
with system modularity, division of labor, parallel working and security.   

 

PTC Integrity Asset Library is an optional add-on tool that can be used in conjunction 
with PTC Integrity Modeler.  As you can see in the picture above, it can be used to link 
models inside models and/or include parts in models that have not been modeled 
themselves.  This section covers the ‘A’ in the PTC Integrity Process Perspective MAP. 

The typical workflow when using Modeler and Asset Library is as follows.  

Starting in a System of Systems (SoS) model, as Asset Consumer 

1. During the model-based systems engineering process, Identify your tentative, main 
Sub-systems/Modules/Components as Blocks 

Note; these may or may not exist 
2. Search in Asset Library for an Asset to satisfy each of these Sub-systems 
3. When you find one or more suitable Assets ‘reuse’ them in your SoS model 

Note; these are now fixed and your SoS model points to versions of assets 
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Note; your SoS model is now a configuration model and you may choose to 
version it now 

4. If you have tentative Blocks that cannot be satisfied by Asset Library Assets you can 
either;  
a. Ask for changes to an existing Asset in Asset Library 
b. Wait for a new or updated Asset to be published into the Asset Library 

Note; register interest and receive email when an Asset is published 
c. Push (publish) your requirements for a new Asset, as an Asset Specification 

Note; this Asset Specification can include Requirements, Use Cases, tentative 
Blocks, tentative Ports and variation, all acting as a contract 

 
Now in a new System model, as an Asset Supplier 

(Note; this may be a different person, team or even 3rd party organization) 
(Note; Asset suppliers will register interest, to receive Asset requests) 

 
5. The Asset Supplier receives an automated email telling them an now Asset request 

has arrived and reviews the specification 
6. They pull (reuse) the Asset Specification into their empty sub-system model 
7. They design the Asset in the Sub-system model 

(Note; they may then version the sub-system model)  
8. They then Publish the delivered Asset back into Asset Library 
 
Returning to the System of Systems (SoS) model, as the Asset Consumer 

9. Asset Consumer gets an automated email to say the Asset is ready 
10. You review the Asset to check it is suitable 
11. You  pull (reuse) the Asset into your SoS model 
12. You connect the reused Blocks and Ports into your SoS model 

(Note; you may now version your SoS model) 
 
After this process has been followed, the SoS model will have OSLC URI pointers to the 
Assets indexed in Asset Library and those Assets will in turn have pointers to the sub-
system models.  This links can be followed, meaning that you can click on an asset in a 
model and automatically open Asset Library at that Asset or navigate from a SoS model 
Asset and automatically open the model of the sub-system.  In this example we have 
only described one level of decomposition but this approach can be used for any level of 
sub-system nesting. 
 
To complete the following asset-based modular design tutorial steps you will need 
access to PTC Integrity Asset Library (with a valid login and password) and a local 
installation of the PTC Asset Library Bridge for Modeler.  With the Bridge running; 
 

1. Right-click the Asset Library Bridge icon   in the Windows Task Bar and select Settings. 
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2. In the Settings 
Window, enter the 
URL for your Asset 
Library, your 
username and your 
password, then click 
on [Save]  

 

 

3. In preparation for this tutorial, open PTC Integrity Asset Library in a web browser, log in and right-
click the asset library name in the Library Browser to select Create Root Catalog.  Name the new 
catalog Tutorial. 

To keep this simple for this high-level tutorial we will focus on the preceding workflow 
items 7 thru 11, publishing an Asset from a Supplier model and then reusing it in a 
Consumer model.  We will start by designing our Asset in a new model. 
 
4. In Modeler, click on the menu item File  ► New Model and select the Asset and SysML (full) profile 

in the Options window.  Then click the OK button and after the model has been created name it 
Rear Axle in the models Property Page General tab. 

5. Right-click on the model in the Packages Browser to create a New ► Package and name it Rear 
Axle. 

6. Right-click on the Rear Axle package you just created in the Packages Browser to create a New ► 
SysML ► Structure ► Block and name Rear Axle. 

Note; we could have named the model, package and block more sensibly but this will 
keep things simple for this tutorial. 
 
7. Right-click on the Rear Axle block you just created in the Packages Browser to create a New ► 

SysML ► Internal Block Diagram and accept the default name. 

8. Drag the Rear Axle Block from the Packages Browser and drop it onto the IBD diagram. 

9. Now create the 
following model; 

Note; The Full Ports on 
the boundary of the 
Rear Axle Block are 
called Stub Wheel 
Flange and Differential 
Drive Flange.  These 
are typed by Interface 
Blocks of the same 
names. 
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The Blocks inside the Rear Axle block (shown as a frame using View Options) are internal 
Parts of the rear axle and therefore should be hidden inside the rear axle ‘black box’.  
These are named Differential and Stub Axle. 
 
10. Open the Property Page for Differential and set the Visibility to Private, on the General tab. 

11. Repeat the previous step for the Stub Axle. 

This will ensure that when we publish the Rear Axle as an Asset, only the Block 
representing the Asset and the Ports (with their types) will be published.  The Asset will 
then represent a ‘black box’ view of the Rear Axle model. 
 
Now we need to apply the Asset stereotype to the Rear Axle package, as the last step 
before it can be published.  This will add Asset tagged values to the Package, to store the 
OSLC URI, its version and other key information. 
 
12. Right-click on the Rear Axle package to create a New ► Diagram ► SysML ► Package Diagram 

and accept the default diagram name. 

13. Drag the Rear Axle package from the Packages Browser and drop it inside the frame on the 
diagram. 

14. Right-click on the Rear Axle package to set Applied Stereotype ► Asset. 

The Package icon next to Rear Axle in the Packages Browser will now change to an Asset 
icon.  The Rear Axle package Property Page will now also include an Asset Tab. 
 
15. In the Browser Pane select the Asset Library Browser and make sure you can see the Tutorial 

catalog. You may need to refresh the Modeler view [F5] if you created the Asset Library Catalog 
while Modeler was running. 

This Asset Browser is a view into the Asset Library, hosted in the Modeler user interface.  
As shown in the first graphic of this section, the Catalogs and Assets in this view reside in 
the Asset Library repository, not the Modeler repository. 
 
16. To publish the Asset, drag the Rear Axle package 

from the diagram and drop it onto the Tutorial 
catalog in the Asset Library Browser 

An Asset properties window will appear. 
 
17. Enter the same version number as the model (0) 

and click on the Publish button. 

 
The Rear Axle asset will now be published into Asset Library.  You can view the new 
Asset in Asset Library by opening Asset Library and navigating to the Asset or by 
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navigating from the model as follows.  If you already had Asset Library open you may 
need to press [F5] to refresh the view. 
 
18. Right-click on the Rear Axle package on the diagram and select Asset ► View in Asset Library. 

In Asset Library you will see the new Asset, the ‘black box’ interfaces and the interface 
types.  This data is now in OMG Reusable Asset Specification standard format, which is a 
generic format that can be mapped to SysML, UML, IDL, WSDL and may other 
component, service and interface formats.  You should also note that the private Blocks 
have not been published.  We have not used them in our simple example but the Asset 
could also include Requirements, Use Cases and variation (covered later in this tutorial). 
 

 
 
You can now edit the attributes of the Asset using the pencil button.  More information 
on the other buttons and features of Asset Library can be found in the Help, at the top 
right of the web browser. 
 
Now that we have an Asset in Asset Library we can use it in our original Tutorial1 model. 
 
19. Click on the File menu and select the Tutorial1 model from the recently access list. 

20. Use the Packages Browser to open the HSUVModel package diagram called [Package] HSUVModel 
[0].  The name may be slightly different if you have versioned the model. 

21. Open the Asset Library Browser and expand the Tutorial Catalog. 
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22. Drag the Rear Axle asset from the Asset Library 
Browser and drop it inside the frame on the 
Package diagram. 

23. In the Asset Reuse Mapping window select SysML 
from the pull-down list and click on the OK button. 

This will use/reuse the Asset in our SoS model, Tutorial1 and display it on the Package 
diagram.  You 
will notice that 
the Package 
(bottom right, 
below) is 
identified as an 
<<Asset>> and 
includes its 
version. 
 
 
 
If you look at the 
Property Page 

for this package you will see that it also includes an Asset Tab, with information about 
its source Asset in Asset Library. 
 
Now go back to the Packages Browser.  You 
will see a new Rear Axle package, which on a 
real project; can be moved to your desired 
location in the package hierarchy.  These 
Block, Ports and Interface Blocks can now be 
used in your SoS design.  You will also see that 
the right-click context menu for the Rear Axle 
package provides hot links to the sub-system 
model and the Asset in Asset Library. 
 
Over time, when the original Rear Axle Asset is updated and re-published into the Asset 
Library you can choose to receive automatic email notifications and update your SoS 
model with the latest Ports and other Asset information.  To do this, right-click on the 
Asset in Asset Library and select Copy Asset, then right-click on the model in the 
Modeler Packages Browser and select Paste Asset.  This will update rather than 
duplicate the originally reused Asset, re-reusing the Asset. 
 
This concludes the brief introduction to Asset based Modular Design. 
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5 Model-based Product Line Engineering using SysML & OVM 

As well as model-based systems engineering and asset-based modular design, PTC 
Integrity Process Perspective also provides best practices for model-based product line 
engineering (MBPLE).  This approach is also supported by product features in PTC 
Integrity Modeler.  MBPLE can be used an extension for basic MBSE independent from 
asset-based modular design or in conjunction with asset-based modular design. 
 
MBPLE can be applied with or without Asset-based Modular Design (ABMD).  ABMD 
focusses on Component Based Design CBD, System of Systems (SoS) design, Service-
oriented Architecture (SOA) design, in other words modular design with service 
contracts or interfaces.  MBPLE concentrates on product lines and in the case on MBSE, 
System Families.  These System Family or Product Line models are overloaded, meaning 
that they include all of the optional parts that can be used to construct any product or 
system in the family.  This is very powerful and allows you to not only include or exclude 
parts (or components) in a similar way to configuration management but also vary the 
number of parts, specific values, parameters, functions, states, etc. 
 
PTC Integrity Manager has an add-on for MBPLE called Product-Line Engineering (PLE).  
You will need this feature installed and licensed to be able to complete this section of 
the tutorial.  
 
The PLE add-
on extends 
the diagrams 
and model 
elements to 
include 
Variation 
Points, 
Variants, 
Decision Sets 
and Variant 
Diagrams.  
We will use 
these in the 
following 
steps.  As an 
introduction, 
here is an example Variant Diagram which shows Blocks which will be included or 
excluded (based on the Variant selected), Variable Parameters and Variable Multiplicity 
(to indicate the number of parts).  This visual model makes complex product lines much 
easier to understand and apply. 
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The modeling language used for Variability Modeling in PTC Integrity Modeler is 
Orthogonal Variability Modeling (OVM) and its elements can be linked to all of the other 
model elements in the repository.  We will introduce Variability Modeling at a high level 
in this tutorial and more information is available in the Help.  
 
As mentioned above, we start MBPLE with a Product Line Model (sometimes called an 
Overloaded Model or a 150% Model).  This can have an MBSE model (SysML) as its core, 
with the addition of a Variability Model (item 1 below) and one or more Decision Sets 
(item 2 below). 
 

 
Then we make decisions for the Variation Points and automatically generate a Product 
Model (item 3 above).  This Product Model represents a specific product instance.  It 
may have decisions for all of the Variation Points or some Variation Points may be 
unresolved.  Partially resolved Product Models are sometimes called 120% models while 
fully resolved Product Models are known as 100% models. 
 
The PTC Integrity Process Perspective provides a detailed workflow for MBPLE but we 
will keep it simple for this tutorial and follow these three main steps. 
 
We will start by creating our Product Line (150%) model. 
 
1. Start by making sure you have the Tutorial1 model open in PTC Integrity Modeler. 

2. Use the Packages Browser to open the HSUVStructure ► [Package] HSUVStructure [Part 
Connections diagram]. 

3. Add a Block to the diagram and name it 
ABS.  Add a Composite Association from 
the Brake System and a Shared Association 
from Power Subsystem (as shown to the 
right).  This Anti-lock Braking System (ABS) 
will be an ‘option’ for the HSUV. 
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Now that we have the base ABS block we will add it as a part on the Power Subsystem 
IBD. 
 
4. Use the Packages Browser to open the HSUVStructure ►Power Subsystem ►[Block} 

PowerSubsystem [1} diagram. 

5. Right-click on the diagram background to Populate ►Nodes ►Block Properties.  Then move the 
ABS part into space and add the connector, as shown below. 

   

6. Right-click on the HSUVStructure in the Packages Browser and select New ►Diagram ►Variability 
►Variant Diagram and accept the default name (Variant Diagram1). 

7. Add a new Variation Point to the diagram using the Variation Point button  and call it Quality 
Level. 

8. Add a Variant to the diagram using the Variant toolbar button and call it Luxury. 

9. Repeat the previous step to create another Variant called Basic. 

10. Add an Optional Variant Dependency from Quality Level to Luxury using the  toolbar button. 
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11. Repeat the previous step to create Optional Variant Dependency from Quality Level to Basic. 

12. Select both of the Optional Variant 
Dependencies (you can click on one, hold 
down the [Shift] button and click on the 
other) and right-click on the selection to 
Create Alternate Choice. 

The diagram now shows and arc with 1..1 
next to it.  This means that the Quality 
Level varies and that you can select one 
and only one of the two variant options, 
Luxury or Basic.  We will now link this 
variability to the underlying SysML model. 

13. Locate the ABS Block in the Brake Subsystem in the Packages Browser and 
drag it onto the diagram.  Use the View Options to not Show Full Name. 

14. Create an Artefact Dependency from Luxury to ABS using the  toolbar 
button. 

This now models the link between the Luxury variant and ABS.  In other words, Basic 
quality level HSUVs will not have ABS. 

Now that we have added an optional Part to make our mode a Product Line Model, 
defined our variability and associated the variability with the base model we can create 
a Decision Set.  This will hold a set of Variation Point decisions which can then be used 
to automatically generate a Product Model. 

15. Right-click on the HSUVStructure package in the Packages Browser and select New ►Variability ► 
Decision Set, accepting the default name (Decision Set1). 

There are two options for making variability decisions in PTC Integrity Modeler, the 
Decision Set Editor and the Variant Selector.  In this tutorial we will use the Variant 
Selector. 

16. Click on Edit in the main 
menu and select Variant 
Selector. 

This will display the Variant 
Selector, which is a great 
interface for anyone 
(including non-modelers) to 
configure a system or 
product. 
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17. As prompted, click on the Decision Set 1 

18. Click on the variation point Quality Level and then select the  next to Basic variant, to include it. 

You will notice that the Luxury variant is automatically set to  because the Variant 
Selector understand the 1..1 logic define in the model. 

Now that we have made our decision we can automatically generate a Product Model. 

19. To keep things simple, close the Variant Selector. 

20. Right-click on the Decision Set1 in the Packages Browser and select Create Product Model. 

This will automatically create a new model sandbox (sandboxes are described in the 
Help) and resolve the variation model using the Set1 decisions. 

21. Use the Packages Browser to open the HSUVStructure ►Power Subsystem ►[Block} 
PowerSubsystem [1} diagram. 

You will now see that 
the ABS Part has been 
removed from the 
diagram as this model 
represents the Basic 
quality level HSUV. 

On a real project you 
would now run a trade 
study on the model 
(using budget reporting, 
SySim, etc.) to judge the 
suitability of this specific 
system or product. 

If this Product Model is 
not ideal you can go to 
the Model Explorer, find 
the latest version of the 
Tutorial1 model, expand it to see the Product Model sandbox, delete the sandbox and 
un-protect the latest version of the Tutorial1 model.  Then modify the base SysML 
model, the variability model or make different decisions and try again. 

This concludes the high-level introduction into MBPLE with PTC Integrity Modeler.  More 
information can be found in the Help.
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6 Summary 

This tutorial took you through a step-by-step introduction to SysML using PTC Integrity 
Modeler, its key SysML diagrams, their toolbars and context menus. The example 
included Block Definition Diagrams, Requirements Diagrams, and many others. The 
tutorial also covered system requirements, system structure, system behavior, system 
parametric views and their relationships. In addition to editing a SysML model, we also 
looked at model quality, and verification with tools such as PTC Integrity Modeler 
Reviewer and model validation with PTC Integrity Modeler SySim. 

As you have now seen, PTC Integrity Modeler provides all the features you need for 
model-based systems engineering with SysML.  It also implements the PTC Integrity 
Process Perspective for MBSE and the optional additions of asset-based modular design 
and model-based product line engineering. 

This tutorial used very simple examples and the successful implementation of MBSE, 
ABMD and MBPLE not only require well suited languages, and a proper implementation 
of this language in a tool, but also the definition and rollout of an appropriate model-
based systems engineering process, such the PTC Integrity Process Perspective. 

We hope you found this tutorial useful and expect you to benefit greatly from the use of 
PTC Integrity Modeler and PTC Integrity Asset Library. 


