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1 Introduction 

The OMG's Unified Modeling Language™ (UML™) has, since its inception in the 1990s, 
been the de jure modeling language standard for software engineers involved in the 
creation of object oriented software. UML has not been adopted by Systems Engineers. 
Even though it provides a potentially useful underlying set of concepts and diagrams, a 
significant numbers of aspects of systems modeling are omitted or difficult to apply. 

In 2001 the International Council on Systems Engineering (INCOSE) and the Object 
Management Group (OMG) proposed that work should begin on an adapted version of 
UML for systems engineering. The subsequent production of a SysML specification in 
2006 led to considerable interest within the systems engineering community. 

1.1 Purpose 

The primary aims of this tutorial are to show how Modeler implements SysML and to 
provide practical guidance in using it to construct SysML models. To do this the tutorial 
specifies certain activities that you should carry out using these SysML models, one of 
which is downloadable from the website. 

1. These activities are numbered, to distinguish them from the explanatory text. 

1.2 Assumptions 

The tutorial is not intended to teach the principles, concepts and notation of Systems 
Engineering and SysML itself; it is assumed that the reader is familiar with these (if not, 
the SysML Final Adopted Specification can be obtained from the OMG website). 
Alternatively, (and probably somewhat easier to digest) a SysML text may be helpful in 
understanding some elements of this tutorial. 

It is also assumed that the reader has access to a licensed (Core) copy of PTC Integrity 
Modeler. 

1.3 Structure 

The first section of the tutorial examines the structure and content of a complete 
example SysML model. We look at how to navigate around this example SysML model 
using its toolbars, context menus and commands.  

In the second section, we show you how to create a new SysML model and how you can 
create a number of outputs based on that model. The order in which the various SysML 
diagrams are created is related more to the structure of SysML (see diagram) than to 
any systems modeling process.  

As with good systems engineering practice, building a SysML model is an iterative 
process, each iteration refining aspects of the model. It is unlikely that a complete 
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SysML model would be built by simply constructing a sequential set of diagrams as we 
have illustrated in the tutorial. However, the order shown here could be the basis for an 
iteration. Requirements might first be captured. Then high-level structural elements 
identified together with key aspects of their connectivity. Following that, required high-
level behavioral elements of the systems might be identified and explored, with some 
allocations of behavior to structure made (that is, what components do what things). 
The next iteration might then move down a layer of abstraction, refining and elaborating 
requirements, structure and behavior:  

 

SysML Diagram Taxonomy 

  

SysML Diagram
{Abstract}

Behavior Diagram
{Abstract}

Requirement

Diagram

Structure Diagram
{Abstract}

Block Definition

Diagram

Internal Block

Diagram

Package Diagram

Parametric

Diagram

Activity Diagram

Sequence

Diagram

State Machine

Diagram

Use Case Diagram

Same as UML 2 Modified from UML 2 New Diagram Type
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1.4 Using the SysML Tutorial 

How you use this tutorial, which sections you follow, and in what order you follow them, 
will largely depend upon your background and your overall goals.  

All readers should go through section 1 to gain an understanding of the level of SysML 
support provided by Modeler, and to familiarize yourself with the basic structural, 
navigational and functional mechanisms built in to its SysML tool.  

For those meeting the previously stated assumptions and wishing to carry out a 
complete evaluation of the tool's SysML, you should read all of section 2, in the order 
presented. Others, who may already be familiar with SysML, and who may want to 
construct only certain types of SysML diagrams can skip those sub-sections within 
section 2 that are not of interest. 

However, you need to be aware of some dependencies necessarily built in to these sub-
sections. These dependencies are shown in the following diagram (a SysML package 
diagram), where for example, the sub-section on Interactions depends upon the sub-
section on Use Case Modeling. That is, if you want to go through the Interactions sub-
section, you should first go through the Use Case Modeling sub-section. 

 

 

If you have any comments or questions regarding the use of the SysML Tutorial, please 
contact us via our website. 
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2 The Supplied Example SysML Model 

The SysML model has been populated with a set of SysML model elements and 
diagrams. The model is the hybrid sports utility vehicle (HSUV) from Annex B of the 
SysML Final Adopted Specification. 

This model is one of the supplied models installed by default into the Examples 
repository during installation. Alternatively it is available as part of the SysML Tutorial 
download from the website. 

2.1 Installing and Opening the Model 

1. Open Model Explorer from your desktop. If you can see the Examples 
repository, select it in the left pane, and then double-click the HSUV 
model in the right pane to open it in Modeler.  

The remainder of this section (1.1) only applies if you do not have access to the HSUV 
model in the Examples repository. 

If you have not already downloaded the SysML Tutorial self-extracting zip file and 
extracted the contained files, you will need to do so now, before attempting any of the 
activities in this section. Instructions can be found on the PTC Integrity Modeler 
downloads page. 

After extracting the files from the download, the model, as an exported zip file, should 
be found in the <target>\SysMLTutorial\HSUV\ directory, where <target> is the 
pathname you specified to extract the files (default is C:\PTCTutorials\).  

2. Open Model Explorer from 
your desktop.  

3. Right-click the Models 
repository and then click 
Import Model. 

4. Use the Open dialog to locate 
and open the HSUV.zip file. 
Select Yes when asked to 
confirm the import and wait 
while the model is imported 
to your Models repository. 

5. When the new model name 
appears in the repository, in 
the right pane double-click to 
open the model. 
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If you do not see a Models repository in the Models Explorer window, there may be 
another repository available to you in which you can import or create new models. If so, 
substitute the Models name in the activities below with the name of this repository.  

If not, you will need to create and start a Models repository before continuing with the 
section. Modeler's Help (Repository, Model, Component… > Repository Management > 
Administration Tasks) has pages explaining how to do both tasks. 

After creating and starting the new repository you will then need to add it to Model 
Explorer. Again the Help system provides information on how to do this (Repository, 
Model, Component … > Model Management > Model Explorer > Working with 
Repositories). 

After you have a repository running and set-up in Model Explorer, import the model 
using the preceding activities 2 to 5. 

2.2 The Modeler SysML User Interface 

 

Your initial screen should look similar to that above. If not, use the View, Reset Layout 
menu option which will change the layout to that shown. You will find that you can drag 
the internal borders of the panes to re-size them, as required.  

Property Pages 

Diagram Pane Browser Pane 

Output Panes 
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2.3 Menus and Toolbars 

The menu bar provides access to a number of generic functions. Let's look at each 
option briefly. 

 

File: Provides a typical set of File menu features. These include the facility to open 
models, to create new models and also to create new diagrams. It also provides Print 
and Page Setup facilities. It does not provide Save and Save As facilities. All changes to 
models update the repository as they are made. Consequently, a large Undo stack is 
provided. 

Edit: Provides one way of using the Undo facility. Also provides standard cut/copy and 
paste mechanisms, plus a powerful Find capability which we will return to shortly. 

View: Permits showing and hiding of toolbars and showing of closed panes. Provides a 
Refresh and the Reset Layout facility already mentioned.  

Tools: Provides access to the various PTC Integrity Modeler add-ins, including the 
documentation production tools, the Component Wizard (for sharing and transferring 
components between models) and the various model interchange mechanisms. Options 
allow you to change the default text fonts, to hide or show an alignment grid and to 
define its resolution, plus a number of other useful things. We look at some of the Tools 
options in more detail in other parts of the tutorial, but you can use Help to find out 
more about Tools options now if you wish. 

Diagram: Only visible when a diagram is open and has the focus, this menu provides 
alignment, sizing and display options for the diagrams displayed in the Drawing pane. A 
quick way to show/hide the diagram grid, and of applying/removing the 'snap to' option. 

Window: You'll find here the 'standard' Window operations, including useful tiling 
mechanisms (for viewing more than one diagram simultaneously) and a Close All to 
close all currently open diagrams. 

Help: The main access point to the Help system.  

Different toolbars are displayed dependent upon your current activities. For example, 
when you have a diagram open, you will see a common diagram toolbar and also a 
toolbar specific to that diagram type. We will examine the diagram toolbars in later 
sections of this tutorial. Here we will briefly examine the three toolbars seen on the 
screen shown earlier. 

The Find toolbar  provides a variety of 
search options as summarized by the tool-tips visible when you hover the cursor over 
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the various buttons. These buttons, and the Find option from the Edit menu, open a 
detailed Find dialog that allows you to refine the search criteria. 

The Change Tracking toolbar  provides a means of 
tracking changes to a model. You can use the Help system to find out more about 
change tracking.  

The main Modeler toolbar provides a number of facilities, many of which are duplicated 
by menu options. 

 

One facility not available from the menu is the navigate facility. The navigation toolbar 
buttons  allow you to navigate to items that have been previously selected in 
the Explorer and Output panes, also to items you have selected on Property Pages, and 
to symbols you have selected on diagrams. 

1. Spend some time (5-10 minutes, we suggest) exploring the structure and contents of 
the Help system. In particular, use the Help menu Help Topics option to bring up the 
Index facility, and from here, input 'navigation buttons' to learn about the use of the 
navigation buttons. 

You can show or hide toolbars using the View menu options. We will not need to use the 
Change Tracking toolbar so it can be hidden. 

2. Use the View menu option to 
hide the Change Tracking 
toolbar as shown opposite. 

 

 

 

 

2.4 Using the Browser Panes 

The browser panes provide access to the various items, diagrams and relationships 
defined within the model. They will also (by default) provide access to the underlying set 
of UML model items and diagrams. Some of the Explorer panes that do the latter are 
only marginally useful for SysML Modeling and can easily be removed. The panes you 
might want to remove are the Diagrams, Relationships and Dictionary panes. You should 
never remove the Packages pane. It is through this tab that new SysML diagrams and 
model elements are created. The Parts pane can sometimes provide a useful view (as 
we will see shortly). 
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A specific browser pane is opened by selecting the required browser pane tab from the 
set of tabs at the foot of the 
current pane. Each tab has a 
tool-tip that identifies the pane. By default the Packages pane is selected and open. 

1. Use the tab to select the Diagrams 
pane. 

2. Close this pane by clicking the 
Close button.  

This results in the Diagrams pane 
being closed and its tab being 
removed from the set of Explorer 
pane tabs. 

3. Repeat the previous two activities 
to remove the Relationships and 
Dictionary panes. 

You can use the View, Show Panes 
menu option at any time to re-open a 
closed pane. 

This should leave you with seven 
browser pane tabs: Packages, Parts 
and five SysML tabs: Blocks, 
Allocations, Requirements, Ports and 
Flows, and Constraint Blocks. The 
order of these may be different, but 
note that you can drag and drop tabs 
into any position.:  

We will start by considering the Packages pane.  

4. Open this pane by selecting the Packages tab (the left most tab of the Explorer tabs). 

There are three top level packages: ModelingDomain, HSUVModel and Profiles.  

Below these entries you can see a couple of Text Diagrams: a ReadMe and a copy of the 
introductory information from Annex B of the SysML specification.  

5. Double-click the ReadMe text diagram name in the Packages view. 

This opens the text 'diagram' in the diagram pane, which explains a little about the 
diagrams in this model. You may also want to open the Annex B text diagram if you're 
not familiar with the SysML sample problem. 
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6. When you have read the text, close the text diagram by 
clicking the close button on the diagram tab in the Diagram 
pane (as opposite). 

The other two top level packages, ModelingDomain and HSUVModel (with the standard 
package icon), contain the HSUV model information. We will need to examine these – 
although much of the information is also accessible through the other panes.  

The main purpose of the Packages tab is to allow you to structure the model content in 
a meaningful way. 

7. Expand the HSUVModel package. 

This allows you to see the sub-packages within the HSUV 
Model and any model elements (items or diagrams) that 
are scoped to the HSUVModel package itself. You can 
expand any of these sub-packages to see their content if 
you wish. 
 
8. Double-click the HSUV Model diagram name. 

This will open a package diagram that diagrammatically 
shows the package structure of the HSUV model 
together with a few key items and relationships. 

You can now see the description of the diagram in the diagram properties. 

All diagrams in this model have the SysML specification description added to their 
properties. 

9. Select the diagram name in the Package browser and examine its Description property 
via the property pages Text tab.  

 

The other top-level package visible in the Packages pane is the ModelingDomain 
package. This package contains domain items and sub-packages that define domain 
specific value types and stereotypes. It also contains two more package diagrams, one of 
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which shows the value types and their units, the other shows how the items and sub-
packages here relate to each other. Both of these diagrams have a Description property 
pasted from the SysML specification.  

Now we will look at the SysML panes and return to the Parts pane later. We will 
consider these panes in the order that we will cover their topics in the tutorial, rather 
than the order their tabs appear in the 
Explorer panes. 

10. Select the Requirements pane.  

Here you see a set of folders containing the 
requirements, diagrams, tables and 
relationships that that exist in the model (as 
shown opposite). 

11. Expand these three folders: 
Requirements, Requirement Diagrams 
and Requirement Tables. 

Each of these (and the other folders) gives 
you a 'flat' list of model items of a specific 
type. This view is a sort of 'dictionary items' 
view of requirement related elements.  

Compare your current on-screen 
Requirements pane view, showing the 
'flat' list of requirements, requirement 
diagrams and requirement tables with 
the view that follows (note that this 
view is not currently visible in your 
model). 

This view is a Packages pane view 
showing the hierarchical structure within 
the HSUVRequirements package. It 
shows the way the model owner has 
chosen to create and organize the same 
set of requirements, requirement 
diagrams and requirement tables you are 
seeing in the Requirements pane. 

12. Select the Blocks tab to open the 
Blocks pane. 
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Blocks are one of the key model elements in SysML. A good description of blocks and 
some of the other folders you see with this tab can be found in the Description property 
of the top 'block' folder in the Blocks pane.  

Like the Requirements pane, the Blocks pane provides a flat, dictionary-like view of 
block-related elements in the model. Each folder displays its content in alphanumeric 
order, making it easy for you to locate any specific item. 

13. Expand a few of the Blocks view folders to get an idea of how much block-related 
information is in the model. 

14. Now switch back to the Packages pane, and expand the HSUVStructure package 
within the top-level HSUVModel package. 

Here you will see many (but not all – some are elsewhere) of the blocks and block 
diagrams visible from the Blocks pane view. Block definition diagrams (BDDs) are visible 
at the foot of the package that scopes them, but to see internal block diagrams (IBDs), 
you will need to expand the block that owns the IBD. 

Because IBDs are owned by a block, you can open an IBD from the context menu of the 
parent block. If a block has one or more child IBDs (not all do), you can right-click that 
block in either the browser or on a diagram and use the Open option to select and open 
a child IBD. 

The remaining SysML Explorer panes (Allocations, Constraint Blocks, and Ports and 
Flows) all provide similar, folder-organized, alphanumerically-ordered lists of relevant 
model elements. If you wish you can select these tabs to see what sort of information 
they contain. 

That leaves us with the Parts pane. As the name implies, this pane is used to show the 
decomposition of anything that can contain parts (for example, requirements, blocks, 
constraint blocks, etc.). It is typically used to view the decomposition of a block.  

15. From the Packages pane, expand the HSUVStructure package within the top-level 
HSUVModel package and then expand the AutomotiveDomain block. 

This exposes the parts of the AutomotiveDomain block. Note that attempting to expand 
the drivingConditions part shows no further layers of decomposition; you will only ever 
see one layer of decomposition in the Packages view. 

16. Double-click the AutomotiveDomain IBD. 

This opens the IBD that follows, where the parts are visible. We are viewing the high-
level automotive domain entities for a Hybrid Sports Utility Vehicle (HSUV) and how 
they connect with each other. 
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Note that the parts on the diagram (in this case, with some customized symbols), as in 
the browser, have a name that shows their part name (for example, drivingConditions) 
followed – after a colon – with the name of the block that types the part (Environment).  

Two additional pieces of information are also visible on the diagram. Firstly, it shows 
which parts connect to which other parts. Secondly, the drivingConditions part is itself 
composed of lower-level parts (weather, object and road), all of which are external to 
the domain, as indicated by the 
«external» stereotype. 

17. Now switch to the Parts pane, where 
you will also be able to find and 
expand the AutomotiveDomain block 
(as opposite). 

There are clearly some differences in 
what is being displayed. For a start, here 
we are able to see all layers of 
decomposition, so we can expand 
drivingConditions to see its parts. We do 
not see the IBD – it's not a part of the 
block, merely scoped to the block. Nor do 
we see the actors because they too are 
not actually part of the block but are 
referenced by it (which is why they have 
no part names in the Packages pane). 

ibd [Block] AutomotiveDomain

«system»

HSUV : HybridSUV

vehicleCargo : Baggage

«external»

drivingConditions : Environment

«external»

weather : Weather

«external»

road : Road

«external»

object : ExternalObject

Driver

Passenger

Maintainer

x5

x2 x3

x4

x1

version="0.1"

description="Initial concept to identify top level domain entities"

reference="Ops Concept Description"

completeness="partial. Does not include gas pump and other 

external interfaces."
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18. You should now spend some time examining the structure and content of the 
HSUVModel package and its sub-packages in the Packages browser. You should also 
relate this content to the way in which that content is presented in the five SysML 
browser panes.  

The intention is for you to get an overview of what this model contains and how this 
content is organized. It may help if you also relate this to Annex B in the SysML 
specification (if you have this available). 

2.5 The Output Panes 

Like the Explorer/Browser Panes, the Output Panes group provides a set of individual 
panes that can be used for a variety of purposes. These panes are as follows: 

 Contents Pane 

 Results Pane 

 Results 2 Pane 

 Output Pane 

 Favorites Pane 

 Diagram Thumbnail Pane 

Contents: Displays the contents of the currently selected item in the currently open 
browser pane. You can use the drop-down View list to select another browser pane that 
you wish to view in the Contents Pane.  

The content display format can be changed 
using the display option buttons. The order in 
which the content is displayed can be 
changed by clicking into one of the column 
headings (for example, the Type heading). 

Unlike the browser panes, items displayed in 
the Output panes can be multi-selected 
(using the Shift or Ctrl keys). This can be 
useful for multi-deletion, common property 

setting, or moving items between packages. 

In the following illustration the Contents pane is showing the contents of the Package 
browser, which has been selected from the drop-down list. 
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Results: The two panes act similarly in showing the list of elements (including diagrams) 
that result from a model item search. You can normally select which Results pane to 
receive your output, thereby allowing you to compare search results for example. 

In the example that follows, we are seeing the results of a request to report all usage of 
a specific actor (Driver). From the list in the Results pane, we could double-click a 
diagram name to open the diagram in the Diagram pane. 
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1. On the previously opened Automotive Domain IBD (as above), right-click on the 
Maintainer actor and select Report, Usage. 

2. When the list appears in the Results pane, double-click the name of the Use Case 
Diagram to open that diagram. 

3. Then right-click on the Maintainer actor entry in the Results pane and select Find, On 
Diagram to locate the actor on the use case diagram. 

4. Finally, right-click the linked 'Maintain the vehicle' use case on the use case diagram 
and select Find, In Package Browser to locate the package scoping the use case. 

Output: Provides the user a way of outputting model specific information. These include 
error messages, status messages and Report Writer outputs (see the Help system for 
details of the Report Writer). 

5. Right-click in a blank area of the currently open use case diagram and select Report, 
Consistency. 

You will notice that the Output pane is automatically selected to show the report 
output. 

The set of consistency checks applied depends upon the type of diagram. You can use 
the Help to find what consistency 
checks are performed for each 
diagram type. 

Favorites: Lets the ability you 
quickly access items and diagrams 
that you use regularly. You can add 
any item or diagram to the Favorites 
pane and then use that item's or 
diagram's context menu commands 
as you would anywhere else in the 
tool. In addition, you can use the 
items and diagrams in the Favorites 
pane for performing drag-and-drop 
operations.  

Items can be added to the favorites 
pane either by dragging the item 
into the pane from the browser 
window, or by right-clicking on the item (in the browser window or on the open 
diagram) and selecting Add To Favorites from the context menu. 
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6. Find the Automotive 
Domain internal block 
diagram in the 
Packages pane. 

7. Open the Favorites 
pane. 

8. Drag the Automotive 
Domain IBD to the 
Favorites pane. 

9. Find the diagram in the 
Blocks browser using 
its context menu by 
right-clicking on the 
diagram in the 
Favorites pane and 
selecting Find ► In 
Blocks Browser. 

Diagram Thumbnail: A view for panning 
around and zooming in or out of the 
diagram currently displayed in the 
Diagram pane.  

10. Select the Blocks browser pane and 
expand the Internal Block Diagram 
folder. 

11. Double-click the diagram name 
highlighted opposite to open this quite 
large diagram. 

12. Zoom in to 100% on this diagram. 

You can now only see part of this diagram 
in the diagram pane. 

Select the Diagram Thumbnail pane and drag 
the shaded area around, noting the effect in 
the diagram pane. 

Panning is normally done by dragging the 
shaded area in the Diagram Thumbnail pane, 
although both arrow keys and the mouse 
wheel (with the Shift key) can be used. 
Zooming is done using the mouse wheel, but 
with the Ctrl key down. This pane is typically 
used to navigate around large diagrams. 
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2.6 Diagrams and the Diagram Pane 

Although we have covered a number of diagram features so far, there are still other 
generic diagramming facilities that are important. One key concept to understand is that 
items displayed on a diagram are actually symbols representing an underlying model 
item in the model database (hence the distinction between Delete and Delete from 
Model in the previous section). The model item can be represented symbolically on 
many diagrams and, in some cases, many times on the same diagram.  

A significant number of diagramming facilities are provided with toolbars. The common 
diagram toolbar is shown here. 

 

 
 
 
 
 
 
 
This toolbar is available whenever any diagram of any type is open.  

It provides three sets of buttons that allow you to align, evenly space out and 
standardize the size of symbols on the diagram.  

Align to Grid: Provides the ability to align any symbols (including connection links) that 
you add to the diagram to the alignment grid. The granularity of the grid, and whether 
you opt to show or hide the grid is controlled through the Tools, Options menu.  

Selecting the Diagrams 
section on the Tool Options 
form provides the options 
for this grid, as opposite. 

You can also see, from the 
other tabs, that the Tools 
Options form provides pages 
to allow you to change the 
default shadow settings for 
diagram items; to define the 
fonts used in rich text fields 
(including that used for 
embedded model 
references); and to set print options for printing of diagrams. 

symbol 
alignment 

align 
to grid 

diagram 
resizing 

page 
breaks 

diagram 
lock 

symbol 
spacing 

symbol 
sizing 
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Diagram Resizing: Allow you to zoom in and out of the currently open diagram or to fit 
the diagram to the diagram pane. 

Page Breaks: Toggles the visibility of printing breaks on a large diagram. Where these 
occur depends on your print option settings. 

Diagram Lock: Allows you to control whether other model users can edit a diagram that 
you have opened with write access. The whole issue of permissions is a complex one in a 
multi-user tool like PTC Integrity Modeler, and is outside the scope of this tutorial.  

In addition to the common diagram toolbar, each individual diagram type has its own 
toolbar. This will contain buttons specific to the modeling relevant to that type of 
diagram. However, they nearly all contain the following set of buttons that are identical 
for each diagram type. 

 
 
 
 
 
 
Note: Provides the ability to add a note to a diagram to add some information. It is 
merely a diagram symbol with no corresponding model item. Often you will want to use 
the Link button to link the note with a specific item or items it relates to. 

Comment: Similar to a Note, the difference being that a Comment is a model item that 
belongs either to the package that contains the diagram (if unlinked), or to the model 
item it is first linked to. 

Constraint: Similar to a Comment but is shown on the diagram enclosed in { }. A 
constraint is a limitation imposed upon the functionality of a system. 

Both Comments and Constraints are created as model items. 

Frame: Used to create a frame box on a diagram that can be resized to enclose a set of 
diagram items. Frame boxes have no model repository items, they are simply diagram 
symbols, to aid communication and understanding. They can be named and the name 
can be shown on the diagram.  

1. Spend a little time now using the toolbar buttons explained in this section on some of 
the diagrams in the HSUV model. Make sure you undo any changes you make. 

2.7 Context Menu Options 

The right-click initiated Context Menu provides quick access to a frequently required set 
of functions, some of which we have already seen (for example, Report). As you 

Note 

Comment 

Constraint 

Link 

Frame 
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progress further through the tutorial you will notice that several of the Context Menu 
options appear in many contexts whereas others are much more context specific. It is 
worthwhile briefly considering some of the more useful and generic options now. 

Links: A powerful mechanism for creating 
associations between appropriate model 
diagrams and/or model items. A Links Editor 
dialog box is used to create or break links. 

New: Used to create new items that belong to 
the source item; this includes child diagrams. 

Populate: Provides a quick way of adding 
existing model items and relationships to a 
diagram. The Populate sub-menu is context 
sensitive depending on whether you invoke it 
from the diagram canvas or an item on the 
diagram, and what type of diagram or item it 
is. 

Open: Allows you to open child or associated 
diagrams. 

Find: Allows you to locate a selected item or 
diagram in one of the Explorer panes, or an 
item on a large diagram. 

Applied Stereotypes: Provides a quick method 
of applying a stereotype to a model element. 
The list of stereotypes offered is dependent on 
the element type. 

Add To Favorites and Remove From Favorites: 
Provide a method of adding the source item to 
the Favorites pane. 

Delete and Delete from Model: Delete simply removes an item from the current 
diagram but leaves it in the model and therefore on other diagrams. Delete from Model 
is more powerful as it totally removes an item from the model and all diagrams (you will 
be asked to confirm this type of deletion). 

View Options: Allows you to show or hide information for one or more diagram items. 

The Help system has more specific information on many of the above options. 
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2.8 Property Pages 

Property Pages are the same as the other panes in that they can be resized, hidden, 
moved or undocked using a common set of buttons in the top right corner . The 
Help section on 'Organizing Modeler panes' is useful here. The Property Pages include 
an additional button , which opens a Help topic for the properties that are displayed 
on the Property Page.  

As you have been selecting elements of the HSUV model, you will have noticed the 
Property Pages changing. Different model item and diagram types have different 
Property Pages as we will see more fully in section 2 of the tutorial. 

However you may also have noticed that certain model items (for example, blocks) have 
a Property Page corresponding to their «block» stereotype. These pages contain a set of 
tags definitions (additional properties), many of which have derived (grayed out) tag 
values. 

2.9 User Roles 

Modeler provides User Roles that provide a way of removing unwanted features from 
the Modeler user interface, and removing unwanted items and diagrams from the 
Packages pane. 

If you are interested in only SysML diagrams and items, you may want to use the 
provided Systems Engineer or Minimal Systems Engineer user role to remove non-SysML 
diagrams and items from the Modeler user interface.  

To select a user role: on the View menu, click User Roles, and then select the user role 
you want to use.  

For more information about using and customizing User Roles, see the User Roles - 
Configuring Modeler for Different Users section of the Modeler Help.  
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3 Building a SysML Model 

The example HSUV model is useful to see how SysML has been implemented in the tool. 
We will now look at how you construct this model within tool. Any models you build 
will, most likely, be different from the supplied example model, so in this section we will 
describe the generic mechanisms that are used to build any SysML model. To save time 
and effort, we will not re-build the complete example model, we will show you the main 
concepts and how to create a SysML model.  

The PTC Integrity™ Process Perspective™ recommends the best practice process for using 
SysML during Systems Engineering projects. That said, organizations always adapt 
existing systems engineering processes or define and evolve new ones as SysML 
becomes more widely used. In this section we apply a logical flow which involves an 
iterative approach based on the SysML diagram taxonomy on page 2. Each iteration 
corresponds to a layer of abstraction of the system and involves the capture of 
requirements relevant to that layer, followed by the definition of structural and 
behavior elements necessary to meet those requirements. Work would then progress 
on the next layer(s). In the main, we will have to restrict what we do to a single layer. 
One other area where we are forced to diverge from 'real' practice is the fact that 
information in the tutorial has to be presented serially. In practice, work within the 
iteration, certainly that defining the structural and behavioral elements, would be done 
in parallel. So the steps we will cover in this section are as follows: 

1. Capture requirements (requirement diagram) 
2. Define blocks, their parts and their connectivity (block definition and internal block 

diagrams) 
3. Define constraint blocks and parametrics (parametric diagram) 
4. Identify use cases (use case diagram) 
5. Define activities (activity diagram) 
6. Allocate activities to blocks (activity diagram) 
7. Define interactions (sequence diagram)  
8. Define state behavior (state diagram) 
9. Establish requirements traceability 
10. Capture model structure (package diagram) 
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3.1 Using SysML 

SysML is implemented as a UML profile. UML profiles allow the customization and 
extension of the UI, properties and behavior of UML within the tool.  

The first step in building a SysML model is to create a new model which includes the 
SysML and UML Profiles. These Profiles can also be added to an existing model at any 
time. Let's start by creating a new model;. 

1. Either open Model Explorer, or if you still have it running, check that you can see the 
Models repositories. 

 
Your Model Explorer window may show more repositories than those shown above; that 
does not matter as long as one of them is the Models repository. 

If you do not see the Models 
repository, try right-clicking the server 
in the left-hand pane of the Models 
Explorer window and selecting Show 
All Repositories, as in the diagram 
opposite. 
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If the Model repository appears, but in 
gray (as in the diagram opposite), right-
click the repository and select Bookmark. 
The repository will then turn blue and can 
be opened. If Models is not present in this 
dialog, you can probably use the 
Examples repository to hold the model 
you are about to create. Failing that you 
will need to create a repository in which 
this model can be stored (see the Help). 

If you have any unforeseen problems at 
this stage our Support team will be able 
to get you up and running. 

The instructions that follow assume you 
will be using the Models repository; you 
will need to change the name if you are 

using some other repository. 

2. In the Model Explorer window, click the Models repository to open it. 

3. Right-click in the right-hand pane and select Create New Model ► New Model with 
Profiles.  

 

4. Scroll down the resulting New Model dialog and select the SysML (Full Profile) check 
box. 
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This will automatically select the UML check box so that both profiles will be added to 
the model. 

5. In the Model Name text box, enter the name My SysML Model, as shown above. Then 
click the OK button. 

It will take some time to create the model with the required profiles. 

6. When My SysML Model appears in the Models repository in the Model Explorer 
window, in the right pane double-click the name to open the model. 

The SysML and UML profile packages are visible in the Packages pane. Note that like all 
profile packages, they are protected so that they are not modified erroneously and 
therefore their content cannot be changed unless the model owner unprotects them.  

WARNING: Editing the SysML or UML Profile can result in severe failure in a SysML 
model and may make it impossible to upgrade the profile at a later point. It should be 
done only in exceptional circumstances and even then only by someone who fully 
understands all aspects of the profile. 

At present your model, with the SysML and UML profiles added, can be used to build 
both SysML and UML models. This can be very useful if you want to combine UML 
design elements in with a SysML model. However, if you want to create a SysML-only 
modeling environment, you can remove the UML-oriented Explorer panes by following 
activities 1-3 on page 8.  
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3.2 Developing the Model 

Existing users will notice that the creation of SysML elements is no different to the 
creation of UML elements. SysML diagrams are created from the context menu of a 
package or item in the Packages browser pane in which you want the diagram to reside. 
SysML model items (for example, blocks or requirements) are created either on the 
diagrams or from the context menu of a package or item in which you want them to 
reside. Relationships between items can be created on diagrams, or in some cases 
through the context menu for one or both of the items. 

Consequently, it is often the case that some thought needs to be given very early on as 
to how the model should be structured, in terms of the package hierarchy. This 
structure typically evolves as the model becomes larger. A package diagram (see section 
3.12 on page 114) can be used to capture this structure together with the dependency 
relationships between packages. We will not create a structure now, but we will 
illustrate the evolution of a structure by adding packages as we go through each of the 
following sections. 

3.3 Capturing Requirements 

SysML requirements can be created manually within the model. However, for many 
projects system requirements will exist in some external form. They might be defined in 
a Microsoft® Office product (Word® document or Excel® spreadsheet), or held in some 
requirements management tool (for example PTC Integrity Lifecycle Manager or IBM 
Rational® DOORS®). Where this is so, simple copy-paste can normally be used to copy 
requirement text into SysML requirements. The problem then is that you need to keep 
both copies synchronized with any changes. Modeler's Integration for IBM Rational 
DOORS does just that, and more. However, it goes well beyond the scope of this tutorial 
to consider the use of the Integration for IBM Rational DOORS here. We will simply 
create requirement text in situ, knowing that in practice we would probably use 
Integration for IBM Rational DOORS to create SysML requirements in a SysML model 
from the requirements source format. 
 
1. Right-click the model name in the Packages browser and select New ► Package. 

 

2. Enter the name HSUVModel as in the supplied model. 
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3. Now right-click on the HSUVModel package, select New ► Package again, and name 
this package HSUVRequirements. 

You now have an HSUVModel package containing an HSUVRequirements package, 
within which you are about to create a requirements diagram and some requirements. 

4. Right-click on the HSUVRequirements package and select New ► Diagram ► SysML 
► Requirement Diagram.  

 

5. Leave the diagram name as the default '[Package] HSUVRequirements' (default 
because the parent item – a package – has this name). 

6. On the requirement diagram toolbar, select the Requirement button . 

7. Click the diagram, inside the diagram 
frame to create a new requirement. 

8. Name it Performance. 

The new requirement appears on the 
diagram. It also appears in the Package 
browser (together with the diagram) 
beneath the HSUVRequirements package, 
as shown opposite.  

9. Open the properties of the Performance 
requirement and select the 
Requirement tab. 

10. To set a requirement id# value, double-
click in the Tag Value column for id#, 
and enter the required text value 
(REQ_1 in the example opposite). 



Capturing Requirements  - Block Definition Diagram (BDD) 

27 

In Modeler, Requirements are created with default text within their description, this will 
need to be changed. 

11. Select the Text tab on the Performance property pages, and select the Description 
property from the drop-down. 

12. Replace the default description text (The System shall do…) with something more 
meaningful (see the example that follows). 

Note that in practice the above text may be imported from some external source. 

You will have noticed that this additional property is not yet visible on the diagram. You 
can control how much information is shown on diagrams, using the View Options form, 
or, as in this case, via a context menu option to Show/Hide Compartments. 

13. Right-click Performance on the diagram and select Show/Hide Compartments. From 
the dialog that appears, expand the Properties folder, and then select the Description 
and Id# check boxes.  

If you wish, you can resize the 
Performance requirement on the diagram, 
so that it looks similar to the example that 
follows. 

Note that you can hide compartments by 
deselecting the selected options (we have 
done so for following screen shots). 

We mentioned earlier that many of the 
derived tag values for a requirement are 
set by creating relationships between the 

requirement and other model items. We will return 
later to consider traceability relationships to other 
model items, but now we will consider relationships 
between requirements. 

14. Use the Requirement toolbar 
button, as previously, to create 
another requirement on the 
diagram called Acceleration. 

15. Now select the Requirement Nesting Link button . 

16. Click first on Performance, then on Acceleration to create the link 
between the requirements (as opposite). 
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This nesting relationship (one requirement contained as part of another) has been 
captured in the properties of both requirements, as you can confirm by looking at the 
requirement tab properties for Acceleration.  

It is also visible in the Package browser view, as shown opposite. 

The other relationship to cover here is the derive dependency, 
where a client requirement is derived from a supplier requirement. This time we will 
show an alternative way to create a requirement. 

17. In the Packages browser, right-click the HSUVRequirements package and select New 

► SysML ► Requirements ► Requirement. 

18. Name the new requirement Power. 

The Power requirement should be clearly visible in 
the Package browser, as shown opposite.  

19. Now drag the Power requirement from the browser and drop it on the diagram. 

20. Then, select the Derive dependency toolbar button , click first on Power (the 
client), then on Acceleration (the supplier). 

This will create the dependency (Power 
requirement is derived from Acceleration 
requirement) as shown opposite. You will 
also see this relationship in the 
requirement properties page of each 
requirement (although there is no visibility 
this time in the Packages browser view). 

In practice, you would set id# and Description properties for both Acceleration and 
Power, and perhaps use the Show/Hide Compartments option to display these on the 
diagram. 

To finish this section on requirements, we will create a requirements table. 

21. Right-click on the HSUVRequirements package in the Packages browser and select 
New ► SysML ► Requirements ► Requirement Table. 

This creates the table scoped to the package. 

22. Amend the default name slightly to include 
Table1 inside the final pair of square 
brackets as shown opposite. 

Before we look at this table, we will consider 
the scope and format of what it contains. 
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The table will include all requirements scoped to the parent package of the table, 
including those in any child packages. If you want to extend the scope to another 
package outside the parent you can do this, by right-clicking the table in the browser 
and selecting Set ► Analyzed Packages. The Links Editor will then allow you to define 
the packages you wish to analyze - look for further details in the SysML Help.  

Another thing you might want to do is to define the specific information that goes into 
the table. There will be a row for each requirement within the selected scope, but you 
have control over what columns are created when you open the table. 

23. Right-click the table name in the browser and select Set ► Column Definitions. 

This opens the Profile Column Editor 
shown opposite, which will allow you to 
configure which columns appear and how 
wide they should be. 

We want to end up with five columns: 
Name, id#, txt, subRequirements and 
derivedFrom, and we want them to appear 
in that order with auto width. The example 
you see opposite has two columns we 
want to remove. Your Editor window may show the same or it may be slightly different. 
Removing an unwanted column is very simple. 

24. Select the unwanted column entry (for example, rationale) and then click the DELETE 
button : on the Editor toolbar. 

25. To add a new column, click the NEW button  on the Editor toolbar.  

This adds a new entry to the list, by default another Name entry. 

26. Click (you may need to double-click) the 
new Name entry to expose the drop-
down list (see opposite). 

27. Scroll the drop-down list to find the 
required entry (for example, the id# 
entry shown opposite) and select it (do 
not click the OK button yet). 

New entries are added with the default auto width value. Should you want to change 
this, you simply double-click the width column and insert the required width value (try 
using 35 as a value). 

The order of the list defines the order of the columns. To move an entry up or down the 
list in the Editor window you use the up/down arrows to the right of the delete button. 
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28. Select the id# entry and click on the 'up' button . 

This positions id# between Name and txt. 

29. Add the other columns we stated earlier and place them in the correct positions. 

30. When your Editor list is correct, click the OK button and confirm your changes when 
asked. 

31. Then double-click the table entry in the browser. 

The table will open in Excel. You may want to adjust column width and row height using 
standard Excel formatting functions, but be aware that these changes will not be 
preserved. You can confirm that the required information is present and that it is correct 
and consistent with that on the requirements diagram. 

32. Close Excel and choose not to Save the table when asked. 

The table gets re-generated from current model information each time you open it in 
the tool, so you only need to save if you want to baseline the table at a point in time. 

Before leaving requirements modeling, you should switch to the Requirements browser 
pane and open the folders there to see the model elements you have created. 

33. Finally, close the requirements diagram and collapse the HSUVRequirements package 
in the Packages pane. 

3.4 Blocks and Block Diagrams 

Blocks, in SysML, provide a means of describing a system as a hierarchy of modular 
components, each of which can have a set of structural and/or behavioral features. The 
block definition diagram (BDD) is principally used to capture block properties and 
relationships. The internal block diagram (IBD) is mainly used to define the internal 
structure of a block, how the internals parts are connected and what flows between 
them. 

To begin we will create a package within the HSUVModel to hold this structural 
information, and from which we can create the diagrams and items we will need. 

1. Right-click on the HSUVModel package in the Package browser, and select New ► 

Package. Name it HSUVStructure. 

3.4.1 Block Definition Diagram (BDD) 

We will start by creating a BDD in our new package. 

2. Right-click on the HSUVStructure package and select New ► SysML ► Structure ► 

Block Definition Diagram as shown in the following image. Leave the diagram name as 
the default. 
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This creates a BDD with the same name as the package scoping it. We will use this to 
build a preliminary block hierarchy for the HSUV. 

3. Select the Block toolbar button , and click on the diagram within the frame. Name 
the block HybridSUV. 

4. Create three other blocks on the diagram, either using the Block toolbar button, or by 
right-clicking the HSUVStructure package in the browser, selecting New ► SysML ► 

Structure ► Block (see the previous screen image) and then dragging the block to the 
diagram. These blocks should be named BrakeSubsystem, ChassisSubsystem and 
PowerSubsystem. 

To show that these subsystems are composite parts of the HybridSUV we create 
composition relationships. 

5. Select the Composition toolbar button , first click on 
HybridSUV, then click on BrakeSubsystem. 

You diagram should look similar to this, and in the browser 
you will see a new entry selected, scoped to the HybridSUV 
block, so that you can name it in-situ.  

6. Through the General tab of its Property Pages, name the 
composition relationship 'bk'. 

You will see the block property BrakeSubsystem added to 
the HybridSUV block appear on the diagram (you may want to hide the compartment as 
was shown before, the parts tag is under the roles section).  
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We have modeled that 1 HybridSUV contains 1 part called bk that is typed by the 
BrakeSubsystem block. Part names are also called role names (the part plays a specific 
role with the parent block).: Both the numbers and the part/role name can easily be 
changed. 

7. Open the properties 
for the composition 
relationship and 
select the End Role 
tab, as opposite. 

8. Select the tbd entry 
from the drop-down 
list (as shown 
opposite). 

You can also use these 
properties to change the 
part/role name. There's 
nothing significant about 
bk, it's just the identifier we have chosen to use to name the instance of the 
BrakeSubsystem within the HybridSUV. Note that, on the diagram, you can move the 
role name around the composition relationship to which it belongs. The tbd selection 
simply means that you will see no value at all shown on the diagram for the multiplicity 
(as in the original diagrams in the SysML specification). As you can see, you have a range 
of options for the multiplicity value, including 'user defined' which allows to specify, for 
example, 2 if you had two separate brake subsystems in the HybridSUV. 

9. Select the Start Role tab and set the HybridSUV multiplicity value also to tbd. 

10. Create two other composition relationships, with their end role names set to 'c' and 'p' 
and their multiplicity set to tbd in each case (as shown in the following example). 
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Note the effect that these diagram changes are having in the 
Packages browser. The part/role names are showing within 
the HybridSUV block to indicate the three top-level parts of 
that block; each part entry also shows the name of the block 
that types that part. 

11. Create another block called BrakePedal and then create a 
composition relationship from BrakeSubsystem to 
BrakePedal (role name is bkp, multiplicities are tbd). 

12. Create a composition as before between PowerSubsystem and BrakePedal. In the 
properties select the Options tab and deselect the Composite Aggregation check box. 

This creates a similar looking relationship to composition, except that the diamond is 
unfilled (see the following diagram). In SysML this type of relationship is used to model a 
shared item. The BrakePedal instance that belongs to the BrakeSubsystem, is shared by 
the PowerSubsystem. We will see the implications of this shortly. Composition (part 
association, in SysML terminology) and aggregation (shared association) have similar 
sets of properties.  

13. Select the shared association from PowerSubsystem to BrakePedal and use its 
properties to set the End Role role name to bkp and the multiplicities to tbd. 

Your diagram should now look much like this. 

 

The BDD tells us what blocks have what parts and what type (of block) those parts have. 
In the Packages browser, you should see the five blocks and the diagram within the 
HSUVStructure package. Note that you cannot expand the HybridSUV's bk part (to see 
its contained bkp part) in the Packages pane, you have to select the Parts pane to see 
multiple levels of decomposition. 

bdd [Package] HSUVStructure [1]

«block»

parts
«BlockProperty» bk : BrakeSubsystem
«BlockProperty» c : ChassisSubsystem
«BlockProperty» p : PowerSubsystem

HybridSUV

«block»

parts
«BlockProperty» bkp : BrakePedal

BrakeSubsystem

«block»

ChassisSubsystem

«block»

references
«BlockProperty» bkp : BrakePedal

PowerSubsystem

«block»

BrakePedal

bk pc

bkp
bkp
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As well as showing part properties, BDDs can also be used to create and show other 
block features. You will find BDD toolbar buttons for both Block Property (Value) and 
Operation. Selecting either of these and clicking on a block on the diagram will create a 
value property for the block or a block operation (a function carried out by the block). 
You can also create block features in the browser by right-clicking the block and using 
the New context menu option.  

In practice, as your structural model becomes more complete, the use of compartments 
on a BDD can be a very useful way to see a variety of block properties. As well as the 
examples we've already mentioned, you can also show compartments for constraints, 
references and ports. 

3.4.2 Internal Block Diagram (IBD) 

It is important to note that what we haven't captured so far is information about the 
connectivity of the parts. The composition and aggregation relationships on the BDD 
show 'ownership' not 'connectivity'.  

1. Right-click on the HybridSUV block on the diagram and select New ► SysML ► 

Internal Block Diagram. 

 

2. Change the default diagram name from '[Block] HybridSUV [1]to '[block] HybridSUV 
[Part Connections]'. 

We want to add the three parts inside the IBD frame – the frame representing the 
HybridSUV block. We could do this by dragging the parts from the browser to the 
diagram, or we could use a Populate context menu option. 
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3. Right-click inside the IBD diagram frame and select 'Populate ► Nodes ► Block 
Properties'. 

 

The HybridSUV parts are added to the diagram, but you will have to drag them to the 
position you want (see the final IBD over the page). Note how the parts are shown with 
the part name (the role name from the BDD) followed by the part type (the block that 
types the part). This can be changed if required using View Options; we will look at View 
Options shortly. Now we will model the connections. 

4. Select the Shallow Connector toolbar button , click on part c, then click on part 
bk. 

5. Drag the connector line to create a waypoint if you want one, and with the connector 
selected open its properties. 

6. Select the General tab and change the 
default name (Connects) to c-bk (as shown 
opposite). 

By default, connector names are not shown 
(they often clutter the diagram). To hide or 
show information on diagrams in Modeler, you 
use the context menu View Options. 

7. Right-click the c-bk connector line and 
select View Options. 

8. Select the Association entry (a 
connector defines an association 
between parts), and select the Show 
Name check box to show the name on 
the diagram. Click the OK button. 

9. Create another shallow connector from 
part p to part bk, name it p-bk, and show 
the name on the diagram. 
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We could have left the use of the View Options until both connectors were created. 
Then, by selecting both connectors (using the Ctrl key), we could have right-clicked on 
either and set View Option for both. You will find that can multi-select similar items on 
many diagrams to change their View Options collectively, rather than individually. 

Your diagram should look similar to the one that follows. You can resize most of the 
items if you wish by selecting them and then dragging a border.  

 

3.4.3 Ports, Interfaces and Item Flows 

Once we start to consider connectivity of parts on an IBD, we will also start to think 
about exactly how the parts are connected and what items can flow between them. This 
leads us to modeling ports, interfaces and item flows. 

In doing this we will also illustrate another important concept in SysML modeling: layers 
of abstraction. Having modeled high-level subsystems and their basic connections, we 
will now drill down inside the PowerSubsystem block to see (some of) its internal 
structure and connectivity. This time however, we will start with an IBD and create the 
blocks we require to type the parts as we go. 

1. In the Packages browser, right-click the PowerSubsystem block within the 
HSUVStructure package, and select New ► SysML ► Internal Block Diagram. (You can 
leave the default name for the diagram - [block] PowerSubsystem [1]). 

2. Right-click on the diagram and select 'Populate ► Nodes ► Block Properties'. 

All that happens is that just one part is added, the bkp part, typed by the BrakePedal 
block, which is owned by the BrakeSubsystem, but shared by the PowerSubsystem. The 
dashed boundary indicates it is a non-composite (in this case, shared) part. 

We can create parts, and, if we wish, the blocks that type them, on the IBD. 
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3. Select the 'Block Property' toolbar button , and click inside the diagram frame. 

This brings up the Type Selector dialog, which defaults to allow you to select an existing 
(block) type but also allows you to create a new one. 

 

4. Select the Create a New Type option (as opposite) which changes the Type Selector 
dialog to allow you to create a new block which will be the type for the part you are 
about to create. 

5. Enter the name InternalCombustionEngine for the new block, and click the OK button. 

Two things will happen: in the browser, you will see the new InternalCombustionEngine 
block appear, and on the diagram a new part – typed by this block – is created, with the 
input box selected for you to enter a part name to replace the default BlockProperty1. 

6. Enter the name ice for the part, 
as shown opposite. 

7. Using the previous three 
activities as a guide, create three more parts (trsm, ecu, and ft) within the 
PowerSubsystem block as shown in the following example. 

 

ibd [Block] PowerSubsystem [1]

PowerSubsystem.bkp : BrakePedal

PowerSubsystem.ICE : InternalCombustionEngine

PowerSubsystem.trsm : Transmission

PowerSubsystem.ecu : PowerControlUnit

PowerSubsystem.ft : FuelTankAsembly
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As you see the diagram is showing the full name of each of the Block Properties. This can 
be changed for all the Block Properties, to make the diagram look a bit cleaner. 

8. Right-click on the diagram background and select 'Default View Options (Profile)'. 

 

9. Select the 'Set existing symbols to default options' check box at the bottom of the 
dialog, select the 'Block Property' check box, high-light the Block Property and finally 
double-click the 'Show Full Name' value to change the value to 'False'. 

At this more detailed level of modeling, the connections between these parts will go via 
ports. We will illustrate the creation and use of both standard ports and flow ports 
(including atomic and conjugated flow ports), as described in the SysML specification. 

We will start with standard ports. We will create standard ports on both the ice and ecu 
parts that specify the provided and required services for these parts. Consequently we 
will use an option that allows a standard port to be untyped, the typing being done by 
the provided and required interfaces defined on these ports. 

10. Select the Standard Port toolbar button , and click on the ice part. 

11. When the Type Selector dialog appears, click the untyped option, and name the port 
ctlPrt. 

12. Move the port around the edge of the ice part, and then 
move its name to the position shown opposite (for 
straight line connection to the ecu part). 

13. Use the last three activities to add a standard port to the ecu part. Name it icePrt, and 
position it for straight line connection to the ctlPrt.  
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Now for the interfaces. An interface is one of the UML concepts inherited by SysML. An 
interface defines a set of operations. 

14. Select the Provided Interface toolbar button 
, click the ctlPrt on the ice part, move the 

mouse pointer to the left (see opposite) of 
the port and then double-click. 

15. In-situ, change the default name (Interface1) 
to I_ICECmds, as opposite.  

This creates the provided interface symbol on the diagram (as 
opposite). It also creates the I_ICECmds interface, scoped to the 
HSUVStructure package, in the model. You will see this in the 
browser: 

16. Now select the Required Interface toolbar button , click again on ctlPrt, move the 
mouse this time to the lower left (see the following image) of the port and double-click. 

17. Name the new interface I_ICEData. 

This also adds the required interface symbol to the diagram and adds the I_ICEData 
interface to the HSUVStructure package. 

The procedure for adding a provided or required interface to a diagram where the 
interface already exists in the model is very similar except that the double-click is with 
the right mouse button not the left mouse button. This opens the Type Selector dialog 
from which you can select the required interface. 

18. You should now use these same two toolbar 
buttons to create provided and required 
interfaces on the ecu part's icePrt port. 
However, note that for this port the interface 
selections are reversed: I_ICEData defines the 
provided interface, I_ICECmds defines the 
required interface. Remember to double-
RIGHT-click to open the Type Selector. 

By default, when you create interfaces using the diagram toolbar, the interfaces are 
scoped to the package scoping the diagram. We will create a sub-package within 
HSUVStructure to hold these interfaces. 

19. Right-click on the HSUVStructure package in the Package browser, select New ► 

Package, and name the new package HSUVInterfaces. 

20. In the browser pane select each interface in turn, drag it and drop it on the 
HSUVInterfaces package name to rescope it. (Note that you could use the Contents 
pane to multi-select both interfaces and do the drag-drop in one operation.) 
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The final step here is to add a shallow connector between these two ports. 

21. Select the Shallow Connector toolbar button , click on icePrt then click on ctlPrt 
(although the order is not important).  

We will take a look now at flow ports, and we will start with atomic flow ports. 

22. Select the Flow Port toolbar button , and click on the ice part. 

This opens the Type Selector dialog. Flow ports may be typed or untyped. We will create 
a Value Type (Torque) to type the atomic flow ports that will be used to connect the ice 
part to the trsm part. We will then show how you can set the unit and dimension 
properties for a Value Type. We could have created the Torque Value Type, including 
any necessary units and dimensions, before attempting to use it when creating the flow 
port (as with the icePrt interfaces).  

23. Select the 
Create a New 
Type option, 
and enter the 
name Torque. 

24. Select Value 
Type (Data 
Type) from the 
drop-down Types list and click the OK button. 

25. When the Value Selector dialog appears, 
select the 'out' option (the engine 
delivers torque to the transmission), 
and click the OK button. 

The flow port is now created on the ice 
part on the diagram, and the browser 
shows the flow port as a new property of 
the InternalCombustionEngine block that 
types the ice part. The browser view has this new port selected, ready for you to replace 
the default name. 

26. Enter the name trsmPrt (you can rename block properties in the browser view at any 
time, using the context menu Rename option). 

The flow port and its name can be repositioned 
anywhere on the boundary of the ice part. It will 
provide a connection to the trsm part, so is best 
placed opposite that. 
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Note that Flow Ports are part of the SysML 1.2 specification. They have been removed 
from the SysML 1.3 specification and replaced with Full and Proxy ports. These ports will 
be discussed later in the tutorial. Modeler has kept both specifications within its profile 
for legacy modeling purposes. 

You can also choose whether to show one or both parts of its name using View Options 
(right-click the port on the diagram). View options also exist to allow you to show 
multiplicity and to define the exact position of the port with respect to the part 
boundary.  

You will see that what you have created is an atomic flow port with an 'out' direction (as 
indicated by its contained arrow) because this was what you selected on the Value 
Selector dialog. So, for the receiving port on the trsm part we need to create an atomic 
flow port of the same type but with an 'in' direction. 

27. Select the Flow Port toolbar button again, and click on the trsm part. This time, in the 
Type Selector dialog you choose Select an Existing Type, select All Valid Types ► 

SysML ► All Value Types (Data Type) and then select Torque from the list before 
clicking the OK button. 

28. From the Value Selector dialog select the 'in' option, click OK and name the new port 
icePrt. 

Before we connect these two flow ports and define what flows between them, we will 
just finish with the Torque value type we've created. Currently Torque is scoped by, and 
visible within, the HSUVStructure package. In practice, it may be sensible to create a 
separate package to hold types created specifically for the automotive domain. This 
could then be exported (see package import/export in the Help) and reused in other 
automotive projects. Because we will only need a couple of specific types we won't 
bother to do this now. But we should set the unit property for this value type. 

To do this we make use of the generic 'set' mechanism provided by the SysML profile. 
There is a Set context menu option for a number of model items where properties can 
be set – we will see some other examples later. However, first we need to create the 
Unit. 

29. Right-click on the HSUVStructure package and select New ► SysML ► Structure ► 
Unit, and call it ft-lbf. 
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30. Right-click Torque in the browser and select Links ► Unit. 

 

31. Expand the All Valid Items ► All Units, then scroll down and select ft-lbf, then press 
OK. 

You will see the ft-lbf unit scoped to the HSUVStructure package in the browser view. 
Again we should probably re-scope this to the types package holding Torque (if we had 
one). 

There is no visible evidence of the setting of qualityKind and unit properties, either in 
the browser or on the diagram. But we do see them in the properties pages. 

32. Open the properties for Torque and 
select the ValueType (DataType) tab, 
as opposite. 

Now we will return to connecting the 
atomic ports. Creating the connector is 
simple. 

33. Select the Shallow Connector toolbar button , click the trsmPrt on the ice part, 
then click the icePrt on the trsm part. 

To finalize this connection we will create an item flow for the connector. 

34. Select the Item Flow toolbar button , and click on the connector. 

For a connector between atomic flow ports, the type of the item flow must match the 
type of the ports. 

35. Use the Type Selector dialog to select Value Type from the drop-down list and then, by 
expanding the All Valid Types ► SysML ► All Value Types (Data Type), select Torque. 
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36. When the pop-up appears, select the 
target port (as shown opposite). 

37. Name the item flow g1 (as in the original 
HSUV model). 

The connection should now look similar to that opposite. 
You can move the item flow and the flow name; you can 
also use View Options to hide or show item flow 
information. 

To complete this section on flow ports we need to look at 
non-atomic flow ports and the use of conjugates. To do 
this we will create a connection between the ice and ft 
parts. Because a single type of item flows between atomic 

flow ports, they are normally of the same type as the item flow type. Non-atomic ports 
are used where there are multiple types of item flow between parts, and are normally 
typed by a flow specification. A flow specification defines a set of valid item flow types 
that can be sent and/or received across the flow ports. We could create a flow 
specification as we create the first flow port (like we did with the Torque Value Type), 
but it's probably more sensible to create it before we need to use it. 

First, we will create a package to hold this and any other flow specifications. 

38. Right-click the HSUVStructure package and select New ► Package. Name it 
HSUVFlowSpecs. 

39. Now right-click on the HSUVFlowSpecs package and select New ► SysML ► Structure 

► Flow Specification. Name it FuelFlow. 

We now need to define the set of flow properties for FuelFlow. Each flow property 
specifies a type and direction for one or more flow items that can flow in or out of a port 
typed by FuelFlow. 

40. Right-click FuelFlow and select New ► SysML ► Flow Property). 
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41. Use the now familiar Type Selector to create a new block type called Fuel, then select 
its direction as out. 

 

This creates a flow property within FuelFlow, typed by the Fuel block. 

42. Name the flow property fuelSupply. 

43. Use the last three activities as a guide to create a second flow property within 
FuelFlow, also typed by the now existing Fuel block, direction as in and called 
fuelReturn. 

The contents of the HSUVFlowSpecs package should look like 
that opposite. 

Now we can create the flow ports. 

44. Select the Flow Port toolbar button once more, and click in the ice part. 

45. Use the Type Selector, and its Types list, to select the existing FuelFlow flow 
specification as the type for the port, select the inout direction. 

46. Name the port ftPrt (on the diagram). 

47. Position ftPrt along the bottom boundary of the ice part. 

48. Now create another non-atomic flow port, also typed by FuelFlow, on the ft part. 

49. Name this port icePrt, and position it along the right boundary of the ft part. 

50. Now right-click icePrt 
(either on the diagram or in 
the browser) and select Set 
► Is Conjugated (as 
opposite). 

51. In the Value Selector 
dialogue, select TRUE. 
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The name of the block typing the port is now prefixed with a 
tilde (~) on the diagram to indicate a conjugated flow port, 
using the same flow specification as ftPrt, but where the flow 
property directions are reversed (that is, what is sent by ftPrt 
is received by icePrt, and vice-versa). 

Finally we will make the connection between these ports and add the specific item 
flows. 

52. Select the Shallow Connector toolbar button , and make a connection between 
the two flow ports (remember you can drag the connector line after creating it, to 
create a waypoint). 

53. Now select the Item Flow toolbar button , and click on the connector line. 

54. From the Type Selector dialog, select the Fuel block as the type for the item flow (you 
may find it easier to locate Fuel through the Package Hierarchy folder, as shown 
opposite).  

55. Click the OK button. 

56. Select the ftPrt on the ice part as the destination of the item flow. 

 

57. Name the item flow fuelSupply. (Although it doesn't need to be, we want to make it the 
same as the flow property name in the FuelFlow flow specification from step 42 – you 
can even copy the flow property name and paste it in at this point as the item flow 
name to make sure they are the same.. 

58. Use the last four activities as a guide to create another item flow, also of type Fuel, but 
going in the opposite direction to the icePrt on the ft part. Name the flow fuelReturn 
(so that it has the same name as the other flow property in the FuelFlow flow 
specification). 

Currently, the diagram should look similar to the one that follows. Note we have added 
a simple connector to the bkp (BrakePedal) part. 
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As mentioned earlier in the Tutorial, we have been creating ports that are part of the 
SysML 1.2 specification. Now we shall discuss the changes to ports in the SysML 1.3 
specification.  

The Ports in SysML 1.3 are called Full ports and Proxy ports. Full ports are used to show 
anything that has behavior, is a system component or physical connections. Due to 
these ports having behavior they handle incoming and outgoing items, operations and 
signals. They are very similar to Flow ports, but are more generic. Proxy ports do not 
have behavior are not system components and provides an indirect access to data and 
features. 

59. Right-click on the HSUVStructure package and select 
New ► Diagram ► SysML ► Block Definition 
Diagram, and leave it with the default name [Package] 
HSUVStructure [2]. 

60. Drag the PowerSubsystem block from the 
HSUVStructure package onto the new diagram. 

61. Remove the compartments by right-clicking on the 
block and select Show/Hide Compartments. Expand 
Roles and deselect the relevant options. 

ibd [Block] PowerSubsystem [1]

bkp : BrakePedal

ice : InternalCombustionEngine

ctlPrt : 

trsmPrt : Torque

ftPrt : FuelFlow

ctlPrt : 

trsmPrt : Torque

ftPrt : FuelFlow

trsm : Transmission

icePrt : TorqueicePrt : Torque

ecu : PowerControlUnit

icePrt : icePrt : 

ft : FuelTankAsembly

icePrt : ~FuelFlowicePrt : ~FuelFlow

I_ICECmds

I_ICEData
I_ICEData

I_ICECmds

g1 : Torqueg1 : Torque

fuelSupply : Fuel

fuelReturn : Fuel

fuelSupply : Fuel

fuelReturn : Fuel
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In this instance, there are no details concerning the SysML 1.2 specification. So removing 
the compartments is to make the diagram easier to read. However, if the flowPorts 
compartment was shown on the block, then we would want to definitely remove the 
compartment as we are creating a SysML 1.3 compliant diagram and mixing the two 
specifications is classed as poor modeling. 

62. Create two new blocks either from the toolbar or the package browser and call them 
Differential and FrontWheel. 

63. From the package browser drag the FrontWheel block onto the diagram, so you have 
two instances of it. 

Your diagram should look similar to this. 

 

64. Select the Composite Association  toolbar button, click on PowerSubsystem and 
then on Differential. 

65. Do the same for both FrontWheel blocks. 
The second block you connect will come 
up with a selection menu, click new. 

66. Select both the Composite Associations 
that go to the FrontWheel blocks (by holding down control) and in the Properties 
Options tab, deselect the Composite Aggregation check box. 

The front wheels are part of the system, but with an automotive they don't have to have 
two wheels. This is why we deselect the composite aggregation check box as a car is not 
composed of just two wheels they are made up of wheels, but how many is a decision 
for the car maker. The model must represent this option. 

bdd [Package] HSUVStructure [2]

«block»

Differential

«block»

FrontWheel
«block»

FrontWheel

«block»

PowerSubsystem
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67. To make the diagram look a bit cleaner right-click on one of the associations and 
select Align Aggregations. 

68. Select each Non-Composite Association individually and on the End Role tab of the 
Properties type 'lfw' for one and 'rfw' for the other (left and right front wheel). Select 
the Composite Association and call the End Role 'dif'. 

The final diagram should look like this: 

 

We have created the Block Definition Diagram first as we needed to show the 
relationships between the PowerSubsystem, the differential and the FrontWheel. This is 
so we can build the Internal Block Diagram more easily with the correct associations. 

69. Right-click on the PowerSubsystem block in the Package browser, selecting New ► 
SysML ► Internal Block Diagram and keep the default name [Block] PowerSubsystem 
[2] 

bdd [Package] HSUVStructure [2]

«block»

Differential

«block»

FrontWheel
«block»

FrontWheel

«block»

PowerSubsystem

1

1

dif
1

1

lfw
1

1

rfw
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70. Right-click on the background of the new diagram and select Populate ► Owner (as 
below). 

 

 
71. Drag the Transmission, Differential and the FrontWheel (twice) parts onto the diagram 

to look like below: 

 

 
72. Select the Full Port  toolbar button and click on the right edge of the Transmission 

Part. 

73. Select New Type 
and call it 'trq', then 
name the port 'trns'. 

74. Select the Full Port 
toolbar button 
again and click the 
left side of 
differential. 

ibd [Block] PowerSubsystem [2]

«block»

PowerSubsystem

trsm : Transmission dif : Differential

lfw : FrontWheel

rfw : FrontWheel



Blocks and Block Diagrams - Ports, Interfaces and Item Flows 

50 

75. Select Existing type and choose the one just created 'trq' under All Valid Types ► All 
Blocks, then name the port 'diff'. 

76. Select the Shallow Connector 

 toolbar button and 
connect the trns port to the 
diff port. 

77. Name the Connector 'spline'. 
Use the connector's view 
options to show the name of 
the connector. 

On the ports you will notice there 
is no direction. So we cannot see 
via the diagram whether the flow 
of the ports is In, Out or InOut. 
Unlike SysML 1.2, SysML 1.3 does 
not allow Flow Specifications on 
ports. Instead to show the direction of a Port a Flow Specification needs to be added to 
its typed block or interface block. 

78. In the package browser, right-click the trq block and select New ► SysML ► Flow 
Property.  

79. In the select type dialog choose existing type and All Valid Types ► SysML ► All 
Value Types (Data Type) ► Torque, click OK. 

80. Set the direction to inout and click OK. 

You will notice that both ports have changed 
to show the inout arrows. This is because 
they are typed by the same block and they 
are now using the Flow Specification just 
created. 

Item flows in SysML 1.3 are created in exactly the same way as in SysML 1.2. 

81. Select the Item Flow   toolbar button and click on the spline connector. 

82. In the select type dialog choose existing type and All Valid Types ► SysML ► All 
Value Types (Data Type) ► Torque, click OK. 

83. Select 1  PowerSubsystem.trsm.trns and 
name the Item Flow t1. 

84. Repeat activities 81 to 83 but choose 2  PowerSubsystem.dif.diff and name it t2. 

Note that if you want to change the direction of an Item Flow on a diagram, you can 
right-click it and then click Change Direction.  
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The view of the ports and their blocks should look similar to this. 

 

85. Create four new Full ports two on the Differential and one each on the FrontWheel 
blocks. 

86. Connect the ports together and from the View Options clear the Show Type check box. 

The resulting diagram should look like the diagram that follows. We are showing that 
the Differential has a connection to the two front wheels. What we are not showing are 
the flows and types as we already know this from the previous connection to the 
transmission. It is advisable to keep the diagram as simple as possible for ease of 
reading. 

 

To complete the section on SysML 1.3 ports we need to look at a Proxy Port. Proxy Ports 
are used to interface between external parts of the system to the internal functionality, 
but they are used as a pass-through. They do not have any behavior, so are always typed 
by an Interface Block. 

87. Select the Proxy Port  toolbar button and click on the boundary of the 
PowerSubsystem near the lfw frontWheel. 

ibd [Block] PowerSubsystem [2]

«block»

PowerSubsystem

trsm : Transmission

«full»

trns : trq

dif : Differential

«full»

diff : trq

«full»

«full»

lfw : FrontWheel

«full»

rfw : FrontWheel

«full»

t1 : Torque

«itemFlow»

t2 : Torque

«itemFlow»

spline



Constraint Blocks and Parametric Diagrams - Ports, Interfaces and Item Flows 

52 

88. Select New Type and 
call it drive, then click 
OK. 

89. Name the port lDrv. 

90. Create a new Proxy 
port next to the rfw 
frontWheel and choose Existing Type All Valid Types ► All Interface Blocks ► drive. 

91. Call the port rDrv. 

92. Select the Shallow Binding Connector  toolbar button and create a connection 
between Proxy port lDrv and the lfw frontWheel. 

93. Do the same for the rDrv and the rfw frontWheel. 

The reason for using a binding connector is because to show that the value at each end 
of the connector are exactly the same, this is why the <<equal>> stereotype is shown on 
the connector. The final diagram should look like this. 

 

3.5 Constraint Blocks and Parametric Diagrams 

In determining the physical structure of systems, systems engineers are frequently 
confronted with trade-off, performance, verification and validation issues that depend 
on the relationships between system properties such as cost, performance, power 
consumption and weight. 

ibd [Block] PowerSubsystem [2]

«block»

PowerSubsystem

trsm : Transmission

«full»

trns : trq

dif : Differential

«full»

diff : trq

«full»

«full»

lfw : FrontWheel

«full»

rfw : FrontWheel

«full»

«proxy»

lDrv : drive

«proxy»

rDrv : drive

t1 : Torque

«itemFlow»

t2 : Torque

«itemFlow»

spline

«equal»

«equal»
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Variables representing such properties and the mathematical relationships between 
them can be defined in SysML using constraint blocks and parametric diagrams. A 
constraint block defines a particular constraint (a formula and the variables it 
references). Constraint blocks are typically reusable specifications that can be related to 
other blocks in the model. A parametric diagram describes how constraints relate to 
specific properties of a block. Such constraints and constraint diagrams can then be used 
by the systems engineer to aid in the analysis of and decision-making about these trade-
off, performance, verification and validation issues. 

The constraint that we will use to illustrate these concepts is to define the relationship 
between fuel flow rate (required to be delivered by the fuel pump as part of the fuel 
tank assembly), the fuel demand (from the fuel injectors in the engine), and the fuel 
pressure (produced by the fuel regulator, also in the engine). The formula relating these 
items is as follows: 

 Flowrate = pressure /(n*demand) 

where n is the number of injectors 

First we will create the constraint block and relate it to the PowerSubsystem block. 

1. Open the HSUVStructure BDD. (You will find this either by expanding the 
HSUVStructure package in the Packages browser, or through the Block Definition 
Diagrams folder in the Blocks browser – in both cases the full diagram name is 
'[Package] HSUVStructure [1]'.) 

2. Enlarge the containing frame on the diagram if necessary (see the final diagram on 
page 55). 

3. Select the Constraint Block toolbar button , and click on the diagram below the 
PowerSubsystem block. Name the constraint block FlowConstraint. 

The constraint block is added to the diagram, with a constraints compartment showing 
an empty constraint between { } symbols. In the Packages browser, within the 
HSUVStructure package, you will see the FlowConstraint constraint block. 

We now need to define the three formula variables as parameters ('n' will be fixed at 4 
for us as there are 4 injectors). This can be done using the diagram toolbar, or, in the 
browser, from the FlowConstraint context menu (New ► SysML ► Constraint 
Parameter). We will use the diagram toolbar. 

4. Select the Constraint Parameter toolbar button, and 
click on FlowConstraint. 

5. Use the Type Selector dialog to select the Value Type 
Real (All Valid Types ► All Value Types (Data Type) ► 
Real) as the type for this parameter. 

6. Name (in situ, in the browser) this first parameter: flowrate. 
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Note how Modeler automatically adds a Parameters compartment to the constraint 
block on the diagram, with the parameter name and type shown.  

7. Create the other two parameters (pressure and demand, both also of Value Type Real). 
You might like to try to use the context menu approach from the browser. 

We will now use these parameters to specify the constraint for 
FlowConstraint.  

If you expand FlowConstraint in the browser, below the three 
parameters you will see an item called Constraint1. It is through 
Constraint1 that we specify the constraint. 

This is a bit of SysML inherited from UML, the SysML constraint block acting as a 
'wrapper' for the UML constraint, the constraint (or constraints – there can be more 
than one) being a property of the constraint block. 

The constraint itself has a set of properties and it is through these that we specify the 
formula. 

8. Select the constraint 
(Constraint1, not the constraint 
block) in the browser, open its 
properties and select the Full 
Text tab. 

9. Enter the formula (as opposite) 
by dragging the parameter 
names from the browser and 
dropping them into the Full 
Text field to create the blue 
hyperlinks and typing the other 
characters. 

Click on the diagram and you will see that the formula has been entered into the 
Constraints compartment of the constraint block.  

Finally, for this diagram, we should model the relationship FlowConstraint has with the 
PowerSubsystem block. We will use a composition relationship, to indicate that a 
specific usage (instance) of the constraint block is owned by PowerSubsystem. 

10. Select the Composition toolbar button , click first on the PowerSubsystem block, 
then on FlowConstraint. (You can add a waypoint by left clicking at any point.) 

You have used this relationship before and should therefore be familiar with the use of 
the composition properties to set the role name and multiplicity values (see activities 7 
to 9 on page 32. 

11. Set the role name to fc, and the multiplicity values to tbd. 
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The BDD should now look similar to this.  

 

We can now move on to create a parametric diagram that will show how the 
parameters for FlowConstraint relate to specific value properties of the 
PowerSubsystem component. 

However, before we can do this we should elaborate the internal structure of 
PowerSubsystem a little more, to create the components directly involved in fuel flow. 

12. Close the HSUVStructure BDD and open the PowerSubsystem IBD (either from 
Packages browser by expanding the PowerSubsystem block, or from the Blocks 
browser Internal Block Diagrams folder).  

13. Select the Block Property toolbar button , and click 
inside the ft part to create a part within ft called fp typed 
by a new block called FuelPump. 

14. In a similar way, create two new parts within the ice 
part: fi typed by a new block called FuelInjector, and fr 
typed by a new block called FuelRegulator. 

15. Now right-click the new fi part and 
select Set ► Multiplicity, as 
opposite. 

 

bdd [Package] HSUVStructure [1]

«block»

HybridSUV

«block»

BrakeSubsystem

«block»

ChassisSubsystem

«block»

constraintProperties
«ConstraintProperty» fc : FlowConstraint

PowerSubsystem

«block»

BrakePedal «constraint»

constraintParameters
«ConstraintParameter» demand : Real
«ConstraintParameter» flowrate : Real
«ConstraintParameter» pressure : Real

constraints
{flowrate=pressure(4*demand)}

FlowConstraint

bk p
c

bkp

bkp fc
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16. In the Value Selector dialog select User Defined and enter the number 4 in the text 
box. 

17. To show the multiplicity value, right-click fi again and use the View Options. 

Each of these new parts needs to have a value property that will relate to each of the 
constraint block parameters. Parts have value properties as defined by the blocks that 
type those parts. This means that we have to create the value properties through the 
block that types each part rather than through the part itself. 

18. Right-click on the FuelPump block in the browser and select New ► SysML ► Block 
Property. 

 

19. Use the Type Selector to define an Existing Type for the value property and select 
Value Type Real (for compatibility with the parameter). Name the value property 
flowRate after OK is selected (upper case R to distinguish it from the parameter 
name). 

 

20. Use the last two activities to create value properties for the FuelInjector and 
FuelRegulator blocks, both of Value Type Real, names are fuelDemand (for the 
injector) and fuelPressure (for the regulator). 

21. Select the Parts pane, locate the PowerSubsystem block and expand it as follows. 
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Although we have created these value properties for the blocks, parts typed by those 
blocks will have these same properties. You can clearly see them in the Parts browser. 

Note that 'fc : FlowConstraint', with its three parameters, 
is also visible as a part of PowerSubsystem (a 'constraint 
property' in SysML). 

It is an important requirement of SysML that all elements 
that appear on a parametric diagram are scoped, at some 
level, by the parent block of that diagram. Using the Parts 
browser allows us to drill down into all the levels of 
nested parts for a block to confirm that we have all the 
required elements. 

Now that we have done all the hard work, creating the 
parametric diagram is pretty straightforward. 

 

22. Right-click the PowerSubsystem block in the Parts browser and select New ► SysML 
► Parametric Diagram (you can leave the default name for now).  

The diagram will open but its name does not appear scoped to the PowerSubsystem. 
This is because we are using the Parts browser and the diagram is not a part of the 
block. It is scoped to the block though, and this is clearly visible in the Packages pane. 
However, we want to stay with the Parts browser pane for now, so to change the 
diagram name we do so on the diagram, rather than in the browser. 

23. Select the diagram frame and then click in the frame header. This will allow you to 
change the default diagram name to '[block] PowerSubsystem [Fuel Flow]'. 

24. Now ensure the Parts browser pane is selected and the PowerSubsystem block is 
expanded as shown in the preceding image. 

25. Then drag the 'fc : FlowConstraint' constraint block from the Parts browser pane to 
the centre of the diagram. 

26. Right-click on 'fc : FlowConstraint' on the diagram and select Populate ► Nodes ► 

Constraint Parameters. 
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27. Right-click again on 'fc : FlowConstraint' and select Show/Hide Compartments. Select 
the Constraints check box to add a compartment showing the constraint formula. 

28. Move the parameters and their names, 
and resize the box, as shown here.  

29. Now drag the flowRate value property 
of the fp part within the 
PowerSubsystem structure (see 
opposite) to the diagram. Place it below, but close to the 
flowrate parameter (see the following diagram). 

30. Select the Shallow Binding Connector toolbar button , 
and connect the flowRate value property to the flowrate parameter (see the following 
diagram). 

31. Now drag the fuelDemand value property of the fi 
part (see opposite) to the diagram and connect it 
to the demand parameter. 

32. Finally drag the fuelPressure value property of 
the fr part to the diagram and connect it to the 
pressure parameter. 

The final diagram should look similar to that below. Note the names on the value 
properties, showing their scoping. The key point to be aware of here is that we have 
been able to drag these items to the diagram because they are all parts within the 
PowerSubsystem block that owns the diagram. 

 

We have now modeled a parametric relationship between value properties of parts 
within the PowerSubsystem. Through the use of PTC's Integration for MATLAB Simulink 

par [block] PowerSubsystem [Fuel Flow]

fc : FlowConstraint

constraints
{flowrate=pressure(4*demand)}

demand : Real

flowrate : Real pressure : Real

demand : Real

flowrate : Real pressure : Real

PowerSubsystem.ft.fp.flowRate : Real

PowerSubsystem.ice.fi.fuelDemand : Real

PowerSubsystem.ice.fr.fuelPressure : Real

fc : FlowConstraint

constraints
{flowrate=pressure(4*demand)}

demand : Real

flowrate : Real
pressure : Real

demand : Real

flowrate : Real
pressure : Real



Use Case Modeling  - Ports, Interfaces and Item Flows 

59 

it is possible to synchronize this static SysML model with a block diagram in MATLAB 
Simulink to carry out dynamic simulation.  

3.6 Use Case Modeling 

In comparison with the complexities of the previous two sub-sections, use case 
modeling is relatively straightforward. However, a significant shift is occurring: we are 
starting to look at behavioral modeling as opposed to structural modeling (see the 
diagram taxonomy on page 2). Use cases can be defined at several levels; the HSUV 
example has both top-level and operational-level use cases defined. We will just 
consider the operational level as the modeling concepts and techniques are the same 
irrespective of the level. 

We will begin by creating a package to hold the use case elements. 

1. Close any currently open diagrams. Then select the Packages pane and collapse the 
HSUVStructure package. 

2. Right-click the HSUVModel package in the Packages pane and select New ► Package. 
Name it HSUVUseCases. 

3. Now right-click the HSUVUseCases package and select New ► SysML ► Use Cases ► 

Use Case Diagram. Name the diagram Operational Use Cases. 

 

From the Use Cases sub-menu, you can also create two of the items that can appear on 
use case diagrams (actors and use cases) directly in the package for dragging on to the 
diagram, or (as we will do) you can use the diagram toolbar to create these items. 
Increments are a tool-specific item that allows you to relate particular use cases to 
increments for an incremental development approach. 
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The first thing you'll probably notice about the diagram, is that there is no diagram 
frame. Use case modeling in SysML is inherited from UML, where diagram frames are 
optional. If you want to add a SysML diagram frame, it's quite simple. Here's how you do 
it. 

4. Select the Frame Box toolbar button , and click onto the diagram. 

5. Enlarge the frame box (drag a corner) so that it nearly fills the diagram pane. 

6. Now select the diagram name in the Packages browser and open the properties for the 
diagram. 

7. Drag the diagram name from the browser and drop it anywhere on the 
boundary of the frame on the diagram (the mouse pointer will change shape, 
as opposite, when you are within drop range of the boundary). 

The result is that the frame gets a name box in the top left 
corner as shown opposite. The name that appears after 
the uc identifier (from the Page reference property) is 
simply the name of the diagram. You can easily change the name in the browser if you 
wish and the diagram frame name will automatically change as well. 

Now let's add the diagram content, inside this frame. 

8. Select the Actor toolbar button  and click on the diagram. Name the actor Driver. 

9. Use the Use Case toolbar button  to add a use case called Drive the Vehicle to the 
diagram. 

10. Add five more use cases to the diagram, name them Start Vehicle, Cold Start, Warm 
Start, Accelerate and Brake. 

The HSUV example has other use cases, but these will be sufficient for our purposes, 
one of which is to create use case relationships. Before we consider these, we will add 
another frame box to the diagram. It is conventional on a use case diagram to enclose 
the use cases in a frame box, with the actor(s) outside the frame box, to separate what 
is happening inside our system (the execution of the use cases) from external actor(s). 

11. Use the Frame Box toolbar button again to create a frame box enclosing the use cases 
only (you may have to move diagram items around to do this – see the final diagram 
that follows shortly). 

12. Now, with the HSUVStructure package expanded in the Packages browser, drag the 
HybridSUV block from the browser and drop it on the new frame box boundary (like 
you did when creating the diagram frame). 

The result is to 'label' the frame box with the block name, but also to apply the style 
properties of a block item to the frame to make it look like a block and hide the use 
cases. This is easily corrected. 
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13. Right-click the name compartment of this frame and select View Options. 

14. On the Style tab select the Default option and then click the OK button. 

15. Select the Interaction toolbar button , click on the Driver actor, then on the Drive 
the Vehicle use case. 

This models that interaction occurs between the driver and the HSUV when the use case 
is executed. 

16. Now select the Include Flow toolbar button , click first 
on Drive the Vehicle, then on Accelerate (the order is 
important here – use Undo or the context menu option 
Delete from Model if your arrow points the wrong way – 
see opposite. Do not use the Delete key – this just simply 
deletes from the diagram canvas and will give you an 
error when you try to create the relationship in the correct 
direction). 

This creates an include relationship between the use cases; 
Accelerate is included as part of Drive the Vehicle. 

17. Create a second include relationship going from Drive the Vehicle to Brake. 

So driving includes both accelerating and braking, but what about the Start Vehicle? 
Sometimes the vehicle is driven off with it already started (every time we stop but leave 
the engine running); only occasionally do we have to start the vehicle before driving off. 
We need the «extend» relationship. 

18. Select the Extend Flow toolbar 
button  and click first on Start 
Vehicle and then on Drive the 
Vehicle. (Again the order is 
important, if you get it wrong (see 
opposite), you cannot use the 
Delete context menu option or the 
Delete key – this removes the relationship from the diagram, but leaves it in the model. 
You must Undo or Delete from Model.) 

Finally we will look at the cold and warm start use cases. 

Both are ways of staring the vehicle, but starting from cold is not the same as starting 
when already warm (for example, cold starting requires a richer air-fuel mixture). The 
generalization relationship is appropriate here.  

19. Select the Generalization toolbar 

button , first click on Cold Start, 
then on Start Vehicle (yet again, 
order is important – if you get the 
direction wrong use Undo or 
Delete from Model). 
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20. Use the Generalization toolbar button again to create this relationship 
going from Warm Start to Start Vehicle. When the pop-up (opposite) 
appears, select 1(as shown), to indicate that this the same type of 
generalization as the first one you created to Start Vehicle, rather than a 
completely new type. 

Your final diagram should look similar to this. 

 

We now need to consider how SysML can model more detailed levels of behavior. 

3.7 Activities and Activity Diagrams 

Activities are a key aspect of behavioral modeling in both UML and SysML. Much of 
SysML's activity modeling is identical to that of UML, but there are some differences. 

Activity modeling "emphasizes the inputs, outputs, sequences, and conditions for 
coordinating other behaviors." [SysML]. The 'other behaviors' include other activities, 
thereby providing a model of activity decomposition similar to models of functional 
decomposition familiar to many systems engineers. An activity can own an activity 
diagram, which describes the detail of that activity in terms of a sequence of actions 
that may include the use of other, lower-level activities. The activity diagram can also 
indicate at what point specific inputs are required by actions and specific outputs are 
produced by them. These inputs and outputs can be typed by other model items, for 
example, blocks or value types. Activity modeling provides an extensive set of model 
items. To keep this section within reasonable limits, we will just consider its key 
elements; additional information can be found in the Modeler Help. To open the 
Modeler Help, from Modeler on the Help menu, click Help Topics.  

To illustrate the creation and use of activities and activity diagrams we will take a 
common way of using activities: the modeling of the detail for a use case, specifically the 
Accelerate use case. Activity diagrams have to be created from an activity. So what we 
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shall do is create an activity from (and scoped to) the use case and use this to create the 
activity diagram. However, we will not necessarily want other activities we create on 
this diagram to also be scoped to the use case – in general, an activity is an independent 
reusable unit of behavior. Therefore we need to create a package (an HSUVActivities 
package) where these other activities can be held.  

1. Right –click on the HSUVModel package in the Packages browser, and select New ► 

Package to create the HSUVActivities package. 

2. Now expand the HSUVUseCases package, right-click on the Accelerate use case and 
select New ► Activity. Name the activity Accelerate. 

 

This creates the activity scoped to the use case. 

3. Now right-click the Accelerate activity and select New ► Activity Diagram. 

The diagram is created 
scoped to the Accelerate 
activity (expand the activity 
in the browser to see it), and 
is given the name of its 
scoping activity. In the 
diagram pane what you see is 
the frame for the diagram, 
with the name of the parent 
activity. 

We will start by adding some 
actions.  

4. Select the Opaque Action toolbar button , then click on the diagram. Name the 
action PushAccelerator. 

Opaque actions are often used in SysML modeling where precise (and lengthy!) 
execution semantics are not required. Modeler provides a comprehensive set of specific 
action types, many of which are largely relevant only to UML modelers needing to 
create 'executable' activity models relating to OO programming languages. You can see 
many of this set of action types by opening the drop-down list toolbar button . 
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Other action types have their own toolbar buttons; these actions are often used in 
SysML modeling, although we will only make use of one of these (Call Behavior Action). 
Opaque actions themselves show their UML code oriented origination in that they have 
a Body and a Language property which can be used to define the semantics for the 
opaque action. For SysML modeling these properties are typically left empty, the action 
name and its pins (see later) are sufficient to adequately define its semantics. 

Our PushAccelerator action produces output (the accelerator position) that will be used 
by another action, as we will see shortly. We model inputs to and outputs from actions 
as pins. A pin is a type of object node (there are other types - Central Buffer and Data 
Store – also visible on the diagram toolbar).  

5. Select the Output Parameter/Pin toolbar button  and click on the right-hand 
boundary of PushAccelerator on the diagram. Name it accelPosition. 

Expanding the Accelerate activity in the browser, as 
opposite, allows you to see its scoped items, including 
(at the foot of the list) its child activity diagram. As we 
add more items to the diagram this list will grow. 

Opaque actions are 'atomic' actions, they do not need 
further decomposition. Actions that are complex enough to require further 
decomposition can be modeled as Call Behavior Actions, actions that invoke the 
behavior of another activity. That activity can itself own an activity diagram that defines 
the more complex behavior, and which may contain other Call Behavior Actions. Call 
Behavior Actions are one of main ways of handling behavioral decomposition in SysML. 

There are two ways to create a Call Behavior Action; one is to create the activity first 
and then drag it on to the diagram, the other is to use the diagram toolbar. We will 
show both, starting with the use of the toolbar. 

6. Select the Call Behavior Action toolbar button  and click on the diagram.  

This opens the Select Object dialog to allow you to select an activity that will be invoked 
through the Call Behavior Action. This may be an existing activity or you can create a 
new one. 

7. On the Select Object dialog, click on the New button, and name it 
MeasureVehicleConditions. 

The Call Behavior Action is created on the diagram as 
opposite. 

Note the colon character preceding the name; this is significant. Call Behavior Actions 
have a two-part name: the first part is the name of the action, the second part is the 
name of the linked activity. By default only the name of the linked activity is shown. 
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8. Right-click on the 
MeasureVehicleConditions Call 
Behavior Action and select View 
Options. 

9. Select the Action Node entry, 
and then select the check boxes 
as shown opposite. 

Now you see both parts of the 
name (as shown below). When you 
create a Call Behavior Action, 
Modeler uses the name of the 
activity as the name of the action. In 
general you are not so interested in the action name as the activity name – hence the 

default view option. Either name 
(action or activity) can be changed 
independently of the other. 

10. Open the properties for the Call Behavior Action and select the General tab. 

11. Use this property page to change the name of the 
Call Behavior Action to CBA1. 

 
The name change is now visible on the diagram (as 
above). 

It is also reflected in the browser. You will see CBA1 
(shown opposite) together with its linked activity, 
both scoped to the Accelerate activity. 

This is an important point: the symbol on the diagram has two associated model items, 
the action – always scoped to the parent activity of the diagram, and the linked activity 
– which may or may not (as we are about to see) be scoped to the parent activity. You 
will see many other examples in this section where a diagram symbol relates to two 
model items, the symbol item, scoped to the parent activity and a linked item which 
may or may not be scoped to the parent activity. 

You can normally see the linked item from the properties of the diagram symbol item, as 
shown in the following exmaple.  
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Note also that this property page allows you to open the properties of the linked item. 

When you create an activity via the creation of a Call Behavior Action the activity is 
scoped to the parent activity of the diagram. This may be what you want (for example, if 
MeasureVehicleConditions only ever gets used within the context of the Accelerate 
activity), but it does somewhat contradict the principle of activities as independent 
reusable behaviors. However, to rescope the activity is easy: you simply drag the activity 
to the required destination - normally a package. 

12. In the browser pane, drag the MeasureVehicleConditions activity from the Accelerate 
activity and drop it on the HSUVActivities package. 

If this works correctly you will see the activity now 
scoped within the package, as opposite. Note that this 
rescoping has no effect on the diagram. Nor does it 
affect the Call Behavior Action in the browser. 

We want to model that this activity, and therefore the Call Behavior Action invoking it, 
produce an output. 

13. Select the Output Parameter/Pin toolbar button, click on the right-hand boundary of 
the Call Behavior Action on the diagram and select New Pin ► New Parameter. 

 

14. Name the Pin/Parameter vehCond. 

As you can see in the browser pane this has created two model items: 

 A pin scoped to the Call Behavior Action 

 A parameter belonging to the linked activity 

Both items have identical properties, including 
their name, direction and type (had we defined one). Unlike the Call Behavior Action 
and its linked activity, these common properties are linked; changing the name for the 
pin will result in the parameter name also changing. You might want to explore and 
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possibly change the properties of these items. If you do make sure you set them back to 
their current settings before continuing. 

Now let's see the alternative way to create a Call Behavior Action. This time we will 
create the activity and its parameters first and then drag it to the diagram. 

15. Right-click the HSUVActivities package in the browser, select New ► SysML ► 

Behavior ► Activity and name the activity ProvidePower. 

16. Now right-click the ProvidePower activity, select New ► Parameter and name it 
accelPosition. 

17. Repeat the previous step to create three further parameters 
called vehCond, drivePower and transModeCmd (as 
opposite). 

 

18. Use the Options 
property page for both 
drivePower and 
transModeCmd to set their 
direction (Mechanism) to Out 
(as opposite). 

 

 

19. Now drag the ProvidePower activity to the diagram. 

This creates a Call Behavior Action, on the diagram and - scoped to the Accelerate 
activity - in the browser. Note again that the Call Behavior Action has the same name as 
its linked activity.  

Expanding the Call Behavior Action in the browser (as 
opposite) you will see that Modeler has also created four pins, 
one for each of the four activity parameters, giving them the 
same name and direction as the parameters (the browser 
button is slightly different for input and output pins). 

There are also four pins on the diagram although they are overlaid so you will need to 
move them to see them all clearly. 
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20. Move your actions and pins so that your diagram resembles that shown below. Resize 
the ProvidePower Call Behavior Action as necessary. 

 

We now need to consider flow, both flow of control and flow of data. The concept of 
'flow', is central to UML/SysML activity modeling. Conceptually, what flows are tokens; 
control tokens to represent transfer of control, object tokens to represent the 
availability of objects or data. It is not the objective of this section of the tutorial to 
provide a detailed explanation of activity modeling concepts and elements – for that you 
should refer to a SysML or UML text – but we do need to show how certain key concepts 
and elements have been implemented in Modeler. 

Control flow is concerned with defining execution order for the actions. It is often the 
case when refining an activity into its composite actions that there is a definite 
sequence, with various control nodes being used to specify starting, stopping, 
branching, merging, etc.. The Accelerate activity is interesting because its three actions 
are not executed sequentially, but in parallel and continuously. The power provided is 
continuously adjusted according to the accelerator position and the vehicle conditions. 
Let's see how we model that. 

21. Select the Fork Node toolbar button  and click on the diagram above the three 
actions. 
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This creates a control node that allows you to model situations where a single incoming 
flow is split into multiple outgoing parallel flows. The Fork can be lengthened to cover 
the three actions as in the following diagram. 

22. Select the Join Node toolbar button  and click on the diagram below the three 
actions. 

This creates another control node (looking very similar to the fork node) which allows 
multiple incoming parallel flows to be joined into a single outgoing flow. 

23. Use the Initial Node toolbar button  to add an initial node above the fork node. 

24. Use the Activity Final Node toolbar button  to add this node below the join node. 

Your diagram should now look similar to this. 

 

We use control flows to show flow of control through actions and control nodes on an 
activity diagram. In SysML, as opposed to UML, control flows can be modeled using 
either dashed lines or solid arrowed lines. Dashed lines are used by default, although 
this can be changed through View Options. Control flows have a name but by default 
these names are not shown on the diagram. They can also have a guard condition 
defined (through their properties); guard conditions, where they exist, are shown by 
default. You can use View Options for the diagram to preset display options, or View 
Options for individual items to change default settings.  

Control flows are directional, as implied by the arrow. It is therefore important when 
adding flows to click first on the sender and then on the receiver. You will find that 
Modeler has a number of built in checks that stop you creating illegal control flows (for 
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example, multiple incoming flows to a fork node). It is generally safer to use Delete from 
Model (from the context menu) rather than the Delete key to remove incorrect flows. 

25. Use the Control Flow tool bar button  to add control flows as shown below. 

 

Note that control flow lines can be moved or have waypoints inserted in situ (left click) 
or afterwards (select and drag). Note also that in the above image we have used View 
Options to hide the action name for the MeasureVehicleConditions Call Behavior Action. 

Now we will add the object flows to show data flow in our model. 

Object flows in SysML must have a solid line. They have similar name and guard 
properties as control flows, but in addition have a more complex set of properties as 
seen through the Options tab in Modeler. It is beyond the scope of the tutorial to 
address the meaning of these additional properties; the Modeler Help system has some 
information about them, but for a detailed understanding you should read the UML 
specification or an appropriate UML/SysML text. 

As with control flows Modeler imposes UML/SysML defined restrictions on where and 
how these can be used. Object flows are only permitted between object nodes (such as 
pins) or certain control nodes (such as forks and joins). Object flows are also directional, 
so similar rules apply regarding defining and changing direction – you will find, for 
example, that Modeler will not allow you to create an object flow going to an output 
pin. 
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26. Use the Object Flow toolbar button  to add object flows between the two 
accelPosition pins and the two vehCond pins. 

This leaves us with the two output pins of ProvidePower having no outgoing object 
flows. These two pins produce outputs that are available as parameters of the parent 
activity of the diagram, Accelerate. If the Accelerate activity already had a set of 
parameters, you could simply drag the required parameters to the diagram frame 
boundary to create the boundary pins to act as destinations for the object flows. 
However, Accelerate currently has no parameters so it is easier to create both the pins 
and the parameters at the same time using the Output Parameter/Pin toolbar button. 

27. Select the Output Parameter/Pin toolbar button  toolbar button and click on the 
right-hand boundary of the diagram frame. 

28. Select New Pin ► New Parameter, and name it 
drivePower. 

A large rectangular pin is added to the frame, with an arrow 
indicating direction. In the browser two new entries have 
now appeared scoped to the Accelerate activity: 

 A new drivePower parameter; 

 The new drivePower pin. 

29. Add the other Parameter/Pin to the diagram frame and 
the Accelerate activity, naming it transModeCmd (see the 
final diagram on page 73).  

30. Create object flows going from the two output pins on ProvidePower to the pins on the 
diagram frame. 

The final issue to address for this diagram is to indicate that the model of object flow we 
have created is continuous. SysML (and the SysML Profile) provides a «continuous» 
stereotype which can be applied to flows ('activity edges' to give them their formal 
name) and parameters. Whether you show «continuous» against a flow or a parameter 
pin is to some extent dictated by the actual model, but also by personal preference. We 
will include an example of both. 

Modeler provides a quick and easy mechanism for allowing you to see all stereotypes 
that can be applied to a model item and then selecting one to be applied. You can use 
this mechanism from a diagram or from a browser pane. 

31. Right-click on the object 
flow between the two 
accelPosition pins and 
select Applied Stereotypes 
► 1 Continuous. 
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Nothing appears to happen. Hiding or showing of applied stereotypes is often 
determined by View Option settings. 

32. Right-click on the object flow again and 
select View Options. 

33. Select the Stereotypes entry, select the Show 
Stereotypes check box (as opposite), and 
click the OK button. 

Still nothing seems to appear. 

34. Right-click on the diagram background and select View Option. 

35. Scroll down to Shown Stereotypes and click the link button. 

36. Scroll down to the 'continuous' stereotype and select its check box. Click OK, then OK 
again. 

 

The stereotype now appears and can be moved anywhere along the object flow.  

37. Use the same approach (point 31-33) to apply and show «continuous» on the object 
flow between the two vehCond pins. 

Rather than apply «continuous» to the drivePower object flow, this time we will apply it 
to the drivePower parameter of the Accelerate activity and show it on the associated 
diagram frame pin. Remember the parameter and the pin are separate but linked model 
items. SysML states that «continuous» can be applied to a parameter, but it cannot be 
applied to a pin. However, Modeler recognizes that most modelers would want to see a 
stereotype that has been applied to a model item on a diagram element linked to the 
stereotyped model item. If we apply a stereotype to a parameter, we want to be able to 
see the stereotype on the linked pin. (The same is true for other similar situations; for 
example, you want to be able to see a stereotype applied to an activity on a Call 
Behavior Action linked to that activity.) 

38. In the browser, right-click the drivePower parameter of the Accelerate activity and 
select Applied Stereotypes ► 1 continuous. 
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39. Now right-click on the drivePower pin on the diagram frame (not the one on the 
ProvidePower Call Behavior Action) and use View Options to show the stereotype. 

The final diagram should look similar to this. 

 

To finish this section on activity modeling we will develop the concept of activity 
decomposition a little more and introduce a few more activity modeling items. 

40. In the browser, right-click the ProvidePower activity (in the HSUVActivities package), 
and select New ► Activity Diagram. 

This will create a child activity diagram for ProvidePower (as you would expect) for you 
to define the detail of that activity. Note how the four parameters of ProvidePower have 
resulted in the automatic addition of four linked pins on the diagram frame.  

We will not evolve this diagram in any great detail, just sufficient to illustrate the 
additional elements. 

The first of these additional elements is an activity partition (often called a swimlane). 

41. Select the Activity Partition toolbar button  and click on the new diagram, inside the 
frame. Name it pcu. 

42. Create a second activity partition (in the same way) named eng. 
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You will have noticed that the default is for activity partitions to be created horizontally. 
You can use View Options to 
arrange them vertically if you 
prefer. 

43. Select both activity partitions 
(drag over both or use the Ctrl 
key), right-click on one of them 
and select View Options. 

44. Select Vertical as the Symbol 
Orientation and set the check 
boxes exactly as shown 
opposite. 

45. Click the OK button. 

The result is to display them vertically but also to hide their names. You can, of course, 
still see their names in the browser, scoped to the parent ProvidePower activity. The 
reason we set the View Options the way we did was because we are about to link each 
activity partition with another model item and it is the linked item name and type that 
we want to see. 

The items we are going to link with are parts of the PowerSubsystem block that was 
created in a previous section of the tutorial. You can see the two parts we want 
highlighted opposite; the 'ice'part, typed by the 
InternalCombustionEngine block, and the 'ecu' 
part, typed by the PowerControlUnit block. 

The rationale behind this linking will become 
clearer with the next section of the tutorial, but 
is basically to do with linking behavior to 
structure – in this case linking the ProvidePower activity to the PowerSubsystem block. 

46. Expand the HSUVStructure package to expose the PowerSubsystem block, then 
expand that block as above. 

47. Use the property pages to identify the 'eng' activity partition by selecting an activity 
partition and seeing in the property pages which one has been selected. 

48. Drag the 'ice' part from the browser and drop it in the name compartment of the 'eng' 
activity partition. Then widen the activity partition so that the name and type appear on 
a single line. 

49. Now drag the 'ecu' part to the name compartment of the other activity partition and 
widen that partition also. 

The reason we have linked the activity partitions to parts of the PowerSubsystem is to 
indicate a structural location for any action nodes or object nodes placed in those 
activity partitions. As we add items to this diagram we will need to enlarge the activity 
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partitions. To make this easier we can join individual activity partitions to form a single 
group that can be re-sized as a unit (rather than having to re-size each activity partition 
separately). 

50. Arrange both activity partitions with the ice partition to the right of the ecu partition, 
as opposite. 

You will notice the small red triangles in the 
top-left corner of each partition. This triangle 
symbol is used to indicate an activity 
partition group. Currently each partition is in 
a group of its own. 

51. Select and drag the ice partition across to 
the ecu partition until you see the cursor 
pointer change to the symbol shown 
opposite and then release the mouse 
button. 

The result is to create a single group (just 
one red triangle) with both partitions 
adjacent to each other. You will find that you 
can now move and re-size as a group but still 
select individual partitions when required. 

There is considerable flexibility in how you can use this drag-drop capability to structure 
activity partition groups. The Modeler Help has full details. 

Now we will add a Call Behavior Action. 

52. Create a new activity in the HSUVActivities package called ProportionPower (New ► 

SysML ► Behavior ► Activity). 

53. Create two input parameters for ProportionPower called beltCond and speed (New ► 

Parameter). 

54. Now drag ProportionPower from the browser and drop it inside the ecu activity 
partition. 
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If you move the activity partition group, you will see that the Call Behavior Action also 
moves within its activity partition. Further confirmation that the activity partition 
provides a conceptual 'location' for the Call Behavior Action can be seen through their 
properties, as indicated below ('pcu' is the activity partition name). 

 

Note how the two parameters result in two input pins being created on the Call 
Behavior Action (although you will need to separate them). To finish our work on this 
diagram, we will see how these pins get their data. 

55. Move the diagram frame (ProvidePower) a little to the right. 

56. Drag the vehCond parameter around the boundary of the diagram frame to the left 
edge (see opposite). 

57. Select the Decision 
Node toolbar button 

 and click on the 
diagram between the 
vehCond pin and the 
ecu activity partition. 

58. Create object flows 
as shown opposite. 

We would normally complete the detail of the ProvidePower activity before addressing 
the next layer in the activity decomposition, that is, creating activity diagrams for 
ProportionPower and any other linked activities for Call Behavior Actions created for 
ProvidePower. 

3.8 Allocation 

Before we move on to consider the remaining two behavioral diagrams (sequence and 
state diagrams), we should briefly consider the topic of allocation. Allocation, in SysML, 
is a general term for cross-associating items from different parts or levels of a model. It 
normally involves the creation of the 'allocate' relationship and its visibility on diagrams 
and in tables. We will illustrate the use of this relationship in the common context of 
allocating behavior to structure.  
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In the previous section we showed an example of creating a Call Behavior Action in an 
activity partition (the 'ecu' swimlane) on the basis that the parent activity for that 
diagram (ProvidePower) was in some way linked to the PowerSubsystem block that 
contained the 'ecu' part. We can now make this 'link' more concrete using allocation. 

1. In the Packages browser expand the HSUVStructure package (if necessary) to expose 
the PowerSubsystem block.  

2. Expand the HSUVActivities package (as opposite) 
to expose the activities created earlier, including 
ProvidePower.  

3. Right-click on ProvidePower and select Start Link, 
as shown opposite. 

4. Now right-click on the PowerSubsystem 
block in the HSUVStructure package and 
select End Link. 

This opens the Quick Link dialog that enables you to confirm or cancel the allocation of 
the activity to the block. 

5. Ensure the 'allocated to' relationship is selected (use the drop down list to select it if 
necessary), and then click the OK button to 
confirm. 

Nothing changes in either the browser view or on 
the diagram, but things have changed in the model. 
One way we can see evidence of this is through the 
properties of the related items. 

6. Open the Allocated property page for both the 
ProvidePower activity and the PowerSubsystem 
block, as follows. 

 

We can also show these allocation relationships on certain diagrams where the related 
items appear. 
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7. Open the ProvidePower 
activity diagram (you may still 
have this open from the 
previous section). 

8. Right-click the ProvidePower 
diagram frame (easiest to 
right-click in the frame name) 
and select Add ► Callout 
Note (as opposite). 

9. In the Compartments to 
Display dialog box expand 
the Roles folder and select the Allocated To check box.  

This adds a note connected to the frame stating the allocation relationship (as opposite). 
You can re-position this note as you wish. 

 

We can, as you would expect, make the allocate relationship visible from the 
PowerSubsystem block.  

10. Open the HSUVStructure [1] block 
definition diagram in the HSUVStructure 
package. 

There's an alternative way to display the 
relationship for a block. 

11. Right-click on the PowerSubsystem block 
and select Show/Hide Compartments. 
Expand the Roles folder and select the 
Allocated From check box (as opposite). 

This results in the PowerSubsystem block 
displaying a new compartment showing any 
allocatedFrom items. 

 

Note that you get the full signature of the activity (name and parameters).  

«block»

constraintProperties
«ConstraintProperty» fc : FlowConstraint

allocatedFrom
«Activity» ProvidePower (in accelPosition, in vehCond, out drivePower, out transModeCmd)

PowerSubsystem
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The Show/Hide Compartments context menu option is a powerful feature of PTC's 
SysML profile and you will find it as an option on virtually all items and diagram types as 
a way of displaying model relationships, not just allocations.  

The use of Start Link and End Link makes allocation both simple and quick; almost any 
types of model item can be linked, not just activities and blocks. It is also very flexible as 
you can right-click items on diagrams or in the browser. We have also seen the use of 
both compartment and callout notation for displaying allocations; we will see more of 
these later. 

To finish we will see how allocations can be summarized in matrix and table form. To 
make this a little more realistic we will create another allocation relationship. This will 
also be allocating an activity (ProportionPower) to a block (PowerControlUnit). This is 
not just arbitrary – the ProvidePower activity diagram (see page 73) shows a Call 
Behavior Action invoking this activity located in an activity partition linked to a part 
typed by this block. If this activity was invoked on this diagram only, it might be sensible 
to allocate it to the block typing the part. 

12. Right-click the ProportionPower activity in the HSUVActivities package and select 
Start Link. 

13. Then right-click the PowerControlUnit block in the HSUVStructure package and select 
End Link. 

14. Select the 'allocated to' relationship in the Quick Link dialog and click the ok button. 

Note that you cannot create the allocation on the ProvidePower activity diagram. You 
are not trying to allocate the Call Behavior Action to the activity partition. 

So now we have two allocations in the HSUV model. Allocation matrices and tables are 
created scoped to a package and detail any allocations relating to items within the scope 
of that package and its sub-packages. The package can be a high-level package (for 
example, HSUVModel) if you want to summarize all allocations in the model, or a sub-
package if you only want to summarize a subset of those allocations.  

15. In the Packages browser, right-click the HSUVActivities package and select New ► 

SysML ► Allocations ► Allocation Matrix. 

16. Change the default name to '[Package] 
HSUVActivities [Allocation Matrix]'. 

The matrix name should appear in the 
browser, scoped to the HSUVActivities 
package as shown opposite. 

17. To open and see the matrix, just double-click the name. 
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After a few seconds the matrix opens in Microsoft Excel. It will show any items within 
the HSUVActivities package that are involved in allocations, along with the allocated 
items in a matrix format. 

18. Close Excel and choose not to save (there is no point in saving, each time you open 
the matrix Modeler regenerates the content). 

19. Now right-click the HSUVStructure package in the Packages browser and select New 

► SysML ► Allocations ► Allocation Table. 

The table name (use the default) appears scoped to the HSUVStructure package and is 
opened as the matrix by double-clicking the name. This also uses Excel, but this time it 
presents allocation information for the selected package in a tabular format. The 
information in the table is similar to that in the matrix, it really depends upon what 
format you want. 

Finally, let's look at how we can see allocations in a browser pane in Modeler.  

20. Select the Dictionary browser pane and expand the Allocates folder.  

This shows all allocations that are in 
the model. Any unwanted entries 
can be easily removed by right-
clicking one of the allocate entries 
and selecting Delete. Allocations can 
also be removed from the model by 
invoking the Links Editor dialog from 
the context menu of one of the 
linked items. The use of the Links 
Editor dialog is very intuitive, but 
further details can be found in the 
Help. 

21. Select the Diagram browser pane and expand the Allocation Matrix and Tables folders. 

This will show the user all the Allocation diagrams that are in the model.  

3.9 Interactions 

Interactions describe messaging between items; in a SysML model these items are 
normally structural items such as block parts or ports. In UML, four diagram types exist 
to support interaction modeling; in SysML only one of these is used: the sequence 
diagram. 

The sequence diagram provides a different approach to the activity diagram as a way of 
modeling behavior. The key difference is that with sequence diagrams the focus is on 
the sequence of message passing between elements of the system whereas with activity 
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diagrams the focus is on flow of control and information between actions. Sequence 
diagrams implicitly relate structure to behavior; the lifelines, defining the senders and 
receivers of the messages, being used typically to represent blocks, their parts or ports, 
or even actors; each message represents a request to invoke behavior in the receiver. 
Rather than trying to show all possible paths of behavior, sequence diagrams are 
typically used to model scenarios – typical patterns of behavior to achieve a particular 
goal (often that of describing the way that the behavior described by a use case is 
fulfilled by the system i.e. as a way of validating a use case). When looking at sequence 
diagrams and activity diagrams, each path through an activity diagram could be 
modeled using a sequence diagram. 

A similarity between sequence and activity diagrams is the ability of both diagram types 
to model layers of abstraction. We have already seen how activities appearing as a 
single action (a Call Behavior Action) on one activity diagram can be refined by creating 
a new activity diagram to describe the detail of each activity. Sequence diagrams use 
two concepts: 'Interaction Use' and 'Part Decomposition' to refine a single step at one 
level into a set of more detailed steps at a lower level. 

Block operations, introduced in the section on blocks and block diagrams, will resurface 
again in this section. Many of the messages modeled on sequence diagrams are 
requests for a block – or more typically a part typed by that block – to execute a block 
operation. We will also see in this section another link to activity modeling, where an 
activity (more specifically its child diagram), defines the detailed implementation of a 
block operation. We will also see how we can capture the specification-implementation 
relationship between an operation (the specification) and its implementing activity in 
the model. 

In this section we will illustrate the refinement concept as well as the use of messages. 
The supplied HSUV example uses sequence diagrams in the context of refining use 
cases. Sequence diagrams don't necessarily have to relate to use cases (we will also 
describe how to create those that do not), but this is a common use for them and is the 
scenario we will use. 

1. Close all currently opened diagrams (Window ► Close All) 

2. Expand the HSUVUseCases package in the Packages browser and double-click the 
Operational Use Cases diagram name to open the diagram. 
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3. Right-click on the Drive the Vehicle use case (either on the diagram or in the browser) 
and select New ► Sequence Diagram. 

 

This creates and opens the sequence diagram as a child diagram of the parent use case – 
as you can see in the browser pane in the following image. 

You can also create a sequence diagram scoped to a package rather than a use case by 
right-clicking the package and selecting New ► Diagram ► SysML ► Sequence 
Diagram. Other permissible parent items for a sequence diagram include Events and 
Operations. 

Driver

Drive the
Vehicle

Brake

Accelerate

Warm Start

Cold Start

Start Vehicle

«include»

«include»

«extend»

uc Operational Use Cases

HybridSUV
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When the diagram is created from a use case, the use case name is added to the top 
left. No diagram frame is created on a sequence diagram. Just like the earlier use case 
diagram, this is an inherited UML diagram, and UML diagrams do not have frames by 
default. If you wish you can add a frame in the same way as you did for the use case 
diagram (activities 4 - 7 on page 60). 

The two vertical lines visible on the diagram are the System Boundary - the thick gray 
line that separates external actors from elements within the system, and the 
Architectural Boundary - the dashed line that can be used for whatever purpose you 
wish, and is often just ignored (but cannot be deleted). 

Because the sequence diagram is a UML diagram it has a rich set of toolbar buttons, 
many of which can be ignored for SysML modeling. If you are interested in what they all 
do, you can look in the Help system or at the section on sequence diagrams in Part 2 of 
the Modeler Tutorial. 

The Description box labels the area of the diagram where you build up the description 
steps for the message sequence. In Modeler each message must have a corresponding 
description step, and the step must be created before the message can be added. You 
can do this one message at a time or, as we will do, define all description steps before 
adding messages. 

4. Select the Sequence toolbar button , 
and click into the Description area 
below the Description box. 

A sequence step is added with (UML) 
default notation seq (as opposite). This 
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default can be easily changed in-situ or afterwards by renaming the step (right-click, 
Rename). 

5. Change seq to startup. 

We will use this step to invoke the Start Vehicle use case. However, if you look at the 
use case diagram, you will see that Start Vehicle is an extension of Drive the Vehicle. We 
need to define the condition under which Start Vehicle is invoked. 

6. Select the Selection toolbar button , and click in the Description area below the 
startup step. 

This adds a selection construct (alt, end alt). 

7. Change the default notation text to something 
more meaningful, as opposite.  

We now need to move the startup step between 
the if and end if lines of the selection construct. 

8. Simply drag the startup step and drop it between 
the if and end if lines (as indicated above). 

The description steps should now look like those 
opposite, with the startup step indented within the 
selection.  

Now we need to consider the two included use 
cases, Accelerate and Brake. In our simplistic scenario we will assume that driving the 
vehicle is a repeated set of accelerate and brake behaviors. We model this on the 
sequence diagram using an iteration construct. 

9. Select the Iteration toolbar button , then click 
in the Description area below the 'end if' line. 

This creates another two-line construct with default 
text of loop and end loop (see opposite). This 
construct would normally specify the condition that 
terminated the iteration, but we will just leave the 
defaults. The final job is to add two sequence steps 
for the accelerate and brake use cases. 

10. Use the Sequence button (twice) to add an accelerate and a brake step, by clicking 
each time between the loop and end loop lines, as opposite. (If you get the order 
wrong, remember you can just drag steps and drop them in the correct position). 

There are other buttons in the toolbar group  for creating 
description steps. These include the creation of selection outcomes and parallel 
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constructs. We don't need them here, but you should refer to the Help system (under 
sequence diagram, statements) to find out what they do. 

Now we will add the 'messages'. However, as Drive the Vehicle is a high-level use case 
that references other use cases, we will not have any actual 'messages' on this diagram. 
Instead we will add references to other lower-level diagrams (child diagrams of the 
included and extended use cases) where the message sequences are shown. To create 
the references we need to have the lower-level diagrams to make the references to. 

11. Switch to the use case diagram and right-click the Start Vehicle use case to create a 
child sequence diagram as in step 3. Immediately close the sequence diagram when it 
opens (we won't need it yet). 

12. Do the same for the Accelerate and Brake use cases. 

13. Now return to the Drive the Vehicle sequence diagram and select the Interaction 
Frame toolbar button . 

14. Click on the diagram 
adjacent to the startup 
step, as shown opposite. 

This adds an interaction 
frame with the description 
step text highlighted in the 
frame's 'label' (as opposite).  

15. With this text highlighted, press the Delete 
key and then the Enter key to leave the 
interaction frame with no 'label' text (as 
opposite). 

16. Make sure the Start Vehicle child diagram is visible in the browser, then drag this 
diagram from the browser and drop it on interaction frame label, as follows. 
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The interaction frame changes, with the label showing the keyword ref - to indicate that 
the frame is now a reference to another diagram, and the name of the referenced 
diagram (Start Vehicle) in the body of the frame (see the following illustration). 

The frame (its formal name in UML/SysML is an 'interaction use') can be re-sized and 
moved horizontally but not vertically (it's tied to the startup description step). It can also 
be used to access the referenced diagram. 

17. Right-click the interaction frame 
and select Referenced Diagram ► 

Open (as opposite). Alternatively, 
double-click on the interaction 
frame. 

Note that you can also change the 
linked diagram or break the link through this context menu. 

18. Return to the Drive the Vehicle sequence diagram, and use the Interaction Frame 
toolbar button to create another frame, with an empty label, against the brake 
description step. 

19. Expand the Brake use case in the 
browser and drag its child sequence 
diagram on to the interaction frame, 
just as you did with Start Vehicle. 

20. Repeat the last two activities to create 
an appropriate frame for the accelerate 
step. 

Your Drive the Vehicle sequence diagram should now look similar to the preceding 
example. Each frame references a child sequence diagram for a use case. 

We will start on the lower-level sequence diagrams by considering the accelerate step. 
You may already have wondered why we created a child sequence diagram for the 
Accelerate use case. The Accelerate use case is the parent of the Accelerate activity, and 
that activity is the parent of an activity diagram that defines the detailed behavior for 
the use case. This is an example of what is referred to in UML as 'classifier behavior'; the 
classifier being the Accelerate use case, and its behavior being specified by the 
Accelerate activity diagram. We are about to change this. 

An operation belongs to a block in SysML and acts as the specification of some behavior 
supported by the block. The implementation of that behavior can then be described by 
an activity diagram that belongs to the activity defined as the implementation of the 
operation. Both the operation and its implementing activity must be scoped to the block 
and they must have identical signatures (number, type and direction of parameters). 

Drive the Vehicle

Description

if engine not running

startup ref Start Vehicle

end if

loop

accelerate ref Accelerate

brake ref Brake

end loop
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Given that we now have a child sequence diagram for the Accelerate use case, we will 
change the role of the Accelerate activity and its child diagram to that of defining the 
implementation for an associated operation for the HybridSUV block. The need for block 
operations can often be identified by analyzing internal block diagrams (IBDs) containing 
parts or ports typed by that block. Although our simple model has no such IBD, the 
original HSUV model does and it shows the HybridSUV typed part with a connector to 
the Driver actor. It would not be unreasonable therefore to assume that the HybridSUV 
block would need to provide an Accelerate behavior as a response to driver input. 

21. Expand the HSUVStructure package to expose the HybridSUV block. 

22. Right-click the HybridSUV block and select New ► SysML ► Operation. Name the 
operation AccelerateOp. 

The acceleration behavior provides both drive power and transmission mode commands 
as output (as defined by the Accelerate activity). Therefore the operation requires 
similar parameters.  

23. Right-click the AccelerateOp operation and select New ► Parameter. Name it dP. 

24. Create another parameter for the AccelerateOp operation called tMC. 

We have now created an operation that has the same number and type (that is, no type) 
of parameters as the Accelerate activity. However, they are not of the same direction. 

25. Select the AccelerateOp operation, open its properties and select the Sig'ture tab. 

26. Replace the 'in' with 'out' (a simple text replacement) for both parameters (as follows). 

 

This is a quicker way of changing the direction (called Mechanism in Modeler) property 
of each parameter than using each parameter's property pages. 

27. Now expand the Accelerate use case in the browser and drag the Accelerate activity 
from the use case to drop it on the HybridSUV block. 

28. Rename the activity 'AccelerateAct' (this is purely to make it easier to distinguish from 
the operation). 
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In doing this, we are redefining the purpose of the activity from that of defining classifier 
behavior for the Accelerate use case to that of defining some behavior detail for the 
HybridSUV block. If we now want to create the specification/implementation 
relationship between operation and activity in the model, we do so through the 
properties of the operation.  

29. Open the properties for the AccelerateOp operation again and select the Items tab. 

30. Select Specified 
Activities from the 
Show associated drop-
down list, and then 
click the Link button 
(highlighted opposite). 

This opens the Links Editor 
(shown below), which 
should have Specified 
Activities selected in the 
Show Associated drop-down list, and any activities scoped to the operation's block 
listed. 

31. Ensure the Types drop-down shows Specified Activities and that the AccelerateOp 
operation is visible in the left pane (as above). Then select the AccelerateAct activity 
in the central pane to add it to the selected items in the right pane (as above), and 
click the OK button. 
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The relationship is now visible through the Items properties of both the operation and 
the activity.  

 

The key point to remember is that, although the names of the operation and activity do 
not need to be the same, their signatures must match in terms of the number, order, 
direction and type (but again, not names) of their parameters. 

We now have an Accelerate use case with a child sequence diagram and the HybridSUV 
block with an AccelerateOp operation that has an associated AccelerateAct activity as its 
implementation. We can now model how the AccelerateOp operation is used on the 
Accelerate sequence diagram. However, before we do this we need to replicate the 
situation in the original HSUV model where the HybridSUV block is used to type an HSUV 
vehicle as a part of the automotive domain (see the IBD on page 12). 

32. In the Packages browser, right-click the HSUVStructure package and select New ► 
SysML ► Structure ► Block. Name the new block AutomotiveDomain. 

33. Now right-click on the AutomotiveDomain block and select New ► SysML ► Block 
Property 

34. Use the Type Selector dialog to select the HybridSUV block as the type for the part, 
and name the part HSUV. 

Acceleration is triggered by the driver depressing the accelerator pedal. The vehicle then 
responds by invoking acceleration behavior. 

35. Open the Accelerate sequence diagram, either from the browser (by double-clicking) 
or from the Drive the Vehicle sequence diagram (Referenced Diagram context menu 
option). 

36. Use the Sequence toolbar button to create two sequence steps: ' driver depresses 
pedal' and 'vehicle accelerates' (see the following diagram).  

37.  Drag the Driver actor from the HSUVUseCases package in the browser and drop it on 
the diagram, to the left of the system boundary. You will not be able to drop it to the 
right of this boundary, but you can position it anywhere to the left of this boundary, 
and in doing so, move the boundary. 



Interactions - Ports, Interfaces and Item Flows 

90 

 
38. Use View Options to hide its full name. 

39. Now expand the HSUVStructure package (if necessary), expand the 
AutomotiveDomain block and drag the HSUV part somewhere to the right of the 
system boundary. 

40. Use View Options again to hide the full name of the part. 

Now we will add some messages. We will use an event message to represent the event 
occurrence of the driver depressing the pedal. 

41. Select the Event toolbar 

button  and click on 
the Driver lifeline in line 
with the 'driver 
depresses pedal' step. 

42. Move the mouse pointer 
to the right and click on the HSUV:HybridSUV lifeline. 

43. In the Select Object dialog click the New button and name the event message 'depress 
pedal'. 

An event message is created on the diagram and the 'depress pedal' event is created in 
the HSUVUseCases package (as this is the package that indirectly scopes the diagram). 

Now we will add the AccelerateOp operation. 

44. Expand the HybridSUV block in the HSUVStructure package to see the AccelerateOp 
operation. 

45. Drag the operation from the 
browser and drop it on the 
HSUV:HybridSUV lifeline in line 
with the 'vehicle accelerates' 
step. 

This creates an operation message going from the HSUV:HybridSUV lifeline back to that 
lifeline. 
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Some modelers may have chosen to capture this differently, for example, by having just 
a single step with the operation message going from Driver to HSUV. The approach we 
have taken is not necessarily more 'correct' but it does separate external events from 
internal behavior and it has also allowed us to demonstrate more of the tool 
functionality (a key objective for the tutorial). 

In Modeler we can indicate that an operation is an 'event handler' through its 
properties. 

46. Open the properties for the 
AccelerateOp operation 
and select the Items tab. 

47. Select Events in the 'Show 
associated' drop-down list 
and click the Link button. 

48. Use the Link Editor dialog 
to select the depress pedal 
event and make the link as 
shown opposite 

The use of reference frames (InteractionUse) allows you to structure sequence diagrams 
to any number of levels. We will now examine an alternative way to model behavioral 
decomposition by considering the detail of the Start Vehicle sequence diagram. 

Unlike the Accelerate use case, where the next level of decomposition below the 
sequence diagram is described using the AccelerateAct activity diagram,: we will model 
the Start Vehicle use case at two levels: black box and white box. This will also allow us 
to illustrate the other decomposition mechanism in Modeler's sequence diagram. 

49. In the browser, rename the existing Start Vehicle sequence diagram to 'Start Vehicle – 
black box' (either right-click and use Rename, or left-click twice (not a double-click) on 
the name). Then open the diagram. 

At this black box level we want to show the driver turning the ignition key and the HSUV 
dealing with this event. This is just a single message going from the Driver actor to 
HSUV. 

50. Use the Sequence toolbar button to create a description step 'driver starts vehicle'. 

51. Drag both the Driver actor and the HSUV part (of the AutomotiveDomain block) to the 
diagram, and use View Option to hide full names (as before). 
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52. Select the Event toolbar button , click on the Driver lifeline, then on the HSUV 
lifeline – in both cases level with the 'driver starts vehicle' description step. 

 

53. Click the New button on the resulting Select Object dialog, and name the new event 
'turn key'. 

This creates an event message 
going from the Driver to the 
HSUV, as opposite. 

It also creates a 'turn key' event, 
scoped to the HSUVUseCases package (which indirectly owns this diagram). 

Events in Modeler have a rich property set that you can see by selecting either the event 
in the browser or the message on the diagram and opening the property pages. 

54. Open the property pages for 'turn key' and select the Rate tab. 

This, and the other tabs, allow 
you to capture potentially useful 
information about this type of 
event in the model. The Help 
system has details if you want to 
know more. 

Let us now consider the white 
box sequence diagram for the 
Start Vehicle use case. The 
HybridSUV block that types the HSUV part itself has parts. The white box diagram is 
going to show the detail of what happens inside a part typed by the HybridSUV block – 
the interactions between its parts -: when the 'turn key' message arrives. In practice, 
we're going to model only a little of what happens, enough to illustrate key concepts 
and techniques. To start we need to create the white box diagram and allow it to be 
referenced from the black box diagram. 

55. Right-click on the Start Vehicle use case and select New ► Sequence Diagram to 
create another 'Start Vehicle' child sequence diagram and rename it 'Start Vehicle – 
white box'. 

56. Immediately close the new diagram to return to the black box diagram. 
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57. Drag the white box diagram from the browser and drop it on the HSUV:HybridSUV item 
on the black box diagram. 

 

A reference to the white box diagram now appears in the HybridSUV item name, as is 
shown below. This is called a 'PartDecomposition', implying the referenced diagram will 
show the internal interaction between the parts of HybridSUV.  

58. Right-click on the HSUV:HybridSUV item and select Referenced Diagram ► Open, to 
open the white box diagram. 

On the white box diagram we will want to show the event message being detected by 
the ignition subsystem and a message being sent on to the power subsystem to power 
up the vehicle. The HybridSUV already has a power subsystem part (p), but it does not 
have an ignition subsystem part. We could create this on either the BDD or IBD that 
shows the high-level breakdown of the HSUV, or we could create it in the browser and 
then use a Populate option on the diagrams to add the extra part, if required. 

59. Expand the HSUVStructure package in the browser, right-click the HybridSUV block 
and select New ► SysML ► Block Property, as follows. 

 

60. Use the Type Selector to create a new block type called IgnitionSubsystem, and name 
the part ig. 
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The part appears in the Packages browser pane (as 
shown opposite). 

We now have what we need to model this level of 
functionality on the white box diagram. This time we 
will create the sequence steps as we add the messages, but remember the step must be 
added before the message can be. 

61. Use the Sequence toolbar button to add a description step 'detect key turn'. 

62. Drag the newly created ig part (of the HybridSUV) to the diagram, and use View 
Options to hide its full name (we know it's a part of the HybridSUV). 

63. Now drag the 'turn key' event from the browser and drop it on the system boundary, in 
line with the description step. 

 

64. Select the second option from the pop up box. 

 

This adds the event to the diagram, as a message going from the system boundary to 
the ig part. At this level of abstraction we are not concerned with where the message 
came from, just how it will be handled. We can envisage the system boundary on the 
diagram as though it were the boundary of the HybridSUV block. 

65. Now add a second description step (using the Sequence button again) 'activate ABS'. 

66. Drag the bk (BrakeSubsystem) part of the HybridSUV to the diagram, to the right of the 
ig part, and use View Options to hide its full name. 

The name of this part has [Instance] appearing (as 
opposite). Where has this come from? 

bk[Instance]:BrakeSubsystem
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The answer is to do with multiplicity. When this part was created on a block definition 
diagram (in section 3.4.1) we set the multiplicity value for it to tbd. This means there 
may be more than one instance of this part. The tool recognizes this and allows you to 
specify which instance you want represented on the diagram. You did not get [Instance] 
appearing with the ig part, because that was created with the default multiplicity of 1. 

67. To remove [Instance], right-click on the name on the diagram and select Anonymous 
Symbol Instance. 

We want to show a message going from the ig part to the bk part requesting activation 
of the ABS. The message this time will be an operation call, the operation being an 
operation provided by the block typing the bk part, that is BrakeSubsystem. 

68. Select the Operation toolbar button , click on the ig part lifeline (in line with the 
activate ABS step) then click on the bk part lifeline. 

The Select Object dialog opens, showing any current BrakeSubsystem operations 
available to the bk part – none at present. 

69. Click the New button and name the operation message activateABS. 

The operation message is added to the diagram (as follows). 

 

You will also now see the activateABS operation scoped to 
the BrakeSubsystem block in the Packages browser pane 
(as opposite). 

As a consequence of this message arriving at the brake subsystem within the HSUV, that 
subsystem will need to execute the required behavior (which could be modeled with 
another, lower-level sequence diagram or an activity diagram for the implementation 
activity for this operation).  

On the current diagram we might want to model that information is returned back to 
the ig part - confirming ABS activation - before the ig part sends a power up message to 
the power subsystem part (p). 

70. Add another sequence step to the description, called 'get reply'. 
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71. Select the Reply toolbar button , click on the lifeline of the bk part, in line with 'get 
reply', then click on the ig part lifeline, to open the Select Object dialog. 

 

72. Select the activateABS operation in the Signature column, and click the OK button. 

A reply message, with the dashed line, is added to the diagram, going from the bk part 
to the ig part.  

We can, if we wish, add some important information about this reply message, 
specifically what sort of information is returned and how quickly this should happen. 
This is done through the 'instance' properties of that message. Instance properties for a 
message allow you to model specific information relating to a particular instance or use 
of the operation call. 

73. Right-click the reply message and select 
Instance Properties, as opposite. 

74. Select the Options tab and enter the values 
shown below.  
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75. Click on the diagram to save the changes and move the message name on the 
diagram, as shown below.  

 

The ig part gets back the ABS status within 20 ms. In practice you would want to check 
the status was ok and set a watchdog on the time. We will just simplify this to a single 
'reply ok' test. 

76. Use the Selection  and Sequence toolbar buttons, to create the 
description steps opposite. 

77. Drag the p (PowerSubsystem) part of the HybridSUV block from the 
browser to the diagram, to the right of the bk part, hide its full name 
and make it an anonymous symbol instance. 

We will now add the powerUp operation, but this time using the approach we used with 
the Accelerate sequence diagram. 

78. Right-click the PowerSubsystem block in the browser, and select New ► SysML ► 

Operation. Name the operation powerUp. 

79. Drag the powerUp operation from the browser and drop it on the lifeline of the ig part, 
in line with the 'power up' description step. 

The message is automatically drawn to terminate at the p part. Because Modeler knows 
that the receiver must be a lifeline typed by the PowerSubsystem block, and there is 
only one such item currently on this diagram (the p part), it creates an operation call 
message going from the sender lifeline (the ig part where you clicked) to the receiver, as 
shown below. Where there is more than one potential target for the message, you will 
be presented with a list from which you need to select the correct item. 
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For many real-time systems the ability to define timing constraints is important. The 
Modeler sequence diagram provides a simple mechanism for doing this.  

80. Select the Timing Constraint toolbar button , click in 
the Description area just to the right of the 'detect key turn' 
step, and then move the pointer vertically down and click in 
line with the 'power up' step (see opposite). 

This will add a timing constraint between these two steps, 
and open an input box for you to enter some text – but do 
not do this yet. 

Instead click an empty area of the diagram to 
close the input box, select the timing constraint 
and open its properties. 

81. Enter the values shown opposite and click 
on the diagram. 

The timing constraint should now appear on 
your diagram as shown opposite. It can be 
lengthened and moved horizontally, as you 
wish. It can also, through the Item's property tab, be 
linked to a Constraint model item related to a 
constraint block. 

Finally, let's use a useful feature in Modeler sequence 
diagrams that allows you to show which lifelines are 
currently controlling the sequence. 

82. Right-click on the 'If ok' description step and select Indent, as 
opposite. 

The effect this has, other than indenting the selection construct, is to 'fill out' the 
corresponding section of the ig part lifeline (as highlighted below), creating what is 
called in SysML an 'ExecutionSpecification', indicating that it is the ig part that is making 
the test and sending the powerUp message. 
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In practice there would be other Start Vehicle activities that might be modeled here, but 
we have probably done enough for you to understand the mechanisms by which this 
diagram could be extended. Hopefully, we have also illustrated how behavior can be 
decomposed into levels of abstraction that often relate to the levels of abstraction 
defined in the structural BDD and IBD diagrams. For example, it would now be possible 
to drill down inside the PowerSubsystem to model how its parts dealt with the powerUp 
message. The final behavioral diagram for us to examine is the State Diagram. 

3.10 State Machine Diagrams 

Like use case and sequence diagrams, state machine diagrams are inherited from UML 
with few changes. Consequently much of the state modeling in Modeler's SysML 
implementation is the same as Modeler's UML state modeling. The intention in this 
section is not to provide detailed coverage of every single feature of state modeling in 
Modeler, but to show those key techniques that will enable you to build simple state 
machines from which you can develop further expertise should you need to do so. 

State modeling is closely aligned with interaction modeling, with sequence diagram 
messages often forming the basis for the events and actions depicted on the state 
diagrams. In both UML and SysML, state diagrams must be child diagrams of a parent 
entity, known as a state machine. 

In SysML, a state machine is a specification of the dynamic behavior of a block, being 
used to describe the state behavior of all instances of that block (for example, parts or 
ports typed by the block) over their lifetime. A state machine is represented 
diagrammatically in Modeler via a state diagram that is a child diagram of the state 
machine it represents. Thus a state diagram is an indirect child diagram of a block; a 
block owns a state machine which in turn owns a state diagram. This is established when 
the state machine and state diagram are created. 

In this tutorial we will build a state diagram for the BrakeSubsystem block. It will not be 
complete, or even particularly realistic, but it will be enough to show the key techniques 
and relationships with other diagrams. The diagram that follows is what we will 
gradually build toward. 
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1. To start, use the Window, Close All menu option to close all currently open diagrams.  

2. Expand the HSUVStructure package in the Packages browser (if necessary) to expose 
the BrakeSubsystem block. 

3. Right-click this block and select New ► SysML ► State Machine. Name the state 
machine 'BrakeSubsystem'. 

4. Right-click on this state machine and select New ► State Diagram. Name the diagram 
'ABS states'. 

By default, a round-cornered frame 
containing the name of the owning state 
machine is shown on the diagram. We want 
to display the frame in the standard SysML 
rectangular format showing the full name. 

5. Right-click the frame and select View 
Options. 

6. Select the Show As Frame, Show Diagram 
Name and Show Parent Item Type check 
boxes.  
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The result is as follows. Note that the Page reference property for the diagram has also 
been changed to 'stm' via the diagram's Properties dialog. 

 

7. Use the Initial State and Final State toolbar buttons  , to add these to the top left 
and top right of the diagram (as in the previous image). 

These would be typically used to define power on and power off (respectively). When 
power is applied, the brake subsystem initially goes into its inactive state. 

8. Select the Atomic State toolbar button , and click on the diagram. Name the state 
Inactive. 

Note how the Inactive state appears scoped to the BrakeSubsystem state machine in the 
browser.  

9. Repeat the last step to add the Faulty state to the right of Inactive. 

The Active state is a sequential composite state (it contains other sub-states within a 
single region). Entry is triggered by the arrival of the same activateABS message we 
modeled on the white box sequence diagram in the previous section. 

10. Select the Sequential State toolbar button , and click on the diagram below and to 
the right of the Inactive state. Name this state Active. 

11. Enlarge the Active state and use the Initial State and Atomic State buttons to create 
the Idle and Braking sub-states, with an initial state, inside the Active state. (Select the 
toolbar button and click inside the Active state.) 

12. Finally use the Junction State toolbar button  to create the choice state above 
Active. 

Note how the states are being added to the browser. You can expand Active to see its 
contained atomic states. 
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Now we will add the transitions that connect the states as shown in the previous 
diagram. This is very easy, made even more so by the use of the Ctrl key. 

13. Select the Transition toolbar button . Now hold the Ctrl key down on the keyboard, 
then simply click in the source and destination states to add each transition in turn, 
holding the Ctrl key the entire time. (If you add each transition separately, without 
using the Ctrl key, you need to press the Enter key or click on the diagram to ignore 
the pop-up box that appears for each transition.) 

14. Press the Esc key on your keyboard after you have added the final transition. 

You may need to separate the two transitions between Idle and Braking (they may be 
created overlapping each other), and don't forget that, like all link lines in Modeler, you 
can add waypoints either as you go (left click) or afterwards by dragging the link. 

You can also remove all waypoints by right-clicking the link and selecting Cancel 
Waypoints. You can remove a single waypoint by selecting the link, right-clicking on a 
specific waypoint and selecting Remove this Waypoint. 

You can also alter the line style to create straight rather than curved lines if you wish. 
Look in the Help system at the Working with diagrams/Customizing the presentation 
topic. Alternatively look at the Diagrams section in Part 1 of the Modeler Tutorial. 

The / characters on the transitions are acting as placeholders for the events and possible 
actions that we now need to add. However, those on the transitions from and to the 
initial and final states are not really necessary. We can easily remove them. 

15. Select all four of these transitions, by using the Ctrl key (standard Windows multi-
select). 

16. Right-click on any one of the selected transition lines and select View Options. 

17. Select the Transition entry, clear the 
Show Event Action Blocks check 
box, as opposite, and then click the 
OK button. 
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By now your diagram should be taking shape, and look similar to this. 

 

We need to think about the events that cause the other transitions to trigger. We 
already have in the model the event that causes the transition from Inactive to Active; it 
is the activateABS operation message shown on the 'Start Vehicle – white box' sequence 
diagram. Whenever this message is sent to a part typed by BrakeSubsystem, the 
response should be either to change state to Active - if the current state is Inactive, or to 
ignore it - if already Active or Faulty.  

18. Drag the activateABS operation from the browser, and drop it on the transition, as 
illustrated below. 
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Note that you can move the triggering event anywhere along or around the transition 
line.  

Operations of the block that owns the state machine that owns the state diagram are 
often used as transition triggers on the diagram, although, strictly, it is the arrival of a 
message requesting the execution of the operation that constitutes the trigger (note 
that the state diagram does not let you see the sender of the message – that's what you 
use sequence diagrams for). The brakeOn and brakeOff triggers between the Idle and 
Braking sub states are also operations, as is deactivateABS. We will need to create these 
now; in practice, they would probably already have been created in the model if we had 
used sequence diagrams as a way of refining the Brake use case. 

19. Right-click the BrakeSubsystem block in the Packages browser and select New ► 

SysML ► Operation to create deactivateABS. Repeat twice more to create brakeOn 
and then brakeOff operations. 

20. Drag these operations from the browser to the correct transitions (see the final 
diagram near the start of this section) and move the events to make them easily 
visible. 

Not all transition triggers are operation requests. ABSfault is an event model item. We 
have already met events as messages on sequence diagrams, which is typically where 
they are created and used. Events cannot be owned by blocks, only by packages, so we 
need to create the event from a package. In our case this might be the HSUVUseCases 
package or the HSUVStructure package; in reality some other package may be a more 
natural home for a set of events. 

Modeler allows you to create different event types (see the Help for details). We will 
create an opaque event, this being the most general. 

21. Right-click the HSUVStructure package in the browser, and select New ► SysML ► 

Behavior ► Event ► Opaque Event. Name it ABSfault. 

22. Drag this event from the browser and drop it on the transition from Active to Faulty 
(see the diagram that follows). 
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Your diagram should now look similar to this.  

 

This leaves just two transitions without triggers. These two transitions are controlled by 
guard conditions. There is a context menu option that will let you edit a guard condition. 
The alternative, and in some respects, better way to add a guard condition, is through 
the properties of the 'event action block' (EAB). This is the term used in Modeler for the 
set of information that can appear on a transition. It really includes three parts: a trigger 
(the event), an optional guard condition and an optional action. It is quite common to 
see guard conditions without events on transitions coming from a choice symbol. 

23. Select the transition going from 
the choice symbol (the 
diamond) to the Active state, 
open its properties and select 
the Options tab (as opposite). 

This will allow you to set any of the 
three components of the EAB. 
 
24. Simply enter the text 'checks 

ok' in the Guard Condition text 
box. Then close the properties. 

This text is added to the transition as a guard condition, enclosed in [ ]. 
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25. Now select the other transition coming from the choice symbol and use its properties 
pages to set the guard text to 'checks fail'. 

Guard conditions are always used with choices as a way of defining which outgoing 
transition to take; they can also be used on other transitions. For example, if we wanted 
to model that the deactivateABS transition is only valid when the vehicle is stationery, 
we can add a guard. 

26. Select the deactivateABS transition and open its Options property pages. 

27. Enter 'speed = 0' in the Guard Condition text box and click on the diagram. 

The third part of an EAB is an optional action. Many transitions will not need to specify 
an action to take when the triggering event occurs. But we have a couple on the diagram 
we are creating. We need to invoke ABS system checks when the ABS is activated (look 
back at the 'Start Vehicle – white box' sequence diagram), and we need to do something 
if a fault event occurs. For the first of these, we can create a 'runChecks' operation for 
the BrakeSubsystem block that is invoked when needed.  

28. Right-click on the BrakeSubsystem block in the browser and select New ► SysML ► 

Operation to create the runChecks operation. 

You cannot simply drag this operation to the activateABS transition, as you might think. 
If you do this, all that will happen is that you will replace activateABS with runChecks as 
the triggering event. You have to use the properties of the EAB. 

29. Select the activateABS transition and open its Options property page. 

30. Drag runChecks from the browser and drop it in the Action text box. 

 

The operation name appears in blue text in both the text box and on the diagram. This 
blue text is indicating that this is not just plain text, it is a model reference; if this 
operation name gets changed anywhere in the model (for example, in the browser), the 
text on the diagram will automatically get updated. Model references can be used 
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almost anywhere in Modeler where text can be entered. They are a good way to make 
your model more robust to change, as well as providing a quick way to examine the 
properties of the referenced item. 

The other action we identified earlier was to handle the fault event. What we might 
want to do here is set a warning indicator on the driver's display panel. Let's assume 
some other, yet to be defined, subsystem is responsible for this panel. All we can do 
now is model the need for the sending of an appropriate message. 

We would want this message to be sent either if the runChecks operation returned a fail 
or if some fault developed while in the Active state. Rather than add an action on both 
incoming transitions to the Faulty state, it is better to define an entry action for that 
state. To do this we need to create what UML calls an 'internal transition'. The name is 
misleading, no actual transition occurs, it is merely an event[guard]/action construct (an 
EAB) inside a state. When the event occurs while in that state, and if the guard (if there 
is one) is true, the specified action is carried out. 

To add an 'internal transition' we use the Event Action Block toolbar button .  

31. Select the Event Action Block toolbar button and click inside the Faulty state. 

32. When the in-line edit box appears, enter the text 'notify ABS fault'. 
Click on the diagram to see an EAB with the correct action (but no 
event as yet) appear inside the Faulty state (as opposite). 

To define the EAB as an Entry block we use its properties. 

33. Select the EAB, open its 
properties and select the 
Options tab. 

34. From the Trigger Type drop-
down list, select entry, as 
opposite.  

The keyword Entry is added 
before the / character (note the 
other options in the list for 
creating time or change triggers, 
or to create an Exit block within a 
state). Entry and Exit blocks can only be created inside states for the sole purpose of 
defining parent block behavior when that state is entered or exited. In this case the 
entry behavior is to send the notification message. 

To finish this section we will illustrate another link between behavior models. Activity 
modeling in SysML has strong support for continuous behavior, as we saw in the section 
on activity modeling, and as would be required for an ABS. We can invoke an activity as 
continuous behavior from within a state using a doActivity. 
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35. In the Packages browser pane, right-click on the HSUVActivities package and select 
New ► SysML ► Behavior ► Activity. Name the new activity 
applyABS. 

36. Now simply drag applyABS from the browser and drop it on the 
Braking sub-state within the Active composite state to create the 
doActivity, as opposite. 

Your diagram should be similar to the State Diagram shown on page 100. 

This completes the state diagram, and this section. You can close the state diagram. 

3.11 Relating Requirements to Other Model Items 

Having now covered all but the Package diagram (coming next), we are in the position 
where we can revisit requirements and relate them to relevant model items. We will 
show the means by which this can be done; we will also see how we can make these 
relationships clearly visible in the model from both the requirements end (that is, for a 
specific requirement, which model items are related to it, and what type of relationships 
are they) and the model item end (for a specific model item, which requirements are 
related to it, and how are they related). 

You may have noticed that sometimes an arrow appears to the right of a toolbar button, 
for example . Clicking the arrow to the right of the button 
makes related toolbar buttons available. For example, the toolbar 
buttons for creating refine, satisfy, trace and verify traceability 
relationships are grouped in this way. The trace relationship is 
inherited from UML, one of the reasons why the UML profile is 
added to the model with the SysML profile. However, its use is 
not recommended in SysML as its definition is rather loose. We 
will therefore not cover trace, although the mechanisms for its 
use are identical to those we will cover. 

1. Expand the HSUVRequirements package 
content in the Packages browser as 
opposite. 

2. Then double-click the HSUVRequirements 
diagram (highlighted opposite) to open 
the diagram. 

The first relationship we will create is a 
satisfy dependency, and we will do this on 
the open requirement diagram. We are going to model that the PowerSubsystem block 
satisfies the Power requirement. 

3. Expand the HSUVStructure package in the browser and drag the PowerSubsystem 
block on to the requirements diagram, below the Power requirement. 
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4. Now select the Satisfy dependency toolbar button, click 
first on the PowerSubsystem block, then on the Power 
requirement. 

This will create the required relationship, as opposite. If 
your arrow points the wrong way, undo and repeat the last 
step. 

The relationship is established in the model and is visible 
from several viewpoints. 

5. Open the property pages for 
the PowerSubsystem block 
and select the (newly created) 
RequirementRelated tab, as 
opposite. 

This tab only exists because you 
created the satisfy relationship. 
However, as you can see it is used 
to record any type of 
requirement relationship. 
 
6. Now open the property pages for the Power requirement and select the Requirement 

tab. 

The relationship is visible here also. 

7. Right-click the PowerSubsystem block, either on the diagram or in the browser, and 
select Links ► Traceability ► Satisfies. 

This opens the Links Editor dialog, where again the relationship is visible. 
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The Links Editor is a powerful facility, which as well as providing visibility of existing 
links, also allows you to make new ones or break existing ones. You might want to try 
doing this and note the effect on item properties and the currently open diagram. Use 
Undo to restore the model to its current state. 

The second relationship we will create is the verify dependency, and again, we will do 
this on the requirement diagram, but in a completely different way. A verify dependency 
can only be created between a requirement and a model item that has had the 
«Testcase» stereotype applied. « Testcase » can only be applied to certain model item 
types: certain behavioral diagrams or behavioral items such as operations or activities, 
which can own diagrams. You need to decide which items in your model constitute test 
cases and apply the stereotype before you can create the verify dependency.  

We will apply the « Testcase » stereotype to the AccelerateAct activity created earlier 
and then show that this activity verifies the Acceleration requirement. 

8. Expand the HybridSUV block in the Packages 
browser, to see the AccelerateAct activity, as 
opposite. 

9. Right-click AccelerateAct, and select Applied 
Stereotypes ►  Testcase. 

This applies the Testcase stereotype and the 
Property Pages of the activity will now 
show a Testcase tab (more shortly). 

10. Now right-click the AccelerateAct 
activity in the browser and select 
Start Link. 

11. Then right-click the Acceleration 
requirement on the diagram and 
select End Link to open the Quick 
Link dialog. 

12. Use the drop-down list control to 
select the 'verifies' relationship (as 
shown opposite) and click the OK 
button. 

The relationship is now established in the model, although there is no visibility of it on 
the diagram. 

13. Right-click the Acceleration requirement on the diagram and select Add ► Callout 
Note.  
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14. Expand the Roles folder, and then 
select the VerifiedBy check box.  

This will add a note indicating the 
verification relationship. 

 

This relationship is also visible in the 
model through properties and the Links 
Editor, and AccelerateAct now also has a 
RequirementRelated property tab. 

Before we leave the requirement diagram to look at these relationships from the model 
item end, we should briefly consider two further toolbar buttons: Problem and 

Rationale ( ).  

Although these can be used on other diagrams, they are often found on requirements 
diagrams. 

15. Select the Problem button and click on the diagram, close to the Acceleration 
requirement and the verifiedBy note (we have moved items around on the following 
image). 

16. Enter the text 'need to specify test conditions' in the pop up text box, and press the 
Enter key. 

A «Problem» note is created on the diagram, as 
opposite. 

17. Now select the Note Link toolbar button , click on the «Problem» note, then on the 
Acceleration requirement. 

This creates a link between the 
problem and the item it relates to (as 
opposite) which persists wherever 
you move the linked items. 

In addition the Problem appears as a model item in the 
browser, scoped to the Acceleration requirement, as 
shown opposite. 

«requirement»

Acceleration

«Problem»

need to specify test conditions

«requirement»

Acceleration

«Problem»

need to specify test conditions

«Problem»

need to specify test conditions

«Problem»

need to specify test conditions
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If you wish you can add a further note link from the «Problem» note to the verifiedBy 
note, but this will not affect its scoping in the model. 

Exactly the same approach is used with Rationale. You can, if you wish, create and link 
the Rationale note shown on the final version of the requirement diagram as follows. If 
you do this, you will find the Rationale as a model item scoped within the 
PowerSubsystem block. 

 

It is clear that the relationship between the Power requirement and the 
PowerSubsystem block is now held in the model. We can therefore see this from the 
PowerSubsystem end. 

18. Expand the HSUVStructure package and double-click the HSUVStructure BDD shown 
near the foot of the package content to open the diagram (see the following diagram, 
and note that we have hidden all compartments for clarity). 

19. Right-click the PowerSubsystem block on this diagram and select Add ► Callout Note. 
Then select satisfies under Roles. 

 

req [Package] HSUVRequirements [1]

«block»

PowerSubsystem

«requirement»

Performance

«requirement»

Acceleration

«requirement»

Power

verifiedBy
«Activity» AccelerateAct (out drivePower, out transModeCmd)

verifiedBy
«Activity» AccelerateAct (out drivePower, out transModeCmd)

«satisfy»

«deriveReqt»

«problem»

need to specify test conditions

«rationale»

Contains both power sources



Relating Requirements to Other Model Items  - Ports, Interfaces and Item Flows 

113 

This adds a note, linked to PowerSubsystem, stating its relationship with the Power 
requirement. View Options can also be used to change this note to a box, if preferred. 
You may need to move things around slightly on this diagram to make it look like this. 

 

Not only can we see related requirements on other diagrams, we can create such 
relationships. 

20. Expand the HSUVUseCases package in the browser and double-click the Operational 
Use Cases diagram at the bottom of the package content to open the diagram. 

21. Drag the Acceleration requirement from the browser and drop it on the use case 
diagram, as shown in the illustration that follows.  

bdd [Package] HSUVStructure [1]

«block»

HybridSUV

«block»

BrakeSubsystem

«block»

ChassisSubsystem

«block»

PowerSubsystem

«block»

BrakePedal «constraint»

constraintParameters
«ConstraintParameter» demand : Real
«ConstraintParameter» flowrate : Real
«ConstraintParameter» pressure : Real

constraints
{flowrate=pressure(4*demand)}

FlowConstraint

bk p
c

bkp

bkp fc

satisfies
«Requirement» Power

satisfies
«Requirement» Power
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22. Select the Refine dependency toolbar button , click first on the Accelerate use case 
(on the diagram), then on the 
Acceleration requirement. 

This will create and show the 
dependency relationship on this 
diagram, as opposite.  

23. Now return to the requirement diagram 
(HSUVRequirements), right-click on the Acceleration 
requirement on this diagram, and select Show/Hide 
Compartments and select refindedBy under the Roles 
option, to show the compartment as opposite. 

There are a number of requirements reporting mechanisms provided by Modeler. 
Requirements tables can be created and configured (as covered in section 3.3) to show 
requirements relationships. You can also use the Report context menu option. 

24. Right-click on the HSUVRequirements package in the Packages browser, and select 
Report ► Unsatisfied Requirements. 

This opens the Results pane and lists any unsatisfied requirements in the 
HSUVRequirements package. You will also see a number of other requirements related 
options from the Report context menu. 

3.12 The Package Diagram 

The package diagram is typically used to capture the structure of, and dependencies 
between, packages, but can also be used to show views and viewpoints (if you are not 
familiar with these, you can find more information in the SysML specification). As with 
other sections of this tutorial, the intention here is not to show all features of Modeler's 
package diagram implementation, but enough to enable you to use it effectively. To do 

«requirement»

refinedBy
«Use Case» Accelerate

Acceleration
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this we will firstly create a simple diagram to show our model structure and then create 
a view and show the items that might relate to this view. 

The package diagram showing model structure is typically held within the top-level 
model package: HSUVModel in our case.  

1. Collapse the packages in the Packages browser pane as 
opposite, to see the package structure within HSUVModel 
(note we have not shown most of the items in the 
HSUVStructure package for space reasons). 

2. Right-click the top level HSUVModel package and select 
New ► Diagram ► SysML ► Package Diagram. Name the 
diagram '[Package] HSUVModel [Structure]'. 

3. Drag each of the four packages within HSUVModel from the browser to the diagram, 
positioned approximately as shown here. 

 

The HSUVStructure package contains two sub-packages, HSUVFlowSpecs and 
HSUVInterfaces. 

4. Right-click on the HSUVStructure package name and select Populate ► Nodes ► 
Packages. 

pkg [Package] HSUVModel [Structure]

HSUVActivities HSUVRequirements HSUVStructure

HSUVUseCases
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5. Move the two nested packages as shown below. 

 

As well as showing the structure of the HSUVModel packages, we can also show package 
dependencies on this diagram. A dependency exists when something in one package 
references something in another package and identifies a need to be careful regarding 
change in the dependee package. An example in our model is the dependency between 
the HSUVUseCases package and the HSUVStructure package that arises because the 
child sequence diagrams in the HSUVUseCases package contain items scoped to the 
HSUVStructure package. It is useful to capture this dependency more visibly in the 
model, on the package diagram. 

6. Click the arrow on the right of the Abstraction toolbar 

button  and from the drop-down menu (see opposite) 
select Dependency. 

7. Click first on the HSUVUseCases package (click on the 
name tab or the boundary – you are not selecting the 
package if you click inside it somewhere), then on the 
HSUVStructure package name tab to create the dependency 
relationship in the model and show it on the diagram. 

pkg [Package] HSUVModel [Structure]

HSUVActivities HSUVRequirements HSUVStructure

HSUVFlowSpecs

HSUVInterfaces

HSUVUseCases
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Your diagram should now look similar to this. 

 

There are other dependencies that could be added to this diagram, but we will move on 
to look at how the package diagram can also be used to model views and viewpoints. 

To start we will create a package in the model to hold this package diagram and the 
elements we create on it (and in doing so, we should of course update the above 
diagram). 

8. Right-click the HSUVModel package and select New ► Package. Name it HSUVViews. 

9. Now right-click the HSUVViews package and select New ► Diagram ► SysML ► 

Package Diagram. Give the diagram the name '[Package] HSUVViews [Operational 
View]'. 

As you will see (from the tool-tips) there are package diagram toolbar buttons for 
creating a view and a viewpoint as well as the relationships that connect them and other 
items. 

10. Select the View toolbar button , and click on the diagram. Name the view 
OperationalView. 

11. Now select the Viewpoint toolbar button , and click on the diagram next to the 
OperationalView. Name the viewpoint OperationalViewpoint. 

Note how both the view and viewpoint appear in the browser, along with the package 
diagram, within the HSUVViews package. 

pkg [Package] HSUVModel [Structure]

HSUVActivities HSUVRequirements HSUVStructure

HSUVFlowSpecs

HSUVInterfaces

HSUVUseCases

«dependency»
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12. Select the 
OperationalViewpoint, either 
on the diagram or in the 
browser, open its properties 
and select the Viewpoint tab. 

The tags you see (opposite) 
allow you to set the required 
data for the viewpoint. You do 
this by simply clicking in the Tag 
Value column for the required 
tag, and entering whatever text 
you want. 

13. Now select the Conform toolbar button , click first on OperationalView, then on 
OperationalViewpoint, to create a «conform» relationship between them. 

 

The final use we will show for the package diagram is to model the relationships 
between the HSUVModel, the SysML Profile and its contained SI Definitions package, 
and the UML Profile. We will create this diagram and the diagram elements in a new 
package called Context. 

14. Right-click on the HSUVModel package to create the Context package (New ► 
Package). 

15. Now right-click on the Context package to create a new package diagram called 
[Package] Context. 

16. Select the Model toolbar button , click on the 
diagram and name this new element HSUV Model. 

The element appears as opposite. This is an abstract 
representation of the actual HSUVModel package (note 
additional space character in the name of the diagram 
element). 

17. Now use the Profile toolbar button  to create two more diagram elements named 
SysML Profile and UML Profile. 

These too are abstract representations of the actual profile packages in the model. 
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18. Enlarge the SysML Profile element on the diagram, select the Model Library toolbar 

button  and click inside the SysML Profile element to create a fourth diagram 
element named SI Definitions.  

Again, this is an abstract representation of the actual SI Definitions package within the 
SysML Profile. Note the scoping of these diagram elements in the Packages browser. 

19. Arrange the diagram elements as shown here. 

 

We can now model the relationships between these elements. We want to show that: 

 the HSUV Model applies both profiles; 

 the HSUV Model imports the SI Definitions; 

 the SysML Profile is dependent on the UML Profile. 

It is beyond the scope of this tutorial to explain these relationships, although most are 
obvious. You can refer to the Help system or the SysML specification for further details. 

All of these relationships are directional, so in carrying out the following activities, it is 
important to get the mouse click order correct: you must click first on the 'from' 
element, then on the 'to' element. If you get the direction wrong, undo and re-create. 
You will find it easiest to select elements by clicking in their name compartment. 
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Remember also that you can add or remove waypoints to improve the readability or 
presentation of the links on the diagram. You can also move or resize the diagram 
elements. 

We will create the diagram relationships in the order defined above.   

20. Use the Profile Application toolbar button  to create an «apply» relationship from 
HSUV Model to SysML Profile. 

21. Use the same toolbar button to create the relationship from HSUV Model to UML 
Profile. 

22. Use the Import toolbar button  from the dependency 
drop-down menu (opposite) to create the «import» 
relationship from HSUV Model to SI Definitions. 

23. Use the Dependency toolbar button  from the dependency 
drop-down menu to create a dependency relationship from 
SysML Profile to UML Profile. 

Note: The icon shown on the button that displays the 
dependency drop-down menu changes to show the last item 
used. Your button might be displaying a different icon to that 
shown above. 

The diagram should now look as follows. 

 

This completes this section and the tutorial. You can now close the model. 
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4 Summary 

As you have now seen, the OMG SysML provides a broad variety of model data and 
diagrams to describe complex systems.: This tutorial took you through a step-by-step 
introduction to SysML using PTC Integrity Modeler, its key SysML diagrams, their 
toolbars and context menus.: The example included Block Definition Diagrams, 
Requirements Diagrams, and many others. The tutorial also covered system 
requirements, system structure, system behavior, system parametric views and their 
relationships. In addition to editing a SysML model, we also looked at model quality, and 
verification with tools such as PTC Integrity Modeler Reviewer and model validation with 
PTC Integrity Modeler SySim. 

This was a very simple example and the successful implementation of MBSE not only 
requires a well suited language, and a proper implementation of this language in a tool, 
but also the definition and rollout of an appropriate model-based systems engineering 
process, such the PTC Integrity Process Perspective. 

Following this tutorial we would recommend that you take a look at the Model-based 
Product Line Engineering tutorial, which extends MBSE in Asset-based Modular Design 
and Model-based Product Line Engineering, which further extend the benefits of MBSE. 
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5 Appendix: The SysML Profile 

Modeler's SysML implementation is based on a supplied SysML profile. This profile 
consists of a set of stereotypes and tags, augmented by a set of scripts. It is the 
application of this profile to a Modeler model that converts the model from a UML 
model into a SysML one. Extended properties for these stereotypes and tags provide the 
UI and functional customization of the 'standard' Modeler UML interface. The Tutorial 
will explain the SysML profile in a little more detail and show how to apply it to convert 
Modeler's UML interface into the SysML one. 

The SysML profile is contained within the SysML Profile package (it has a customized 
package icon). We will examine some of the concepts behind this profile later in this 
section of the tutorial and we will see how this it used in section 2. There is also a UML 
Profile package (also with a customized icon) – remember SysML reuses some of UML, 
including some standard UML stereotypes that are in this package. Also within the 
Profiles package you will see a symbol style item called Model Custom Styles. This 
defines customized presentation options for certain item types within this model. You 
can see which item types through the Model Item Types drop down selection on the 
Items property page for the symbol style item. You can also see details of the 
presentation customization through the Edit button on the Style property page. 

The other two top level packages, ModelingDomain and HSUVModel (with the standard 
package icon), contain the HSUV model information. You can examine these – although 
much of the information is also accessible through the other panes.  

Another important browser pane within Modeler is 
the Requirements browser pane. 

1. Select the Requirements browser pane and 
expand  the requirement folder as shown 
opposite.  

This folder's contained list of all requirements in the 
model is generated because each requirement is a 
model item that is stereotyped by the 
«requirement» stereotype.  

This principle is used to provide the lists of items for all folders within the five SysML 
browser panes. 

2. In the Dictionary pane, expand the UML folder, expand the Stereotype folder, and then 
select the Requirement stereotype. 
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3. In its Property Pages, click the Directly-Stereotyped Options tab. 

 

The Browsable check box you see here is used to define 'Requirement' as a stereotype 
that is shown as a folder in the Requirements (browser) pane, which is why we see it as 
a folder.  

4. Now select the Options tab. 

 

The selected check boxes on this page, together with properties defined on other tabs, 
will result in UI and behavior changes for any item to which this stereotype is applied. 
One such item is the 'Acceleration' requirement 

5. In the Requirement panes, expand the 'Requirements' folder, open the Property Pages 
for the Acceleration requirement and select the General tab. 

Acceleration has had the Requirement stereotype applied, automatically at its creation, 
with the following results: 

 It has a requirement type (the use of Override Type Name check box, in the 
preceding image). 

 It has a profile-defined requirement icon (similar to that in the browser pane). 

 It has a set of requirement properties, seen through its Requirement tab. 

6. Select the Requirement tab on the Acceleration property pages. 
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Here you'll see the set of tags linked to all requirements (through the Requirement 
stereotype).  

7. Now expand the Acceleration requirement in the browser pane. 

Here you will a subset of the tags visible through the property pages. Why just a subset? 

8. In the Dictionary pane, expand the UML folder, expand the Tag Definitions folder, and 
then select the derived stereotype. 

9. In its Property Pages, click the Usage tab. 

You will see that this tag definition has its Browsable check box selected, and therefore 
is visible in the browser pane. The additional tags that showed up in the Requirements 
tab of the Acceleration requirement's property pages had this check box cleared, and so 
are not visible in the browser pane. 

The other thing you will have noticed on the Requirement tab of the Property Pages of 
the Acceleration requirement is that most of the tag values appear grayed-out. These 
are derived values, dynamically updated as you open the property page from current 
model information. What does the updating is a script defined as a property of the tag. 

10. With the 'derived' tag definition still selected in the browser pane, open the Derivation 
Script tab of its properties. 

You'll see the script being used to update this property. Scripts are a key aspect of an 
ergonomic profile and are also used by SysML profile stereotypes. A script is a piece of 
code that gets executed when an event occurs on a stereotyped item, such as the 
selection of a context menu option or a double-click. 

The scripts and properties of the stereotypes and tags that constitute the SysML profile 
have been preset by PTC to create a SysML modeling environment consistent with that 
defined by SysML. If you change any of these scripts or properties, you are likely to 
adversely affect that environment. You should not, therefore, attempt to change any of 
these scripts or properties directly in the SysML Profile.  

However, you can customize a SysML Profile in the following ways:  

 Through Tag Definitions, you can extend properties and linking capabilities 

 Through aliases, you can define aliases to use for SysML items and diagrams.  

 Through lightweight extensions, you can create new item and link types that are 
based on SysML item and link types. 

For more information about customizing a SysML Profile, see the Customizing the SysML 
Profile topic in the Modeler Help.
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